Windows Media Encoder

Program Windows Media® Encoder Seria 9 firmy Microsoft® to wydajne narzędzie do konwersji emitowanego na żywo oraz nagranego audio i wideo do plików Windows Media lub strumieni. Poniższe sekcje zawierają najważniejsze informacje o procesie kodowania i czynnościach związanych z wykorzystaniem programu Windows Media Encoder.

  • Wprowadzenie. Wyjaśnia sposób konfiguracji sesji kodowania w kilku prostych krokach z wykorzystaniem funkcji szybkiego uruchamiania lub Kreatora nowej sesji. Zawiera także opis programu Windows Media Encoder, wymagania systemowe i informacje o różnych okienkach tworzących interfejs użytkownika.
  • Pojęcia. Zawiera informacje ogólne na temat pracy z koderem.
  • Konfigurowanie źródeł. Zawiera informacje o źródłach wejściowych obsługiwanych przez koder, w tym o plikach, urządzeniach, ekranach i poleceniach skryptu.
  • Dostosowywanie sesji. Zawiera opis konfigurowania sesji kodowania lub dostosowania istniejącej sesji w celu spełnienia wymagań użytkownika.
  • Opcje wyjściowe. Zawiera opis opcji wyjścia dostępnych dla użytkownika podczas kodowania: kodowanie do pliku lub emisja zdarzenia na żywo (z wykorzystaniem dystrybucji wypychania lub ściągania).
  • Opcje konfiguracji systemu. Zawiera opis opcji konfiguracji systemu, w tym zabezpieczeń komputera kodującego, uruchamiania wielu wystąpień kodera na komputerze, kodowania wsadowego i czynności jakie można wykonać, aby uzyskać optymalną wydajność systemu.
  • Często zadawane pytania i rozwiązywanie problemów. Zawiera łącze do witryny sieci Web firmy Microsoft, gdzie można znaleźć sugestie dotyczące rozwiązywania problemów, które można napotkać podczas korzystania z kodera.
  • Ułatwienia dostępu dla osób niepełnosprawnych. Zawiera informacje o funkcjach, produktach i usługach, które ułatwiają osobom niepełnosprawnym korzystanie z programu Windows Media Encoder.
  • Słownik. Zawiera definicje i terminy dotyczące kodera.
© 2000-2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.


Wprowadzenie

Ta część zawiera informacje dotyczące konfigurowania sesji kodowania w kilku krokach przy użyciu szybkiego uruchamiania lub Kreatora nowej sesji. Zawiera również informacje o nowościach w programie Windows Media Encoder, wymaganiach funkcji, wymaganiach dotyczących sprzętu i oprogramowania. Opisuje także różne panele, z których składa się interfejs kodera.

Tematy pokrewne

  • Windows Media Encoder
  • Kodowanie z użyciem szybkiego uruchamiania lub Kreatora nowej sesji
  • Co nowego
  • Wymagania funkcji
  • Wymagania dotyczące sprzętu i oprogramowania
  • Informacje o widokach kodera
  • Informacje o narzędziach kodera
  • Konwencje stosowane w dokumentacji


Kodowanie za pomocą funkcji szybkiego uruchamiania lub Kreatora nowej sesji

Przed zakodowaniem zawartości należy skonfigurować sesję kodowania. Najprostszym sposobem na wykonanie tej czynności jest użycie funkcji szybkiego uruchamiania lub Kreatora nowej sesji. Funkcje szybkiego uruchamiania to pliki sesji, które zawiera program Windows Media Encoder. Są one zaprojektowane do obsługi popularnych scenariuszy kodowania i zawierają większość ustawień potrzebnych do rozpoczęcia natychmiastowego kodowania. Wszystko, co trzeba zrobić, to podać dane o zawartości, takie jak nazwy plików czy nazwy serwerów. Można użyć również Kreatora nowej sesji, który przeprowadza użytkownika przez kroki niezbędne do skonfigurowania czterech najpopularniejszych scenariuszy kodowania.

Funkcje szybkiego uruchamiania i kreator są dostępne w oknie dialogowym Nowa sesja (jeśli są włączone), które jest wyświetlane przy pierwszym otwarciu kodera, lub do którego można uzyskać dostęp z głównego okna kodera, klikając na pasku narzędzi przycisk Nowa sesja.

Po skonfigurowaniu sesji kodowania można rozpocząć kodowanie zawartości. Jeżeli użytkownik zamierza ponownie uruchomić tę samą sesję, można zapisać ustawienia w pliku sesji i użyć sesji w późniejszym czasie. Pliki sesji są zapisywane z rozszerzeniem .wme.

Tematy pokrewne

  • Wprowadzenie
  • Korzystanie z funkcji szybkiego uruchamiania do kodowania
  • Korzystanie z Kreatora nowej sesji do kodowania
  • Sesje – informacje
  • Otwieranie istniejącej sesji
  • Zapisywanie sesji


Korzystanie z funkcji szybkiego uruchamiania do kodowania

Funkcje szybkiego uruchamiania to pliki sesji dołączone do programu Windows Media Encoder. Są przeznaczone do obsługi typowych scenariuszy kodowania i zawierają już większość ustawień potrzebnych do natychmiastowego rozpoczęcia kodowania. Należy podać jedynie informacje związane z zawartością, takie jak nazwy plików lub nazwy serwerów.

Dostępne funkcje szybkiego uruchamiania obejmują:

  • Przechwytywanie zawartości na żywo do odtwarzania lokalnego. Przechwytuje zawartość na żywo z urządzeń audio lub wideo i koduje ją do pliku. Zawartość można dystrybuować, dzięki czemu użytkownicy mogą pobierać ją i odtwarzać lokalnie.
  • Przechwytywanie zawartości na żywo w celu przesyłania strumieniowego. Przechwytuje zawartość na żywo z urządzeń audio lub wideo i koduje ją do pliku pakietu Windows Media.
  • Konwertowanie zawartości filmowej do wideo. Konwertuje opartą na plikach zawartość pochodzącą z filmu do formatu Windows Media, dzięki czemu użytkownicy mogą pobierać ją i odtwarzać lokalnie.
  • Emisję spotkania firmowego. Wypycha strumień do punktu publikacji na serwerze z uruchomionym programem Microsoft Windows Media Services.

Jeśli użytkownik posiada sesję, której chce często używać, można dodać ją do listy funkcji szybkiego uruchamiania.

obrazek „Uwaga” Uwaga

  • Aby uruchomić funkcję szybkiego uruchamiania, należy na pasku narzędzi kliknąć przycisk Nowa sesja, kliknąć kartę Szybkie uruchamianie, a następnie kliknąć wybraną funkcję.

Tematy pokrewne

  • Kodowanie za pomocą funkcji szybkiego uruchamiania lub Kreatora nowej sesji
  • Tworzenie niestandardowej funkcji szybkiego uruchamiania
  • Kodowanie CBR lub VBR – informacje


Korzystanie z Kreatora nowej sesji do kodowania

Kreator nowej sesji przeprowadza użytkownika przez etapy konieczne do skonfigurowania czterech najczęściej występujących scenariuszy kodowania. Scenariusze te wymieniono poniżej:

  • Emisja zdarzenia na żywo. Umożliwia przechwytywanie audio lub wideo z urządzeń zainstalowanych w komputerze, a następnie emisję zawartości na żywo, czy to przez wypychanie strumienia na serwer z uruchomionym programem Microsoft Windows Media Services, czy przez zezwolenie serwerom i odtwarzaczom Windows Media na ściąganie strumienia bezpośrednio z kodera.
  • Przechwytywanie audio i wideo. Umożliwia przechwytywanie audio lub wideo z urządzeń zainstalowanych w komputerze, a następnie przekonwertowanie przechwyconej zawartości na plik pakietu Windows Media w celu późniejszej dystrybucji.
  • Konwertowanie pliku. Umożliwia przekonwertowanie plików wideo do formatu pakietu Windows Media Format w celu późniejszej dystrybucji.
  • Przechwytywanie ekranu. Umożliwia przechwytywanie obrazów z ekranu komputera, w tym ruchów wskaźnika myszy. Istnieje możliwość przechwycenia całego ekranu, wybranego regionu lub określonego okna.

Aby zmienić właściwości sesji, można ponownie uruchomić Kreatora nowej sesji lub skorzystać z panelu Właściwości w celu edycji ustawień. Jeżeli sesja ma być używana ponownie, należy zapisać wprowadzone ustawienia w pliku sesji.

obrazek „Uwaga” Uwaga

  • Aby otworzyć Kreatora nowej sesji, należy na pasku narzędzi kliknąć przycisk Nowa sesja, a następnie kliknąć jednego z czterech kreatorów. Opcja Sesja niestandardowa służy do konfigurowania niestandardowej sesji kodowania.

Tematy pokrewne

  • Kodowanie za pomocą funkcji szybkiego uruchamiania lub Kreatora nowej sesji
  • Zapisywanie sesji


Co nowego

Program Windows Media Encoder Seria 9 zawiera ulepszenia, które są zarówno wydajne, jak i łatwe w użyciu. W tej sekcji podsumowano zmiany dokonane w koderze dla tej wersji.

  • Wybór wielu scenariuszy kodowania został ułatwiony dzięki dodatkowym formatom docelowym. Dostępne są również cztery opcje szybkiego startu, które pomagają rozpocząć natychmiastowe kodowanie. Każda z opcji szybkiego startu jest zaprojektowana z myślą o popularnym scenariuszu kodowania.
  • Nowe kodery-dekodery charakteryzują się zwiększoną jakością zakodowanej zawartości audio i wideo.
  • Obsługa przeciągania do okna kodera plików źródłowych i plików sesji ułatwia szybkie rozpoczęcie kodowania.
  • Nowe tryby kodowania ze stałą szybkością transmisji bitów (CBR) i ze zmienną szybkością transmisji bitów (VBR) umożliwiają dostosowanie ustawień w zależności od wybranego scenariusza kodowania.
  • Funkcja sterowania urządzeniami umożliwia uruchamianie urządzeń bezpośrednio z kodera. (Urządzenie musi być podłączone do cyfrowego portu wideo IEEE 1394; można też użyć magnetowidu, który obsługuje protokół Sony RS422, podłączonego do portu COM.) Można również użyć wbudowanej listy decyzji dotyczących edycji (EDL) w celu ułożenia i zakodowania klipów w dowolnym porządku.
  • Kodowanie wielokanałowe audio jest dostępne przez kodery-dekodery Windows Media Audio 9 Professional i Windows Media Audio 9 Lossless.
  • Zarządzanie prawami dostępu do zawartości nośników cyfrowych (DRM) jest dostępne w celu ochrony zakodowanej zawartości.
  • Nowa funkcja dystrybucji poprzez wypychanie pomaga nawiązać połączenie z serwerem Windows Media z kodera.
  • Obsługa języka umożliwia określenie języka zawartości.
  • Dostępne są cztery programy narzędziowe oferujące dodatkowe funkcje, takie jak tworzenie profili niestandardowych, dzielenie i łączenie strumieni w różnych plikach oraz indeksowanie plików po zakodowaniu.
  • Tymczasowe przechowywanie zawartości na dysku twardym pomaga zapewnić jakość kodowanej zawartości.
  • Obsługa dodatków transformacji umożliwia deweloperom pisanie dodatków modyfikujących zawartość audio i wideo, które mogą zostać wykorzystane w celu dodania efektów specjalnych podczas kodowania.
  • Wprowadzona została obsługa pobierania źródła z dodatkowych formatów plików.
  • Obsługa wyjścia o niekwadratowych pikselach pomaga zakodować zawartość w formacie letterbox z zachowaniem proporcji oryginalnego wideo.
  • Wyszukiwanie na poziomie klatek może zostać zaimplementowane poprzez utworzenie lub zachowanie kodów czasowych dla niektórych źródeł.
  • Zawartość o wielu prędkościach transmisji bitów (MBR) obsługuje teraz wiele formatów audio i rozdzielczości wideo.
  • Obsługa funkcji Plug and Play w systemie Microsoft Windows® XP umożliwia automatyczne wykrywanie urządzeń przez koder, gdy jest on uruchomiony. Ponadto koder jest automatycznie uruchamiany, gdy nowe urządzenie zostanie podłączone do komputera.

Tematy pokrewne

  • Wprowadzenie
  • Korzystanie z funkcji szybkiego uruchamiania do kodowania
  • Opis koderów-dekoderów
  • Kodowanie CBR lub VBR – informacje
  • Pobieranie źródła z urządzeń
  • Pobieranie źródła z wielokanałowych plików audio
  • Korzystanie z zarządzania prawami cyfrowymi do ochrony zawartości
  • Emisja zawartości na żywo
  • Informacje o programach narzędziowych kodera


Wymagania funkcji

W poniższej tabeli znajdują się informacje dotyczące funkcji programu Windows Media Encoder, które mają określone wymagania względem programu Microsoft Windows Media Player, systemu operacyjnego lub kodera-dekodera.

Funkcja | Program Windows Media Player |  |  | Systemy operacyjne | Kodery-dekodery
 | 6.4 | 7.1/Windows XP | z serii 9 |  |
Wideo wyjściowe z przeplotem |  |  | X | Microsoft Windows XP | Windows Media Video 9
Wyjście o niekwadratowych pikselach |  |  | X |  |
Zawartość MBR o wielu rozdzielczościach |  |  | X |  |
Audio MBR |  |  | X |  |
Obsługa DRM | X | X | X |  |
Audio wielokanałowe |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional lub Windows Media Audio 9 Lossless
Dźwięk o wysokiej rozdzielczości (24-bit, 96 kHz)1 |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
Kontrola zakresu dynamiki |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
Kodowanie CBR (jedno- lub dwuprzebiegowe) | X | X | X |  | Patrz następna tabela
Kodowanie VBR w oparciu o jakość |  | X | X |  | Patrz następna tabela
Kodowanie VBR w oparciu o szybkość transmisji bitów |  | X | X |  | Patrz następna tabela
Kodowanie VBR w oparciu o szczytową szybkość transmisji bitów |  | X | X |  | Patrz następna tabela

1 Starsze odtwarzacze lub systemy operacyjne będą renderować zawartość 16-bitową o częstotliwości 48 kHz

Należy zauważyć, że zawartość zakodowana za pomocą koderów-dekoderów Windows Media Audio i Video serii 9 (za wyjątkiem kodera-dekodera Windows Media Audio 9) nie jest obsługiwana przez program Windows Media Player w wersji 6.4. W przypadku programu Windows Media Player w wersji 7.1 i Windows Media Player dla Windows XP, aby odtwarzać zawartość zakodowaną za pomocą dowolnego z tych koderów-dekoderów, należy pobrać koder-dekoder. Podczas odtwarzania zawartości zakodowanej ze zmienną szybkością transmisji bitów za pomocą kodera-dekodera Windows Media Audio 9 w programie Windows Media Player w wersji 6.4 mogą występować krótkotrwałe zakłócenia lub wyciszenia. W przypadku programów Windows Media Player w wersji 7.1 i Windows Media Player dla Windows XP nie trzeba pobierać kodera-dekodera, aby odtwarzać zawartość zakodowaną za pomocą kodera-dekodera Windows Media Audio 9.

W poniższej tabeli znajduje się lista obsługiwanych metod kodowania dla koderów-dekoderów dołączonych do kodera.

Koder-dekoder | Jednoprzebiegowe kodowanie CBR | Dwuprzebiegowe kodowanie CBR | Kodowanie VBR w oparciu o jakość | Kodowanie VBR w oparciu o szybkość transmisji bitów | Kodowanie VBR w oparciu o szczytową szybkość transmisji bitów
Windows Media Audio 9 Professional | Tak | Tak | Tak | Tak | Tak
Windows Media Audio 9 Lossless | Nie | Nie | Tak | Nie | Nie
Windows Media Audio 9 | Tak | Tak | Tak1 | Tak1 | Tak1
Windows Media Audio 9 Voice | Tak | Nie | Nie | Nie | Nie
Windows Media Video 9 | Tak | Tak | Tak | Tak | Tak
Windows Media Video 8.1 | Tak | Tak | Tak | Tak | Tak
Windows Media Video 7 | Tak | Tak | Tak | Tak | Tak
Windows Media Video 9 Screen | Tak | Nie | Tak | Nie | Nie

1 Podczas odtwarzania za pomocą programu Windows Media Player w wersji 6.4 mogą występować krótkotrwałe zakłócenia lub wyciszenia.

Tematy pokrewne

  • Wprowadzenie
  • Kodowanie CBR lub VBR – informacje


Wymagania dotyczące sprzętu i oprogramowania

Aktualne informacje o wymaganiach dotyczących sprzętu lub oprogramowania można znaleźć w kilku witrynach sieci Web:

  • Informacje na temat wymagań systemowych znajdują się na stronie z wymaganiami systemowymi w witrynie sieci Web firmy Microsoft.
  • Lista obsługiwanych kart do przechwytywania audio i wideo znajduje się na stronie dostawców sprzętu w witrynie sieci Web firmy Microsoft.
  • Lista obsługiwanych urządzeń przenośnych znajduje się na stronie urządzeń przenośnych w witrynie sieci Web firmy Microsoft.

Tematy pokrewne

  • Wprowadzenie


Widoki kodera – informacje

Główne okno programu Windows Media Encoder zawiera wiele paneli z informacjami o bieżącej sesji. To, które panele są wyświetlane podczas kodowania, zależy od typu kodowanej zawartości i liczby skonfigurowanych źródeł dla bieżącej sesji oraz preferencji użytkownika. Można wyświetlić dodatkowe panele lub ukryć wyświetlane. Wszelkie dokonane w oknie zmiany są zapisywane pomiędzy sesjami.

  • Panel Właściwości. Zawiera właściwości, których można użyć w celu dostosowania ustawień związanych z bieżącą sesją lub w celu skonfigurowania sesji niestandardowej.
  • Panel Wideo. Wyświetla kodowaną zawartość. W zależności od typu zawartości, okno można dostosować do wyświetlania tylko zawartości przed kodowaniem, tylko zawartości zakodowanej lub obu. W niektórych przypadkach zawartość źródłowa lub zakodowane wyjście nie są wyświetlane podczas kodowania.
  • Panel Źródła. Zawiera listę źródeł w bieżącej sesji. Klikając przycisk odpowiedniego źródła, można przełączać pomiędzy poszczególnymi źródłami.
  • Panel Audio. Zawiera regulatory monitorowania i dostosowywania głośności kodowanego strumienia audio.
  • Panel Urządzenie. Jest wyświetlany, gdy do komputera podłączone jest urządzenie poprzez port IEEE 1394 lub port COM, gdy jest to magnetowid obsługujący protokół Sony RS422. Na tym panelu można sterować funkcjami odtwarzania, wstrzymywania, zatrzymywania, przewijania do przodu i do tyłu oraz wysuwania. Można również utworzyć listę decyzji dotyczących edycji (EDL) w celu automatycznego kodowania określonych segmentów czasowych zawartości na jednej lub kilku taśmach wideo.
  • Panel Monitorowanie. Zawiera informacje o stanie sesji.
  • Panel Skrypt. Jest wyświetlany po włączeniu skryptów jako typu źródła podczas konfigurowania bieżącej sesji. Podczas kodowania można z tego panelu wstawić do strumienia polecenie skryptu.

Aby wyświetlić lub ukryć panel, w menu Widok należy kliknąć panel, który ma zostać wyświetlony lub ukryty.

Tematy pokrewne

  • Wprowadzenie


Narzędzia kodera – informacje

W programie Windows Media Encoder znajdują się cztery narzędzia:

  • Edytor profili Windows Media. Używany do tworzenia niestandardowych profili używanych podczas sesji kodowania.
  • Edytor plików Windows Media. Wcześniej nazywany Windows Media ASF Indexer. Tego narzędzia można używać do edytowania plików pakietu Windows Media. Na przykład można obcinać początek lub koniec pliku; dodawać znaczniki i polecenia skryptów; sterować zakresem dynamiki zawartości audio i, w przypadku plików wielokanałowego audio, sterować nakładaniem się kanałów podczas odtwarzania stereo.
  • Edytor strumieni Windows Media. Tego narzędzia można używać do dzielenia lub łączenia strumieni w istniejących plikach pakietu Windows Media w celu utworzenia pliku. Na przykład można podzielić plik MBR na wiele plików o pojedynczej szybkości transmisji bitów. Można też utworzyć wiele plików, każdy z tym samym strumieniem wideo, ale z innymi strumieniami audio (na przykład, aby stworzyć jeden plik z wieloma wersjami językowymi).
  • Skrypt kodowania Windows Media. Dawniej nazywane narzędziem Windows Media Encoding Utility. Tego narzędzia można używać z poziomu wiersza polecenia (Wmcmd.vbs) do kodowania i emisji zawartości. Narzędzie to jest instalowane w tej samej lokalizacji co koder, którą domyślnie jest C:\Program Filer\Windows Media Components\Encoder.

Tematy pokrewne

  • Wprowadzenie
  • Uzyskiwanie dostępu do narzędzia kodera


Uzyskiwanie dostępu do narzędzia kodera

transparent programu Windows Media Encoder

Aby uzyskać dostęp do narzędzia kodera

  1. Kliknij przycisk Start, wskaż pozycję Programy, Windows Media, a następnie wskaż Narzędzia.
  2. Kliknij program narzędziowy, którego chcesz użyć.

obrazek „Uwaga” Uwaga

  • W tej samej lokalizacji znajduje się pomoc dla Skryptu kodowania Windows Media.

Tematy pokrewne

  • Narzędzia kodera – informacje


Konwencje stosowane w dokumentacji

W tym systemie Pomocy stosowane są następujące konwencje.

Konwencja | Zastosowanie
Czcionka pogrubiona | Tekst wyświetlany w interfejsie użytkownika lub tekst, który należy wpisać w interfejsie użytkownika, dokładnie tak jak pokazano.
Czcionka pochylona | Symbol tekstu zastępczego, który należy zastąpić tekstem odpowiednim dla używanego środowiska.
Kod | Przykładowy kod, który należy zastąpić kodem odpowiednim dla używanego środowiska.

Tematy pokrewne

  • Wprowadzenie


Pojęcia

Ta sekcja zawiera ogólne informacje na temat pracy z programem Windows Media Encoder Seria 9.

Tematy pokrewne

  • Windows Media Encoder
  • Opis koderów-dekoderów
  • Sesje – informacje
  • Porównanie serwerów Windows Media i serwerów sieci Web
  • Kodowanie CBR lub VBR – informacje
  • Kodowanie jedno- i dwuprzebiegowe – informacje


Opis koderów-dekoderów

Nieskompresowana zawartość audio i wideo może wymagać dużej przepustowości podczas przesyłania strumieniowego lub tworzenia dużych plików. Dzięki kompresji zawartości można ją emitować przez łącze internetowe o normalnej przepustowości lub zapisać w pliku Windows Media o rozsądnym rozmiarze. Zawartość można skompresować poprzez zastosowanie algorytmów kompresji na danych, biorąc pod uwagę żądaną jakość wyjściową i dostępną przepustowość. Przed odtworzeniem zawartości jest ona dekompresowana przy użyciu algorytmów dekompresji. Te algorytmy kompresji i dekompresji nazywane są koderami-dekoderami. Poniższa tabela zawiera bardziej szczegółowe informacje na temat koderów-dekoderów dostępnych w programie Windows Media Encoder.

Koder-dekoder | Opis
Windows Media Audio 9 Professional | Zapewnia pełne wrażenie dźwięku przestrzennego oraz sterowanie zakresem dynamiki. Inteligentnie redukuje wielokanałowe audio do 2 (stereo) kanałów lub 1 (mono) kanału, w zależności od konfiguracji głośników urządzenia odtwarzającego. Zakładane szybkości transmisji to 128 do 768 Kb/s.
Windows Media Audio 9 Lossless | Zapewnia bezstratne kodowanie audio. Obsługuje kodowanie wielokanałowego audio i sterowanie zakresem dynamicznym.
Windows Media Audio 9 | Zapewnia 20-procentowy wzrost kompresji w porównaniu z koderem-dekoderem Windows Media Audio 8. Obsługuje kodowanie audio VBR.
Windows Media Audio 9 Voice | Oferuje znakomitą jakość zawartości audio ze wzmocnieniem głosu. Oferuje kodowanie w trybie mieszanym głosu i muzyki. Przeznaczone do odtwarzania przy szybkościach transmisji bitów równych 20 Kb/s lub mniejszych.
Windows Media Video 9 | Tworzy wysokiej jakości wideo do scenariuszy przesyłania strumieniowego, pobierania i odtwarzania oraz scenariuszy zapisywania na nośnikach fizycznych. Zapewnia wzrost kompresji o 15 do 50 procent w porównaniu z koderem-dekoderem Windows Media Video 8.1, przy czym znaczny wzrost występuje w przypadku wyższych szybkości transmisji bitów. Umożliwia odtwarzanie zawartości z przeplotem w telewizorach i przystawkach telewizyjnych.
Windows Media Video 8.1 | Obsługuje szereg przepustowości sieciowych. Usuwa przeplot z zawartości z przeplotem przed kodowaniem.
Windows Media Video 7 | Umożliwia użytkownikom programu Windows Media Player 7 wyświetlanie zakodowanej zawartości wideo bez pobierania najnowszych koderów-dekoderów. Jest to najlepszy wybór, gdy komputer kodujący nie spełnia wymagań wydajności dla nowszych koderów-dekoderów Windows Media Video.
Windows Media Video 9 Screen | Zapewnia ulepszoną obsługę cieniowanych obrazów, ruchu na ekranie i przewijania przechwytywanych obrazów. Obsługuje kodowanie jednoprzebiegowe CBR i VBR bez opuszczania ramek. Ten koder-dekoder jest w pełni zoptymalizowany dla scenariuszy przesyłania strumieniowego oraz pobierania i odtwarzania.

obrazek „Uwaga” Uwaga

  • W niektórych sytuacjach na liście koderów-dekoderów znajduje się koder-dekoder Sipro Labs ACELP: na przykład w przypadku importowania profilu utworzonego w programie Windows Media Encoder w wersji 7.1. Jeśli tak jest, zaleca się użycie zamiast niego kodera-dekodera Windows Media Audio 9 Voice.

Tematy pokrewne

  • Pojęcia


Sesje – informacje

Przed rozpoczęciem kodowania należy skonfigurować sesję kodowania. Jako część konfiguracji sesji, należy wykonać następujące czynności:

  • Określić źródło zawartości audio lub wideo. Źródłem mogą być urządzenia, pliki lub urządzenia i pliki jednocześnie. Można także przechwytywać obraz bezpośrednio z pulpitu.
  • Wybrać opcje wyjściowe. Należy wybrać, czy zawartość będzie emitowana czy kodowana do pliku. Jeśli zawartość będzie emitowana, można wypchnąć strumień na serwer Windows Media i w ten sposób umożliwić serwerom i odtwarzaczom Windows Media ściąganie strumienia z kodera. Można także wybrać archiwizowanie kopii emisji w celu późniejszego wykorzystania.

Ponadto, przed rozpoczęciem kodowania należy sprawdzić ustawienia kompresji i jakości. Stosowane są ustawienia domyślne, ale może zaistnieć konieczność dostosowania ustawień zgodnie z określonymi wymaganiami. Na przykład jeśli zawartość ma być dystrybuowana w celu pobierania i odtwarzania na komputerze, może być wskazane użycie kodowania VBR opartego na szybkości transmisji bitów i ustawienie poziomu jakości audio i wideo na wyższą szybkość transmisji bitów.

Po zidentyfikowaniu źródła zawartości i określeniu wyjścia pozostaje jeszcze duża liczba opcji umożliwiających dostosowanie sesji. Na przykład można zoptymalizować audio i wideo, aby poprawić jakość zakodowanej zawartości.

Po skonfigurowaniu sesji zgodnie z wymaganiami można rozpocząć kodowanie. Aby uruchomić ponownie tę samą sesję, można zapisać sesję w pliku sesji przed lub po kodowaniu.

obrazek „Uwaga” Uwaga

  • Nie jest konieczne tworzenie sesji podczas każdego kodowania. Koder zawiera funkcję szybkiego uruchamiania i Kreatora nowej sesji, które wspomagają najczęstsze scenariusze kodowania.

Tematy pokrewne

  • Pojęcia
  • Konfigurowanie źródeł
  • Opcje wyjściowe
  • Dostosowywanie sesji
  • Kodowanie za pomocą funkcji szybkiego uruchamiania lub Kreatora nowej sesji
  • Zapisywanie sesji


Porównanie serwerów Windows Media i serwerów sieci Web

Zawartość do odtwarzacza można dostarczać z serwera z uruchomionym programem Windows Media Services lub z serwera sieci Web. Serwer i odtwarzacz mogą się znajdować w sieci Internet lub intranet i mogą być oddzielone zaporą. Serwer Windows Media jest specjalnie zaprojektowany do przesyłania strumieniowego zawartości opartej na technologii Windows Media, natomiast standardowy serwer sieci Web nie. W przypadku gdy ma być używany serwer sieci Web, należy zwrócić uwagę na różnice w sposobie dostarczania zawartości, co może mieć wpływ na jakość odtwarzania.

Serwery Windows Media

Serwer Windows Media mierzy dostarczanie pakietów zgodnie z informacjami zwrotnymi otrzymywanymi podczas wysyłania strumienia do odtwarzacza. Gdy serwer odbiera pakiety w ten sposób, prezentacja będzie płynniejsza. Ponieważ wykorzystanie przepustowości jest kontrolowane, więcej użytkowników może łączyć się równocześnie z witryną i odbierać strumienie bez występowania przerw.

Jeśli zawartość ma być dostarczana jako strumień emisji pojedynczej z serwera Windows Media, można zakodować strumień z wieloma szybkościami transmisji bitów (MBR). Zapewni to dostarczenie użytkownikom zawartości o lepszej jakości, gdy w sieci wystąpią przeciążenia. Gdy zawartość MBR zostanie odebrana przez odtwarzacz, tylko szybkość transmisji bitów najbardziej odpowiednia dla przepustowości sieci będzie przesyłana strumieniowo. Proces wyboru odpowiedniego strumienia obsługiwany jest przez serwer Windows Media, a odtwarzacz jest niewidoczny dla użytkownika.

W przypadku przesyłania strumieniowego plików lub strumieni z pojedynczą szybkością transmisji bitów, serwer Windows Media pozwala na płynne regulowanie obciążeń sieci. Jeśli przeciążenie wystąpi podczas emisji, strumień zostanie „uszczuplony”, co oznacza, że szybkość klatek zostanie obniżona. Jeśli to nie wystarczy, część strumienia wideo zostanie zatrzymana i strumieniowo zostanie przesłana tylko część audio.

Serwery sieci Web

Serwer sieci Web został zaprojektowany w taki sposób, aby pobierać maksymalną ilość danych w jak najkrótszym czasie. Jest to odpowiednia metoda do przesyłania pakietów zawierających statyczne obrazy, tekst i skrypty sieci Web, ale nie jest to najlepszy sposób przesyłania pakietów zawierających multimedia przesyłane strumieniowo. Multimedia przesyłane strumieniowo powinny być dostarczane w czasie rzeczywistym, a nie w dużych seriach, natomiast odtwarzacz powinien odbierać pakiety tuż przed ich renderowaniem.

Serwery sieci Web nie obsługują strumieni MBR. Jeśli plik jest przesyłany strumieniowo z serwera sieci Web, jakość dostarczanych danych nie jest monitorowana i nie można dostosować szybkości transmisji bitów. Serwery sieci Web nie mogą korzystać z preferowanego protokołu dostarczania, User Datagram Protocol (UDP), więc dostarczanie strumienia może być przerywane okresami ciszy, gdy odtwarzacz buforuje dane. Dodatkowo serwery sieci Web nie obsługują emisji na żywo ani strumieni multiemisji.

obrazek „Uwaga” Uwaga

  • Program Windows Media Services Seria 9 w systemie Windows .NET Server 2003 zawiera kilka funkcji, zwanych szybkim przesyłaniem strumieniowym, które łączą niektóre z zalet pobierania i przesyłania strumieniowego. Więcej informacji na temat szybkiego przesyłania strumieniowego znajduje się w Pomocy programu Windows Media Services.

Tematy pokrewne

  • Pojęcia
  • Opcje wyjściowe


Kodowanie CBR lub VBR – informacje

Za pomocą programu Windows Media Encoder można zakodować zawartość audio i wideo ze stałą szybkością przesyłania bitów (CBR) lub ze zmienną szybkością przesyłania bitów (VBR).

Kodowanie CBR

Kodowanie CBR jest zaprojektowane do efektywnego działania w scenariuszu przesyłania strumieniowego. W kodowaniu CBR szybkość transmisji bitów pozostaje stała i zbliżona do docelowej szybkości transmisji bitów przez cały strumień, wewnątrz małego okna czasowego ustawionego przez rozmiar bufora. Wady kodowania CBR są takie, że jakość zakodowanej zawartości nie jest taka sama. Ponieważ niektóre fragmenty trudniej jest kompresować niż inne, niektóre części strumienia CBR mają niższą jakość niż inne. Ponadto kodowanie CBR cechuje się niejednakową jakością pomiędzy kolejnymi strumieniami. Ogólnie zmiany jakości są bardziej zauważalne przy niskiej szybkości transmisji bitów.

Kodowanie VBR

Kodowania VBR należy użyć, gdy planuje się dystrybuować zawartość dla pobierania i odtwarzania lokalnego lub na urządzeniu, które ma ograniczoną prędkość odczytu, takim jak odtwarzacz CD lub DVD. (Można również użyć trybu kodowania szczytowego VBR, gdy planuje się przesyłać strumieniowo zawartość.) Kodowanie VBR jest najkorzystniejsze podczas kodowania zawartości, która jest połączeniem prostych i skomplikowanych danych, na przykład wideo z przejściami pomiędzy wolnym i szybkim ruchem. W kodowaniu VBR do mniej skomplikowanych fragmentów zawartości automatycznie przydzielanych jest mniej bitów, dzięki czemu pozostaje więcej dostępnych bitów dla fragmentów bardziej skomplikowanych. Oznacza to, że zawartość o bardziej jednolitej złożoności (na przykład programy publicystyczne) nie wykorzysta kodowania VBR. W przypadku użycia w zawartości mieszanej kodowanie VBR tworzy lepiej zakodowane wyjście przy tym samym rozmiarze pliku w porównaniu z kodowaniem CBR. W niektórych przypadkach można uzyskać plik zakodowany VBR o tej samej jakości co plik zakodowany CBR, ale o połowę mniejszy.

Opcje trybu kodowania

W kodowaniu CBR można użyć jedno- lub dwuprzebiegowego kodowania. Dostępne są trzy opcje kodowania VBR: VBR w oparciu o jakość (jednoprzebiegowe), w oparciu o szybkość przesyłania bitów (dwuprzebiegowe) i w oparciu o szczytową szybkość przesyłania bitów (dwuprzebiegowe). Nie wszystkie kodery-dekodery obsługują kodowanie CBR i VBR.

Tematy pokrewne

  • Pojęcia
  • Korzystanie z kodowania CBR
  • Korzystanie z kodowania VBR
  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Wymagania funkcji


Kodowanie jedno- i dwuprzebiegowe – informacje

Za pomocą programu Windows Media Encoder można wykonać kodowanie jedno- lub dwuprzebiegowe, zarówno kodowanie CBR jak i kodowanie VBR. (Oparty na jakości tryb kodowania VBR jest jednoprzebiegowy; oparte na szybkości transmisji bitów i szczytowej szybkości transmisji bitów tryby kodowania VBR są dwuprzebiegowe.)

Podczas kodowania jednoprzebiegowego, zawartość jest przetwarzana przez koder jednokrotnie i wtedy stosowana jest kompresja. Podczas kodowania dwuprzebiegowego, zawartość jest analizowana podczas pierwszego przebiegu, a następnie jest kodowana podczas drugiego przebiegu na podstawie danych zgromadzonych podczas pierwszego przebiegu. Kodowanie dwuprzebiegowe może dać w wyniku lepszą jakość zawartości, ponieważ koder poświęca czas na znalezienie optymalnej kombinacji szybkości transmisji bitów, szybkości klatek, rozmiaru buforu i jakości obrazu opartej na kompozycji sceny. Jednak kodowanie dwuprzebiegowe trwa dłużej, ponieważ koder dwukrotnie analizuje całą zawartość.

Kodowanie dwuprzebiegowe nie jest dostępne w następujących sytuacjach:

  • Strumień jest emitowany
  • W sesji występuje wiele źródeł
  • Źródło jest ustawione na zapętlenie
  • W strumieniu znajdują się polecenia skryptu
  • Źródło zawartości pochodzi z urządzeń, chyba że włączono sterowanie urządzeniem
  • Plik źródłowy posiada rozszerzenie nazwy pliku .bmp

Ponadto, kodowanie dwuprzebiegowe jest dostępne tylko z pewnymi koderami-dekoderami. Aby zapoznać się z listą koderów-dekoderów obsługujących kodowanie dwuprzebiegowe, zobacz Wymagania funkcji.

obrazek „Uwaga” Uwaga

  • Jeśli używane jest kodowanie dwuprzebiegowe, podczas pierwszego przebiegu w koderze nie będzie wyświetlany wyjściowy obraz wideo.

Tematy pokrewne

  • Pojęcia
  • Kodowanie CBR lub VBR – informacje
  • Włączanie sterowania urządzeniem


Konfigurowanie źródeł

Za pomocą programu Windows Media Encoder można kodować zdarzenia na żywo w czasie rzeczywistym, przechowywaną zawartość lub przechwycone ekrany. Źródła zawartości czasu rzeczywistego obejmują wszystkie urządzenia, które można podłączyć do karty dźwiękowej lub karty wideo, łącznie z odtwarzaczami dysków CD, mikrofonami, magnetowidami, kamerami wideo, odtwarzaczami wideo i telewizorami. Źródła przechowywane są to pliki audio i wideo. Można również przechwytywać ekrany bezpośrednio z pulpitu oraz wstawiać polecenia skryptów podczas kodowania.

Należy pamiętać, że wyższa jakość zawartości źródłowej daje wyższą jakość zawartości wyjściowej. Oznacza to, że należy rozpocząć pracę z plikiem źródłowym o najwyższej jakości lub, jeśli źródłem jest urządzenie, należy ustawić je na przechwytywanie z najwyższą możliwą jakością.

Podczas konfigurowania źródła należy najpierw zidentyfikować typy źródeł (audio, wideo lub skrypt), z których składa się źródło. Źródło musi składać się z co najmniej jednego typu źródła audio lub wideo. Do sesji kodowania można dodać nieograniczoną liczbę źródeł, zarówno przed, jak i po rozpoczęciu kodowania, ale każde następne źródło jest oparte na kombinacji typów źródeł utworzonych w sesji. Na przykład, jeśli pierwsze źródło zawiera tylko dźwięk, to wszystkie następne źródła w sesji są oparte na dźwięku. W przypadku sesji z wieloma źródłami zalecane jest skonfigurowanie pierwszego źródła, tak aby korzystało ze wszystkich trzech typów źródeł. Jeśli dodatkowe źródła nie używają typu źródła, dla tego typu źródła można zakodować pusty strumień.

Tematy pokrewne

  • Windows Media Encoder
  • Pobieranie źródła z pliku
  • Pobieranie źródła z plików wielokanałowego audio
  • Pobieranie źródła z urządzeń
  • Przechwytywanie ekranów
  • Wstawianie poleceń skryptu
  • Korzystanie z wielu źródeł podczas sesji


Pobieranie źródła z pliku

W programie Windows Media Encoder jako źródeł można używać plików z następującymi rozszerzeniami nazw plików: .wma, .wmv, .asf, .avi, .wav, .mpg, .mp3, .bmp i .jpg. (Aby jako źródła używać plików z rozszerzeniem nazwy pliku .mpg, należy na komputerze kodującym zainstalować dekoder zgodny ze standardem MPEG-2.)

Jeśli kodowany jest plik pakietu Windows Media, dowolne atrybuty nagłówka skojarzone z plikiem (na przykład znaczniki, polecenia skryptów, itp.) są usuwane podczas przetwarzania. Za pomocą Edytora plików Windows Media można z powrotem dodać do pliku następujące atrybuty: tytuł, wykonawca, prawa autorskie i opis.

Gdy źródłem jest plik, można przyciąć czas rozpoczęcia i zakończenia pliku, aby zapewnić, że zakodowana zostanie tylko wymagana część pliku.

Aby uzyskać więcej informacji dotyczących uzyskiwania dekodera MPEG-2, zobacz witrynę sieci Web firmy Microsoft.

obrazek „Uwaga” Uwaga

  • Nie są obsługiwane pliki, które zawierają obrazy o nieparzystych wymiarach. Na przykład, nie jest obsługiwany obraz o wymiarach 300 x 321 pikseli, ale obsługiwany jest obraz o wymiarach 300 x 320 pikseli.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Pobieranie źródła z pliku


Pobieranie źródła z pliku

transparent programu Windows Media Encoder

Aby pobrać źródło z pliku

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. Na liście Źródło kliknij pozycję Plik.

    -lub-

    Kliknij Urządzenie i plik, aby pobierać źródło audio i wideo z dwóch różnych plików.

  3. Aby zlokalizować plik źródłowy, kliknij przycisk Przeglądaj.
  4. Jeśli planowane jest przycięcie początku lub końca pliku, kliknij przycisk Znacznik początk./końc.. Zostanie zakodowana tylko pozostała część pliku.
  5. Jeśli planowane jest zakodowanie tylko części audio lub wideo pliku, usuń zaznaczenie pola wyboru Wideo lub Audio.

obrazek „Uwaga” Uwaga

  • Można również przeciągnąć plik źródłowy do kodera.

Tematy pokrewne

  • Pobieranie źródła z pliku


Pobieranie źródła z plików wielokanałowego audio

Za pomocą programu Windows Media Encoder można kodować wielokanałowe audio, co oznacza, że można kodować dźwięk do odtwarzania przestrzennego z użyciem sześciu (audio 5.1) lub ośmiu (audio 7.1) kanałów. Ten format jest w szczególności przeznaczony dla odtwarzaczy CD, DVD, telewizji o wysokiej rozdzielczości oraz programów dźwiękowych kina cyfrowego. Źródło zawartości musi mieć jedną z poniższych postaci:

  • Pojedynczy plik 6- lub 8-kanałowy w formacie WAVE_FORMAT_EXTENSIBLE. Aby uzyskać więcej informacji, zobacz witrynę sieci Web firmy Microsoft. Jeśli źródłem jest plik 8-kanałowy, to zalecane jest, aby częstotliwość próbkowania i liczba bitów na próbkę w pliku źródłowym i kodowanej zawartości były równe.
  • Sześć jednokanałowych plików .wav. Aby utworzyć pliki, należy użyć programu do edycji dźwięku w celu rozłożenia dźwięku do sześciu plików, po jednym na każdy kanał. Podczas konfigurowania źródła w koderze należy określić, z którym kanałem jest skojarzony każdy plik. Żaden z plików .wav nie może być większy niż 2 gigabajty (GB). Ta opcja nie jest dostępna w przypadku audio 7.1.
  • Istniejący wielokanałowy plik pakietu Windows Media Audio. Istniejącego pliku można użyć do zakodowania z użyciem innej szybkości transmisji bitów. Jeśli koder jest zainstalowany na komputerze z systemem Windows 2000, to nie jest możliwe zakodowanie istniejącego wielokanałowego pliku pakietu Windows Media Audio.

Podczas kodowania wielokanałowej zawartości należy używać kodera-dekodera Windows Media Audio 9 Professional lub Windows Media Audio 9 Lossless i formatu audio obsługującego kodowanie wielokanałowe. Ponadto użytkownik odtwarzający zawartość musi mieć system Microsoft Windows XP i odtwarzacz oparty na zestawie Windows Media Format 9 Series Software Development Kit (SDK). W przeciwnym przypadku dźwięk zostanie automatycznie zredukowany do dwóch kanałów dla głośników stereo.

Koder automatycznie redukuje liczbę kanałów do dwóch w celu odtwarzania na głośnikach stereo. Jeśli kodowany jest dźwięk 5.1, na karcie Przetwarzanie w panelu właściwości można sterować dystrybucją redukcji między kanały boczne, centralne i głośnika niskotonowego. Jeśli zawartość jest kodowana do pliku, to do sterowania dystrybucją redukcji w pliku wyjściowym można użyć Edytora plików Windows Media.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Pobieranie źródła z plików wielokanałowego audio
  • Pobieranie źródła z pliku


Pobieranie źródła z plików wielokanałowego audio

transparent programu Windows Media Encoder

Aby pobrać źródło z plików wielokanałowego audio

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. Na liście Źródło kliknij pozycję Urządzenia.
  3. W obszarze Audio kliknij opcję Wielokanałowe źródło WAV, a następnie kliknij przycisk Konfiguruj.
  4. Dla każdego kanału wprowadź źródłowy plik .wav.
  5. Kliknij kartę Kompresja.
  6. Na liście Miejsce docelowe kliknij opcję Pobieranie pliku, Urządzenia sprzętowe, Serwer Windows Media lub Serwer sieci Web, zależnie od scenariusza odtwarzania.
  7. Na liście Audio kliknij pozycję Wielokanałowe audio.
  8. Kliknij przycisk Edytuj, a następnie kliknij kartę szybkości transmisji bitów.
  9. Na liście Format audio kliknij format audio 5.1 lub audio 7.1, który będzie używany.

obrazek „Uwaga” Uwaga

  • Koder automatycznie redukuje liczbę kanałów do dwóch w celu odtwarzania na głośnikach stereo. W przypadku kodowania audio 5.1, na karcie Przetwarzanie można zmodyfikować domyślną dystrybucję redukcji.

Tematy pokrewne

  • Pobieranie źródła z plików wielokanałowego audio


Pobieranie źródła z urządzeń

Gdy źródłem zawartości są urządzenia, należy najpierw wybrać urządzenia audio lub wideo, które będą używane. Po wybraniu urządzeń należy ustawić ich właściwości bezpośrednio z poziomu kodera. Właściwości niektórych urządzeń, takich jak karty dźwiękowe i karty wideo, są globalne i mają zastosowanie nie tylko do wszystkich źródeł sesji kodowania, ale również do wszystkich programów na komputerze. (Na przykład jaskrawość, kontrast, wymiary przechwytywania i ustawienia miksera dźwięku.)

Urządzeń i kart przechwytujących można używać tylko raz w sesji. Na przykład, jeśli utworzono dwa źródła – jednym źródłem jest zdarzenie na żywo, w którym mówca zapowiada nowe wideo, a drugim źródłem jest wideo – dla każdego źródła wymagana jest osobna karta i urządzenie.

Niektórymi urządzeniami można sterować bezpośrednio z poziomu kodera. Jeśli włączono sterowanie urządzeniem, można skonfigurować listę decyzji dotyczących edycji (EDL) identyfikującą części taśmy, które zostaną zakodowane.

Właściwości urządzeń audio i wideo można skonfigurować za pomocą Kreatora nowej sesji, panelu właściwości lub polecenia Konfiguruj urządzenia w menu Narzędzia. Urządzenia muszą być zainstalowane w komputerze, aby możliwe było skonfigurowanie ich w koderze. Kodera nie można używać do dodawania lub usuwania urządzeń; w tym celu należy używać Panelu sterowania.

Jeśli zainstalowano obsługiwaną kartę tunera TV, to za pomocą kodera można zmieniać kanały telewizyjne.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Włączanie sterowania urządzeniem
  • Konfigurowanie listy EDL
  • Pobieranie źródła z urządzeń
  • Zmienianie kodowanych kanałów telewizyjnych


Pobieranie źródła z urządzeń

transparent programu Windows Media Encoder

Aby pobrać źródło z urządzeń

  1. Na pasku narzędzi kliknij przyciskWłaściwości, a następnie kliknij kartę Źródła.
  2. Na liście Źródło kliknij pozycję Urządzenia.
  3. W obszarach Wideo i Audio kliknij urządzenia, które będą źródłami.

Tematy pokrewne

  • Pobieranie źródła z urządzeń


Zmienianie kodowanego kanału TV

transparent programu Windows Media Encoder

Aby zmienić kodowany kanał TV

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. W sekcji Źródło kliknij Urządzenia.
  3. W sekcji Wideo kliknij kartę tunera TV, z której chcesz pobierać dane źródłowe.
  4. Kliknij przycisk Konfiguruj.
  5. W sekcji Kanał wpisz kanał, który chcesz zakodować.
  6. W sekcji Wejścia wybierz opcję tunera, a następnie kliknij przycisk OK.
  7. W sekcji Audio kliknij kartę przechwytywania, którą skonfigurowano do korzystania z kartą tunera TV.

Tematy pokrewne

  • Pobieranie źródła z urządzeń


Włączanie sterowania urządzeniem

Używając funkcji sterowania urządzeniem, można uruchomić urządzenia pewnych typów bezpośrednio z poziomu kodera. Sterowanie urządzeniem umożliwia sterowanie z poziomu kodera następującymi funkcjami urządzenia: odtwarzanie, wstrzymywanie, zatrzymywanie, szybkie przewijanie do przodu, przewijanie do tyłu i wysuwanie. Aby sterować urządzeniem, należy podłączyć je do portu wideo cyfrowego IEEE 1394 lub można użyć magnetowidu obsługującego protokół Sony RS422 i podłączyć go do portu COM. Można również użyć wbudowanej listy decyzji dotyczących edycji (EDL) funkcji sterowania urządzeniem, aby rozmieścić i zakodować klipy w dowolnej kolejności.

Po włączeniu sterowania urządzeniem można używać kodowania dwuprzebiegowego, jeśli wykonano następujące czynności:

  • Wybrano kodowanie do pliku
  • Wybrano tymczasowe składowanie zawartości
  • Ustawiono listę EDL dla zawartości

obrazek „Uwaga” Uwaga

  • Jeśli używane w sesji urządzenie nie jest wyświetlane w oknie dialogowym Konfigurowanie urządzeń, należy zamknąć okno dialogowe, kliknąć przycisk Zastosuj, a następnie ponownie otworzyć okno dialogowe.

Tematy pokrewne

  • Pobieranie źródła z urządzeń
  • Konfigurowanie listy EDL
  • Tymczasowe przechowywanie przechwyconej zawartości
  • Włączanie sterowania urządzeniem


Włączanie sterowania urządzeniem

transparent programu Windows Media Encoder

Aby włączyć sterowanie urządzeniem

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. W grupie opcji Źródło kliknij opcję Urządzenia.
  3. W polach Wideo i Audio kliknij urządzenie, które ma być źródłem.

    Jeżeli urządzenie nie jest wyświetlone na liście, sprawdź, czy jest włączone. Może być konieczne zamknięcie kodera i ponowne jego uruchomienie po włączeniu urządzenia.

  4. Kliknij przycisk Zastosuj.
  5. Na panelu Urządzenie kliknij przycisk Ustawienia.
  6. Na liście zaznacz urządzenie lub port COM, przez który urządzenie jest podłączone, a następnie kliknij przycisk OK.
  7. Steruj urządzeniem za pomocą regulatorów na panelu.

obrazek „Uwaga” Uwaga

  • Aby było możliwe sterowanie urządzeniem cyfrowym z poziomu kodera, urządzenie to musi być ustawione w tryb magnetowidu. Magnetowidy muszą być ustawione w tryb TC.

Tematy pokrewne

  • Włączanie sterowania urządzeniem


Konfigurowanie listy EDL

Jeśli włączono sterowanie urządzeniem, to za pomocą sygnatury czasowej można określić dokładne punkty rozpoczęcia i zakończenia kodowania zawartości audio lub wideo. Aby to zrobić, należy utworzyć listę decyzji dotyczących edycji (EDL) identyfikującą części taśmy, które zostaną zakodowane.

Nie jest zalecane używanie listy EDL w przypadku emisji, ponieważ koder potrzebuje podczas kodowania dodatkowego czasu na wyszukanie punktów listy EDL. Podczas emisji może spowodować to nadmierne buforowanie w odtwarzaczu.

Można dodać dowolną liczbę wpisów listy EDL w dowolnej kolejności – niekoniecznie w kolejności, w której występują na taśmie. Można również skonfigurować listę EDL do pobierania źródła z wielu taśm. Podczas sesji kodowania koder będzie monitować użytkownika, gdy będzie konieczna zmiana taśmy.

Podczas konfigurowania listy EDL należy używać wstępnie przygotowanej taśmy. Aby wstępnie przygotować taśmę, należy po nabyciu w sposób ciągły nagrać ją od początku do końca. Zapewnia to, że kod czasowy na taśmie będzie ciągły. Jeśli taśma nie jest wstępnie przygotowana, urządzenie będzie generować nowy kod czasowy podczas każdego konfigurowania listy EDL dla urządzenia.

Tematy pokrewne

  • Pobieranie źródła z urządzeń
  • Włączanie sterowania urządzeniem
  • Konfigurowanie listy EDL


Konfigurowanie listy EDL

transparent programu Windows Media Encoder

Aby skonfigurować listę EDL

  1. Skonfiguruj sesję sterowania urządzeniem, która koduje do pliku.
  2. W menu Widok kliknij polecenie Panel monitorowania, a następnie kliknij kartę EDL.
  3. Kliknij przycisk Edytuj EDL.
  4. W obszarze Urządzenie kliknij przycisk Odtwórz, aby rozpocząć odtwarzanie taśmy.

    Odtwarzanie taśmy można również rozpocząć od określonego punktu, używając innych regulatorów odtwarzania, takich jak przyciski Wyszukaj i Szybko przewiń do przodu.

  5. Po znalezieniu szukanej klatki kliknij przycisk Znacznik początkowy, aby określić, że ta klatka jest punktem początkowym klipu.

    Odtwarzanie taśmy będzie kontynuowane.

  6. Kliknij przycisk Znacznik końcowy przy klatce, która ma być punktem końcowym klipu.
  7. W przypadku użycia kilku taśm podaj unikatowy identyfikator (taki jak 1, 2, 3 lub A, B, C) w polu Identyfikator taśmy.
  8. Kliknij przycisk Dodaj wpis EDL, aby dodać klip do listy decyzji dotyczących edycji.
  9. Aby edytować klip, kliknij go na liście, a następnie kliknij przycisk Edytuj.
  10. Powtarzaj kroki od 4 do 8, aby dodać więcej klipów.
  11. Gdy lista jest gotowa, kliknij przycisk OK, a następnie kliknij przycisk Rozpocznij kodowanie na pasku narzędzi.

    Podczas kodowania karta EDL na Panelu monitorowania wyświetla informacje o stanie klipów.

Tematy pokrewne

  • Konfigurowanie listy EDL
  • Włączanie sterowania urządzeniem
  • Kodowanie do pliku


Przechwytywanie ekranów

Można przechwycić cały ekran pulpitu, poszczególne okna lub obszar ekranu, a następnie wyemitować ekran lub zakodować do pliku, tak jak każdą inną zawartość. Funkcji przechwytywania ekranów można użyć do wykonania następujących czynności:

  • Przechwytywanie z plików .avi, które zostały utworzone za pomocą programów narzędziowych innych firm do przechwytywania ekranów.
  • Przechwytywanie okna (lub całego pulpitu) bezpośrednio z pulpitu.
  • Przechwytywanie z karty, która jest podłączona do urządzenia konwertera sygnału.

Podczas przechwytywania okna można zapisać sesję w celu jej późniejszego użycia. Należy jednak pamiętać, że tytuł okna i jego współrzędne są zapisywane razem z innymi informacjami o konfiguracji w pliku sesji. Po ponownym załadowaniu pliku sesji na potrzeby kolejnych sesji przechwytywania ekranu koder szuka okna, które odpowiada zapisanemu tytułowi. Jeśli koder go nie znajdzie, przechwytuje okno, które odpowiada zapisanym współrzędnym okna.

W przypadku przechwytywania całego pulpitu i zapisywania sesji, ustawienia kolorów i rozmiar ekranu monitora są zapisywane w pliku sesji. Jeśli po zapisaniu sesji rozmiar ekranu lub ustawienia kolorów zostaną zmienione, należy utworzyć nową sesję w celu uwzględnienia tych ustawień.

Jeśli podczas przechwytywania okna lub całego pulpitu zostanie wyświetlony wygaszacz ekranu, wygaszacz ten zostanie zakodowany. Z tego względu zaleca się wyłączenie wygaszacza ekranu podczas przechwytywania okna lub całego pulpitu.

obrazek „Uwaga” Uwagi

  • Gdy sygnał analogowy jest przesyłany przez konwerter obrazu i konwertowany do formatu NTSC (National Television Standards Committee), mogą powstawać zakłócenia. Te zakłócenia wzmacniane są podczas kodowania i mogą obniżyć jakość zakodowanego wideo.
  • Po zakończeniu kodowania ekranu należy kliknąć przycisk Zatrzymaj kodowanie na pasku narzędzi. Samo zminimalizowanie przechwytywanego okna nie powoduje zakończenia sesji kodowania.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Poprawianie wydajności podczas kodowania ekranów
  • Kodowanie pliku avi z zawartością ekranu
  • Przechwytywanie ekranu na pulpicie


Poprawianie wydajności podczas kodowania ekranów

Z powodu ilości przetwarzanych danych i wymaganej mocy procesora przechwytywanie ekranów wymaga dużej wydajności. Poniższe wskazówki pomogą zapewnić, że przechwycone obrazy ekranu zostaną poprawnie zakodowane i odtworzone:

  • Użyj szybkiego procesora.
  • Użyj kodera-dekodera Windows Media Video 9 Screen.
  • Ustaw mniejszą rozdzielczość ekranu. Na przykład przechwytywanie obrazu w rozdzielczości 1024 x 768 wymaga więcej danych niż przechwytywanie w rozdzielczości 640 x 480.
  • Ustaw głębię kolorów na 16- lub 8-bitową. Ewentualnie, aby poprawić wykorzystanie procesora, należy ustawić koder do pracy w trybie 256-kolorowym. Należy pamiętać, że praca w 256 kolorach może spowodować zmiany palety kolorów przy przełączaniu się między programami wykorzystującymi inne schematy kolorów. Koder nie obsługuje zmiany palety podczas przechwytywania ekranu w czasie rzeczywistym. Dlatego należy użyć 16-bitowej głębi kolorów lub najpierw przechwycić do pliku .avi, a następnie użyć kodera do konwersji pliku na format Windows Media.
  • Ustaw mniejszą szybkość klatek. Aby określić jaka szybkość klatek najlepiej odpowiada potrzebom użytkownika, konieczne może być wypróbowanie różnych wartości.
  • Przechwyć mniejszy obraz.
  • Użyj większej prędkości transmisji bitów.
  • Unikaj wielu zmian sceny, na przykład częstego otwierania i zamykania okien podczas przechwytywania.
  • W przypadku korzystania z konfiguracji dwumonitorowej przechwytuj ekrany lub fragmenty tylko z głównego monitora.
  • Wyłącz przyspieszenie sprzętowe. (Należy je włączyć po zakończeniu przechwytywania ekranu, aby uzyskać lepsze rezultaty w innych programach.)
  • Zamknij wszystkie nieużywane programy do obsługi wideo.
  • Ustaw rozmiar klatki wyjściowej na taki sam, jak rozmiar w źródle. Nie należy używać kodera do zmiany rozmiaru źródłowego wideo.

Tematy pokrewne

  • Przechwytywanie ekranów
  • Wymagania dotyczące sprzętu i oprogramowania


Kodowanie pliku avi z zawartością ekranu

transparent programu Windows Media Encoder

Aby zakodować plik avi z zawartością ekranu

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. W grupie opcji Źródło kliknij opcję Plik, a następnie wpisz nazwę pliku avi.
  3. Kliknij kartę Kompresja.
  4. W polu Miejsce docelowe kliknij opcję Serwer Windows Media lub Serwer sieci Web, zależnie od zamierzeń dotyczących odtwarzania.
  5. W polu Wideo kliknij opcję Przechwytywanie ekranu.
  6. Kliknij przycisk Zastosuj, a następnie na pasku narzędzi kliknij przycisk Uruchom kodowanie.

obrazek „Uwaga” Uwaga

  • Jeżeli przechwytywanie odbywa się z plików avi utworzonych za pomocą innego narzędzia do przechwytywania ekranów, to w przypadku plików, które użytkownik zamierza później przekonwertować za pomocą kodera, należy korzystać z kompresji z kodowaniem długości (RLE) lub formatów RGB bez kompresji.

Tematy pokrewne

  • Przechwytywanie ekranów


Przechwytywanie ekranu na pulpicie

transparent programu Windows Media Encoder

Aby przechwycić ekran na pulpicie

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. W sekcji Źródło kliknij pozycję Urządzenia.
  3. W sekcji Wideo kliknij pozycję Przechwytywanie ekranu, a następnie kliknij przycisk Konfiguruj, aby określić okno lub region na ekranie, który chcesz przechwycić.
  4. Kliknij kartę Kompresja.
  5. W sekcji Miejsce docelowe kliknij opcję Serwer Windows Media lub Serwer sieci Web, w zależności od scenariusza odtwarzania.
  6. W sekcji Wideo kliknij pozycję Przechwytywanie ekranu.
  7. Kliknij przycisk Zastosuj, a następnie na pasku zadań kliknij polecenie Uruchom kodowanie.

    Okno kodera zostanie zminimalizowane podczas kodowania. W przypadku kodowania pliku przywrócenie okna kodera powoduje zazwyczaj wstrzymanie kodera. Jeśli jednak sesja przechwytywania ekranu wciąż pobiera audio z pliku, przywrócenie okna kodera nie spowoduje wstrzymania kodera. W przypadku sesji emisji kodowanie jest kontynuowane, nawet jeśli okno kodera zostanie przywrócone. Aby zatrzymać lub wstrzymać kodowanie, kliknij przycisk kodera na pasku zadań. Następnie, na pasku zadań, kliknij polecenie Zatrzymaj kodowanie lub Wstrzymaj kodowanie.

Tematy pokrewne

  • Przechwytywanie ekranów


Wstawianie poleceń skryptu

Polecenia skryptu można wstawić do strumienia podczas kodowania. Koder obsługuje następujące typy poleceń skryptu:

  • Podpisy. Ciągi tekstowe o dowolnej postaci wyświetlane w odtwarzaczu wraz z zakodowaną zawartością. Aby podpisy były widoczne, użytkownicy muszą włączyć ich wyświetlanie w odtwarzaczu.
  • Napisy. Jeśli karta do przechwytywania obsługuje przechwytywanie danych podpisów, można zakodować napisy.
  • Adresy URL. Jeśli polecenie jest wstawione do strumienia, otwarta zostanie domyślna przeglądarka, a żądany adres URL zostanie załadowany do przeglądarki. Jeśli osadzono odtwarzacz w przeglądarce, żądany adres URL zastępuje odtwarzacz, a użytkownicy nie mogą przejrzeć pozostałej części strumienia. Można to obejść, wyświetlając żądany adres URL w oddzielnej ramce w tym samym wystąpieniu przeglądarki lub otwierając dodatkowe wystąpienie przeglądarki.
  • Niestandardowe polecenia skryptu. Poza obsługą podpisów i adresów URL, odtwarzacz automatycznie przetwarza polecenia skryptu FILENAME, EVENT i OPENEVENT. Polecenia FILENAME można użyć do otwarcia danego pliku multimedialnego o określonej godzinie. Polecenia EVENT można użyć do utworzenia niestandardowych poleceń skryptu. Można na przykład wstawić reklamę do strumienia. Należy pamiętać, że kod dla określonego zdarzenia musi zostać zdefiniowany w metapliku pakietu Windows Media strumienia odtwarzacza, aby odtworzyć określone zdarzenie. Polecenie OPENEVENT poprzedza rzeczywiste polecenie EVENT. Polecenie OPENEVENT umożliwia odtwarzaczowi wstępne buforowanie zawartości, aby po wystąpieniu określonego zdarzenia przełączenie nastąpiło niezauważalnie.

Szczegółowe informacje na temat poleceń skryptu obsługiwanych przez program Windows Media Player Seria 9 zawiera zestaw Windows Media Player 9 Series Software Development Kit (SDK). Informacje na temat poleceń skryptu obsługiwanych przez program Windows Media Services Seria 9 zawiera zestaw Windows Media Services 9 Series SDK.

Ponieważ polecenia skryptu są zapisywane w strumieniu, nie są one dostępne do edycji.

Wstawianie poleceń skryptu do sesji kodowania wymaga wybrania skryptów jako typu źródłowego podczas konfigurowania sesji. Podczas konfigurowania sesji z wykorzystaniem Kreatora nowej sesji nie można dołączać skryptów, ale można dodawać skrypty do sesji za pomocą karty Źródła na panelu Właściwości.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Wstawianie poleceń skryptów podczas kodowania
  • Kodowanie danych napisów


Wstawianie poleceń skryptów podczas kodowania

transparent programu Windows Media Encoder

Aby wstawić polecenia skryptów podczas kodowania

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. W obszarze Źródło kliknij pozycję Urządzenia.

    -lub-

    Aby wstawić polecenia skryptów podczas pobierania źródła z pliku, kliknij opcję Urządzenie i plik.

  3. Zaznacz pole wyboru Skrypt, a następnie kliknij pozycję Panel skryptu.
  4. Kliknij przycisk Zastosuj, a następnie kliknij przycisk Rozpocznij kodowanie.
  5. W panelu Skrypt kliknij przycisk rodzaju skryptu, który ma zostać wstawiony. Można wstawić napis (łańcuch tekstowy), adres URL lub niestandardowe polecenie skryptu.
  6. Wykonaj jedną z następujących czynności:
    • W przypadku wstawiania napisu lub adresu URL wpisz tekst lub adres URL, który ma zostać wstawiony.
    • W przypadku wstawiania skryptu niestandardowego wpisz typ i wartość polecenia skryptu.
  7. Kliknij przycisk Wstaw w miejscu, w którym skrypt ma zostać wstawiony do strumienia. Wartość pozycji Liczba skryptów w panelu monitorowania jest zwiększana po wstawieniu każdego skryptu.

Tematy pokrewne

  • Wstawianie poleceń skryptu


Kodowanie danych napisów

transparent programu Windows Media Encoder

Aby kodować dane napisów

  1. Na pasku narzędzi kliknij Właściwości, a następnie kliknij kartę Źródła.
  2. W obszarze Źródło kliknij Urządzenia.
  3. Zaznacz pole wyboru Skrypt, a następnie kliknij nazwę karty przechwytywania, która obsługuje napisy.
  4. Aby skonfigurować kartę, kliknij przycisk Konfiguruj.

Tematy pokrewne

  • Wstawianie poleceń skryptu


Korzystanie z wielu źródeł podczas sesji

Podczas sesji można korzystać z wielu źródeł. Chociaż podczas kodowania jest przesyłane strumieniowo tylko jedno źródło, można przełączać się między źródłami, tak aby przesyłać strumieniowo inną zawartość. Na przykład przed emisją spotkania firmowego, można skonfigurować źródła dla głównej zawartości oraz powitania, przerwy i pożegnania. Gdy rozpoczyna się emisja spotkania, można rozpocząć od źródła powitania, przełączyć się w odpowiednim momencie na prowadzącego spotkanie, na źródło przerwy podczas przerwy, a następnie na źródło pożegnania, gdy spotkanie dobiegnie końca.

W przypadku używania kodera-dekodera Windows Media Audio 9 Voice w sesji z wieloma źródłami, tryb (tylko głos lub mieszany głos i muzyka) pierwszego źródła określa tryb kolejnych źródeł. Na przykład, jeśli wybrano tryb tylko głosu lub tryb mieszany dla pierwszego źródła, kolejne źródła będą kodowane w tym samym trybie. Jednak jeśli dla pierwszego źródła zostanie określony tryb mieszany i dla tego źródła zostanie skonfigurowany plik definicji optymalizacji, kolejne źródła w sesji zostaną zakodowane w trybie tylko głosu.

Tematy pokrewne

  • Konfigurowanie źródeł
  • Przełączanie między wieloma źródłami podczas kodowania
  • Ustawianie porządku wielu źródeł


Przełączanie między wieloma źródłami podczas kodowania

transparent programu Windows Media Encoder

Aby przełączać między wieloma źródłami podczas kodowania

  1. W menu Widok kliknij polecenie Panel źródeł.
  2. Na panelu źródeł kliknij źródło, od którego chcesz rozpocząć, a następnie kliknij przycisk Uruchom kodowanie.
  3. Aby przełączyć się na inne źródło, kliknij jego przycisk na panelu źródeł.

Tematy pokrewne

  • Korzystanie z wielu źródeł podczas sesji


Ustawianie porządku wielu źródeł

transparent programu Windows Media Encoder

Aby ustawić porządek wielu źródeł

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Źródła.
  2. Na liście źródeł kliknij źródło, które chcesz przesunąć, a następnie kliknij przycisk strzałki w górę strzałka w górę lub strzałki w dół strzałka w dół.

Tematy pokrewne

  • Korzystanie z wielu źródeł podczas sesji


Dostosowywanie sesji

W tej sekcji zamieszczono informacje na temat opcji, za pomocą których można dostosować sesję kodowania zgodnie z własnymi potrzebami. Jeżeli użytkownik chce często korzystać z dostosowanej sesji, może zapisać ją do pliku sesji i dodać do listy szybkiego uruchamiania.

Tematy pokrewne

  • Windows Media Encoder
  • Otwieranie istniejącej sesji
  • Zapisywanie sesji
  • Uruchamianie, zatrzymywanie lub wstrzymywanie kodowania
  • Tworzenie niestandardowej funkcji szybkiego uruchamiania
  • Przycinanie i zmienianie rozmiaru wideo przed zakodowaniem
  • Zachowywanie współczynnika proporcji pikseli w wideo
  • Optymalizowanie wideo i audio
  • 92Określanie języka dla zawartości
  • Stosowanie kompresji czasu w zawartości
  • Korzystanie z kodowania CBR
  • Korzystanie z kodowania VBR
  • Konfigurowanie strumienia MBR
  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości
  • Osadzanie znaku wodnego w zawartości
  • Korzystanie z profili sprzętowych
  • Korzystanie z dodatków transformacji


Otwieranie istniejącej sesji

transparent programu Windows Media Encoder

Aby otworzyć istniejącą sesję

  1. W menu Plik kliknij przycisk Otwórz.
  2. W polu Nazwa pliku wprowadź nazwę i lokalizację pliku sesji, który ma zostać otwarty.

    Pliki sesji mają rozszerzenie nazwy pliku .wme.

  3. Kliknij przycisk Otwórz.

obrazek „Uwaga” Uwaga

  • Plik sesji można również otworzyć, przeciągając go do kodera.

Tematy pokrewne

  • Dostosowywanie sesji


Zapisywanie sesji

transparent programu Windows Media Encoder

Aby zapisać sesję

  1. W menu Plik kliknij polecenie Zapisz.
  2. W polu Nazwa pliku wprowadź nazwę i lokalizację dla pliku, a następnie kliknij przycisk Zapisz.

Tematy pokrewne

  • Dostosowywanie sesji


Uruchamianie, zatrzymywanie lub wstrzymywanie kodowania

transparent programu Windows Media Encoder

Aby uruchomić, zatrzymać lub wstrzymać kodowanie

  • Aby rozpocząć kodowanie, na pasku narzędzi kliknij przycisk Uruchom kodowanie. Zostanie wyświetlony komunikat informujący o rozpoczęciu kodowania.

    -lub-

    Aby zatrzymać kodowanie, na pasku narzędzi kliknij przycisk Zatrzymaj. Zostanie wyświetlony komunikat informujący o zatrzymaniu kodowania. Podsumowanie wyników sesji jest dostępne w oknie dialogowym Wyniki kodowania.

    -lub-

    Aby wstrzymać kodowanie, na pasku narzędzi kliknij Wstrzymaj. Należy zwrócić uwagę, że kodowanie można wstrzymać tylko wtedy, gdy źródłem są urządzenia lub przechwytywanie ekranu i kodowanie następuje do pliku. Jeśli jedno ze źródeł w sesji to plik, nie ma możliwości wstrzymania kodowania.

Tematy pokrewne

  • Dostosowywanie sesji


Tworzenie niestandardowej funkcji szybkiego uruchamiania

transparent programu Windows Media Encoder

Aby utworzyć niestandardową funkcję szybkiego uruchamiania

  1. Utwórz sesję spełniającą odpowiednie wymagania w zakresie kodowania, a następnie ją zapisz.
  2. Zapisz plik sesji w katalogu szablonów, który znajduje się w tej samej lokalizacji, co program Windows Media Encoder. Domyślna lokalizacja to C:\Program Files\Windows Media Components\Encoder\Templates.

    Utworzona funkcja szybkiego uruchamiania będzie wyświetlana na liście szybkiego uruchamiania w oknie dialogowym Nowa sesja.

Tematy pokrewne

  • Dostosowywanie sesji
  • Korzystanie z funkcji szybkiego uruchamiania do kodowania


Przycinanie i zmienianie rozmiaru wideo przed zakodowaniem

Korzystając z programu Windows Media Encoder, można przycinać krawędzie wejściowego obrazu wideo. Na przykład na krawędziach często pojawiają się zakłócenia, więc można przyciąć jedną lub kilka krawędzi, aby wyeliminować linie z zakłóceniami. Można określić stopień przycinania z każdej strony obrazu lub użyć domyślnych wartości przycinania. Po przycięciu można zmienić wysokość i szerokość wyjściowego wideo. Domyślnie wyjściowy obraz wideo jest rozciągany, aby był zgodny z rozmiarem klatki określonym w profilu. Można jednak zmienić rozmiar wideo, aby obraz wyjściowy odpowiadał rozmiarom przyciętego obrazu. Można również automatycznie zmienić rozmiar obrazu, aby wykorzystać przepustowość określoną w profilu. Można także określać niestandardowe wielkości zmiany rozmiaru.

Wideo MBR i wiele źródeł

W przypadku kodowania wideo MBR można zmienić rozmiar klatki wyjściowej dla każdej szybkości transmisji bitów z osobna. Oznacza to, że plik lub strumień MBR mogą zawierać obrazy o różnych rozmiarach.

Jeśli w jednej sesji znajduje się kilka źródeł, rozmiary wyjściowe pierwszego źródła określają rozmiary kolejnych źródeł. Z tego względu możliwa jest zmiana tylko pierwszego źródła w sesji z wieloma źródłami.

Wykrywanie rozmiaru wejściowego

W przypadku gdy źródłem jest plik, koder może wykryć rozmiar źródła wideo przed rozpoczęciem kodowania; gdy źródłem są urządzenia lub programy do przechwytywania ekranu, rozmiar wejścia nie może zostać wykryty przed kodowaniem. Z tego względu, gdy źródłem są urządzenia lub programy przechwytywania ekranu, należy określić rozmiar wejścia podczas przycinania lub zmiany rozmiaru wideo. Gdy zostanie to zrobione, koder wykryje bieżący rozmiar wejścia po rozpoczęciu kodowania. Jeśli rzeczywisty rozmiar wejścia będzie inny niż określony, do bieżącego rozmiaru wejścia zostanie zastosowana procentowa wartość przycięcia (a nie bieżąca wartość w pikselach).

Na przykład rozmiar wyjściowy został określony na 100 x 200 pikseli i określono następujące wartości przycinania:

  • Góra: 4 (2 procent wysokości)
  • Dół: 4 (2 procent wysokości)
  • Lewa: 10 (10 procent szerokości)
  • Prawa: 10 (10 procent szerokości)

Jeśli koder wykrył, że rzeczywisty rozmiar to 200 x 400, rzeczywiste wartości przycięcia będą zgodne z procentową wartością przycięcia:

  • Góra: 8 (2 procent wysokości)
  • Dół: 8 (2 procent wysokości)
  • Lewa: 20 (10 procent wysokości)
  • Prawa: 20 (10 procent wysokości)

Przycinanie sprzętowe

Jeśli karta przechwytywania obsługuje sprzętowe przycinanie, zaleca się użycie sprzętowego przycinania wideo. Informacje na temat sprzętowego przycinania znaleźć można w dokumentacji karty przechwytywania.

Jeśli karta przechwytywania nie obsługuje sprzętowego przycinania lub jeśli źródłem jest plik, przycięte wideo nie będzie wyświetlane w obszarze Wejście w panelu Wideo dopóki kodowanie nie zostanie rozpoczęte.

Zmienianie rozmiaru

W celu uzyskania najlepszych rezultatów nie należy zmieniać rozmiaru wyjściowego wideo. Zmiana rozmiaru może spowodować utworzenie wyjścia o niższej jakości. Jednak w przypadku kodowania do pliku za pomocą kodera-dekodera Windows Media Video 9, gdy czas kodowania nie jest istotny, można zwiększyć jakość zawartości, której rozmiar ma zostać zmieniony, dostosowując ustawienia wydajności w opcji Koduj do pliku na wyższą jakość. Należy zwrócić uwagę, że w przypadku użycia tej metody czas kodowania znacznie się zwiększa.

obrazek „Uwagi” Uwaga

  • Nie należy zmieniać rozmiaru obrazu podczas kodowania ekranu, ponieważ może to spowodować niską jakość zakodowanej zawartości.

Tematy pokrewne

  • Dostosowywanie sesji
  • Dostosowanie ustawień wydajności kodera
  • Przycinanie i zmienianie rozmiaru wideo
  • Dopasowanie rozmiaru klatki do źródłowego wideo


Dopasowanie rozmiaru klatki do źródłowego wideo

transparent programu Windows Media Encoder

Aby dopasować rozmiar klatki do źródłowego wideo

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Kliknij przycisk Edytuj, a następnie kliknij kartę szybkości transmisji bitów.
  3. Zaznacz pole wyboru Taki sam jak wejście wideo.

Tematy pokrewne

  • Przycinanie i zmienianie rozmiaru wideo przed zakodowaniem


Przycinanie i zmienianie rozmiaru wideo

transparent programu Windows Media Encoder

Aby przyciąć lub zmienić rozmiar wideo

  1. Na pasku narzędzi kliknij polecenie Właściwości, a następnie kartę Rozmiar wideo.
  2. Na liście źródeł kliknij źródło, które chcesz przyciąć. (Wymagane tylko w przypadku sesji z wieloma źródłami.)
  3. Jeśli źródłem są urządzenia lub ekrany, w polu Przycięcie wpisz rozmiar wejściowy.
  4. W polu Metoda przycinania kliknij pozycję Niestandardowa lub jedną z domyślnych wartości przycinania.
  5. Jeśli wybrano przycinanie niestandardowe, wpisz liczbę pikseli do przycięcia z góry, z dołu, z lewej i z prawej strony.
  6. W polu Metoda zmiany rozmiaru kliknij jedną z następujących opcji:
    • Taki sam jak profil. Zwiększa wymiary wideo wyjściowego w celu dopasowania do rozmiaru klatki podanego w profilu.
    • Bez zmiany rozmiaru. Wymiary wideo wyjściowego odpowiadają wymiarom przyciętego wideo wejściowego.
    • Automatyczna. Jeśli źródłem jest plik, wymiary wideo wyjściowego są zmieniane w celu wykorzystania szerokości pasma określonej w profilu, a jednocześnie próbowane jest zachowanie współczynnika proporcji przyciętego obrazu wejściowego. Jeśli rozmiar wejściowy określony w kroku 4 jest różny od rozmiaru wejściowego, rozmiary wideo wyjściowego odpowiadają rozmiarom przyciętego wideo wejściowego.
    • Niestandardowa. Umożliwia określenie niestandardowych wymiarów wideo wyjściowego.
  7. Podczas kodowania zawartości MBR kliknij i dopasuj inną szybkość transmisji bitów. (Opcja ta jest dostępna tylko po wybraniu metody zmiany rozmiaru Niestandardowa lub Taki sam jak profil dla pierwszej szybkości transmisji bitów.)

obrazek „Uwaga” Uwaga

  • W przypadku przycinania zawartości, z której usuwany jest przeplot lub do której stosowany jest filtr inverse telecine, wartości przycinania górnego i dolnego muszą być podzielne przez 2.

Tematy pokrewne

  • Przycinanie i zmienianie rozmiaru wideo przed zakodowaniem
  • Optymalizowanie wideo i audio


Zachowywanie współczynnika proporcji pikseli w wideo

Jeśli źródło wideo ma niekwadratowe piksele, można zachować ich współczynnik proporcji. Sprawdź dokumentację urządzenia wideo, aby dowiedzieć się, czy korzysta z niekwadratowych pikseli.

Współczynnik proporcji pikseli to stosunek szerokości piksela (x) do jego wysokości (y). Kwadratowy piksel ma współczynnik proporcji 1:1, ale niekwadratowy (prostokątny) piksel nie ma takiej samej wysokości i szerokości. Ta koncepcja jest podobna do współczynnika proporcji klatki, który jest stosunkiem szerokości obrazu do jego wysokości. Jednak te współczynniki proporcji nie muszą być ze sobą ściśle związane. Na przykład obraz panoramiczny ze współczynnikiem proporcji 16:9 może być złożony z kwadratowych lub niekwadratowych pikseli.

ten sam współczynnik proporcji klatki i różne współczynniki proporcji pikseli

Jeśli kodujesz źródło wideo z niekwadratowymi pikselami w ten sam sposób jak z kwadratowymi, obraz wyjściowy będzie zniekształcony, jak na poniższym rysunku.

kodowanie obrazu z niekwadratowymi pikselami bez zachowywania ich współczynnika proporcji

Jeśli znasz współczynnik proporcji klatki (Ix:Iy) i dokładną wysokość i szerokość źródła obrazu, do określenia wartości x i y współczynnika proporcji pikseli można użyć następującego wzoru.

WspółczynnikProporcjiPikseliX / WspółczynnikProporcjiPikseliY = (Ix * wysokość) / (Iy * szerokość)

Jeśli na przykład obraz ma wymiar 720 na 360 pikseli, a współczynnik proporcji jest panoramiczny (16:9), to WspółczynnikProporcjiPikseliX=8 i WspółczynnikProporcjiPikseliY=9:

WspółczynnikProporcjiPikseliX / WspółczynnikProporcjiPikseliY = (16*360) / (9*720) = 8/9

obrazek „Uwaga” Uwagi

  • Jeśli ustawisz rozmiar wyjścia wideo taki sam, jak źródła wideo, a źródło wideo ma niekwadratowe piksele, to współczynnik proporcji pikseli źródła wideo zostanie automatycznie zachowany w wyjściu wideo.
  • Zachowanie współczynnika proporcji pikseli wideo powoduje zwiększenie rozmiaru pliku lub szybkości transmisji bitów strumienia.

Tematy pokrewne

  • Dostosowywanie sesji
  • Zachowywanie współczynnika proporcji pikseli w wideo
  • Dopasowanie rozmiaru klatki do źródłowego wideo


Zachowywanie współczynnika proporcji pikseli w wideo

transparent programu Windows Media Encoder

Aby zachować współczynnik proporcji pikseli w wideo

  1. Na pasku narzędzi kliknij przycisk Właściwości, kliknij kartę Kompresja, a następnie kliknij przycisk Edytuj.
  2. Na karcie Ogólne zaznacz pole wyboru Zezwalaj na wyjście o niekwadratowych pikselach, a następnie kliknij przycisk OK.
  3. Kliknij kartę Rozmiar wideo, a następnie w polu Współczynnik proporcji pikseli określ współczynnik proporcji pikseli w wejściowym wideo. W przypadku korzystania z niestandardowego współczynnika proporcji pikseli wpisywane wartości muszą znajdować się w przedziale od 1 do 255.

Tematy pokrewne

  • Zachowywanie współczynnika proporcji pikseli w wideo


Optymalizowanie wideo i audio

Programu Windows Media Encoder można użyć do usuwania przeplotu wideo źródłowego, które zawiera przeplot, zastosowania filtru inverse telecine do zawartości, która została poddana działaniu funkcji telecine lub zachowania przeplotu w źródłowym wideo.

Jeśli nie ma pewności, czy zawartość źródłowa zawiera przeplot lub została poddana działaniu funkcji telecine, można użyć kodera do wykrycia formatu, klikając przycisk Wykryj na karcie Przetwarzanie na panelu Właściwości.

Jeśli zawartość audio to głównie głos z dodaną muzyką, można użyć kodera-dekodera Windows Media Audio 9 Voice i zoptymalizować zawartość pod kątem głosu.

Tematy pokrewne

  • Dostosowywanie sesji
  • Usuwanie lub zachowywanie przeplotu w wideo
  • Stosowanie filtru inverse telecine do wideo
  • Optymalizowanie audio dla głosu


Usuwanie lub zachowywanie przeplotu w wideo

Klatka wideo może posiadać przeplot lub może być progresywna. Klatka wideo z przeplotem zawiera dla każdej klatki dwa pola przechwycone w dwóch różnych momentach czasowych. Gdy renderowany jest obraz wideo, najpierw wyświetlane są linie pierwszego pola, a następnie linie drugiego pola. Odwrotnie, w progresywnej klatce wideo linie w każdej klatce są rysowane sekwencyjne. Zawartość z przeplotem jest częściej stosowana, ponieważ standardy NTSC i PAL używają sygnałów wideo z przeplotem.

Usuwanie przeplotu z wideo

Gdy odtwarzane jest wideo z przeplotem na wyświetlaczu ze skanowaniem progresywnym, takim jak komputer, podczas wyświetlania pól może wystąpić miganie. Usuwanie przeplotu to proces tworzenia progresywnej klatki wyjścia wideo z klatki z przeplotem, co zmniejsza miganie. Koder posiada trzy filtry usuwania przeplotu. To, który filtr zostanie użyty przez koder, zależy od różnic między rozmiarem klatek wejściowych i wyjściowych, oraz od szybkości klatek wejściowych i wyjściowych.

  • Normalne usuwanie przeplotu. Jest to domyślny filtr używany po wybraniu opcji usuwania przeplotu. Ten filtr łączy nieparzyste i parzyste pola klatki z przeplotem w celu utworzenia klatki progresywnej, tak jak pokazano na poniższym diagramie.

    normalne usuwanie przeplotu

  • Usuwanie przeplotu, połowa wysokości. Ten filtr jest używany, gdy liczba linii określona dla wyjściowego wideo jest równa połowie (lub mniej) liczby linii wideo wejściowego. Na przykład ten filtr jest używany, gdy rozdzielczość klatek wideo wejściowego to 640x480 pikseli, a rozdzielczość wyjściowa to 320x240 pikseli. Ten filtr używa algorytmu, który łączy ze sobą pola, zamiast usuwać jedno z pól danych. Wynikiem jest wideo wyjściowe o wyższej jakości.
  • Usuwanie przeplotu, połowa wysokości, podwójna szybkość klatek. Ten filtr jest używany, gdy liczba linii określona dla wyjściowego wideo jest równa połowie (lub mniej) wideo wejściowego, a szybkość klatek wyjścia jest dwukrotnie wyższa niż szybkość klatek wejścia. Ten filtr tworzy ramkę z każdego pola w sekwencji wideo, co pokazano na poniższym diagramie.

    usuwanie przeplotu, połowa wysokości, podwójna szybkość klatek

    Korzyści z użycia tego filtru są takie, że tworzy on klatki progresywne o wysokiej jakości, ponieważ nie ma konieczności łączenia informacji pomiędzy polami. Ponadto zachowywany jest pełny ruch przeplatanych pól. Jednak ten filtr ma wyższe wymagania dotyczące wydajności i szybkości transmisji bitów.

Usuwanie przeplotu nie jest obsługiwane w przypadku źródeł, które nie mają przeplotu.

Zachowywanie przeplotu w wideo źródłowym

Zachowanie przeplotu w wideo jest przydatne, jeśli będzie ono wyświetlane na urządzeniach do odtwarzania z przeplotem, takich jak telewizory. Aby można było użyć tej opcji, należy użyć kodera-dekodera Windows Media Video 9. Ponadto użytkownik odtwarzający zawartość musi posiadać system Microsoft Windows XP, odtwarzacz utworzony w oparciu o pakiet Windows Media Format 9 Series Software Development Kit (SDK) oraz kartę graficzną obsługującą przeplot; w przeciwnym razie przeplot zostanie automatycznie usunięty z zawartości.

Jeśli źródłowe wideo jest mieszane (progresywne i z przeplotem) i wybrana zostanie opcja Zachowaj przeplot, wideo wyjściowe również będzie mieszane.

obrazek „Uwaga” Uwagi

  • Niektóre karty przechwytywania obsługują sprzętowe usuwanie przeplotu. Zalecane jest używanie sprzętowego usuwania przeplotu, jeśli jest to możliwe.
  • Zachowanie przeplotu w wideo źródłowym podczas kodowania z niską szybkością klatek (na przykład 15 klatek na sekundę) może spowodować powstanie niepożądanych zakłóceń w zakodowanej zawartości. Dlatego w przypadku kodowania z niską szybkością klatek zaleca się usunięcie przeplotu z wideo, nawet jeśli zawartość ma być wyświetlana na urządzeniu stosującym przeplot.

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Usuwanie przeplotu z wideo
  • Zachowywanie przeplotu w wideo


Usuwanie przeplotu z wideo

transparent programu Windows Media Encoder

Aby usunąć przeplot z wideo

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Przetwarzanie.
  2. Kliknij źródło, z którego chcesz usunąć przeplot. (Wymagane tylko w sesjach wieloźródłowych.)
  3. Kliknij opcję Bez przeplotu.

obrazek „Uwaga” Uwagi

  • Filtr usuwania przeplotu należy stosować tylko do źródeł wideo, w których wcześniej zastosowano przeplot.
  • Filtru usuwania przeplotu nie należy stosować przy przechwytywaniu ekranów.

Tematy pokrewne

  • Usuwanie lub zachowywanie przeplotu w wideo


Zachowywanie przeplotu w wideo

transparent programu Windows Media Encoder

Aby zachować przeplot w wideo

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Kliknij przycisk Edytuj, a następnie zaznacz pole wyboru Zezwalaj na przetwarzanie z przeplotem.
  3. Kliknij kartę Przetwarzanie.
  4. Kliknij źródło, w którym ma być zachowany przeplot. (Jest to konieczne tylko w przypadku sesji o wielu źródłach.)
  5. Kliknij przycisk Zachowaj przeplot.
  6. Jeśli wiesz, które pole w zawartości jest pierwsze, kliknij opcję Pierwszy z góry lub Pierwszy z dołu. Jeśli nie wiesz, które pole jest pierwsze, kliknij opcję Automatyczny.

obrazek „Uwaga” Uwaga

  • Aby zachować przeplot w wideo, należy użyć kodera-dekodera Windows Media Video 9.

Tematy pokrewne

  • Usuwanie lub zachowywanie przeplotu w wideo


Stosowanie filtru inverse telecine do wideo

Proces inverse telecine usuwa klatki dodane podczas działania funkcji telecine po konwersji filmu (24 k/s) na wideo w systemie NTSC (29,97 lub 30 k/s). Filtr inverse telecine usuwa artefakty i poprawia jakość zakodowanej zawartości, szczególnie przy niskich szybkościach transmisji bitów.

Zawartość jest poddawana działaniu funkcji telecine zgodnie z techniką „dobierania 3:2” (3:2 pulldown), wykorzystywaną do tworzenia dodatkowych klatek. Jeśli technika ta jest używana w całym wideo źródłowym, wideo jest określane jako spójne. Jednakże zawartość wideo często jest niespójna, co oznacza przerwy w stosowaniu „dobierania 3:2”. Na przykład tego typu przerwy lub niespójności mogą zostać wprowadzone podczas edycji wideo. Jeśli zawartość jest niespójna, można wybrać określoną klatkę, od której zaczyna się stosowanie techniki „dobierania 3:2”. Można też wykrywać ten efekt automatycznie.

Funkcja inverse telecine nie jest obsługiwana w następujących źródłach:

  • Źródło NTSC, którego nie poddano wcześniej działaniu funkcji telecine.
  • Zawartość, w której zastosowano kompresję czasu.
  • Zawartość, w której jest zachowywany lub tworzony kod czasowy.

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Stosowanie filtru inverse telecine do wideo


Stosowanie filtru inverse telecine do wideo

transparent programu Windows Media Encoder

Aby do wideo zastosować filtr inverse telecine

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Przetwarzanie.
  2. Kliknij źródło, do którego chcesz zastosować filtr inverse telecine. (Wymagane tylko w sesjach wieloźródłowych.)
  3. Kliknij opcję Inverse telecine.
  4. Jeżeli zawartość jest spójna i chcesz ograniczyć regulacje dotyczące przerw, z listy wybierz początkową klatkę materiału.

obrazek „Uwaga” Uwagi

  • Filtru inverse telecine należy używać tylko w przypadku źródeł wideo, które wcześniej poddano działaniu funkcji telecine z zastosowaniem szybkości 30 klatek na sekundę.
  • Filtru inverse telecine nie należy stosować przy przechwytywaniu ekranów.

Tematy pokrewne

  • Stosowanie filtru inverse telecine do wideo


Optymalizowanie audio dla głosu

Jeśli źródłem jest sygnał audio składający się całkowicie lub głównie z głosu, należy użyć kodera-dekodera Windows Media Audio 9 Voice, który jest zaprojektowany do kodowania głosu. Można zoptymalizować zachowanie kodera-dekodera przez zidentyfikowanie, czy zawartość jest tylko głosem lub czy zawiera niewiele muzyki. Jeśli audio jest połączeniem głosu i muzyki, podczas kodowania koder-dekoder automatycznie użyje odpowiedniego algorytmu optymalizującego kodowanie zawartości (głos lub muzyka). Można również utworzyć plik definicji optymalizacji, który jest plikiem tekstowym identyfikującym miejsca w pliku, w których muzyka się zaczyna i kończy. Nieokreślone części pliku są traktowane jako głos.

W przypadku korzystania z kodera-dekodera Windows Media Audio 9 Voice w sesji z wieloma źródłami należy zapoznać się z sekcją Korzystanie z wielu źródeł podczas sesji w celu uzyskania informacji na temat zachowania kodera-dekodera.

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Optymalizowanie audio dla głosu
  • Tworzenie pliku definicji optymalizacji audio


Optymalizowanie audio dla głosu

transparent programu Windows Media Encoder

Aby zoptymalizować audio dla głosu

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Kliknij przycisk Edytuj, a następnie w obszarze Tryb kliknij pozycję CBR.
  3. W obszarze Koder-dekoder kliknij opcję Windows Media Audio 9 Voice, a następnie kliknij przycisk OK.
  4. Kliknij kartę Przetwarzanie, a następnie kliknij opcję Tylko głos lub Audio ze wzmocnieniem głosu.

    W przypadku audio ze wzmocnieniem głosu można utworzyć plik definicji optymalizacji określający miejsca w danych audio, w których muzyka się zaczyna i kończy.

  5. W przypadku utworzenia pliku definicji optymalizacji wprowadź nazwę pliku.

Tematy pokrewne

  • Optymalizowanie audio dla głosu
  • Tworzenie pliku definicji optymalizacji audio


Tworzenie pliku definicji optymalizacji audio

transparent programu Windows Media Encoder

Aby utworzyć plik definicji optymalizacji audio

  1. Za pomocą edytora tekstu, na przykład Notatnika, utwórz plik tekstowy.
  2. Wpisz numer wersji i liczbę segmentów muzycznych zawartych w pliku.

    Numer wersji powinien zawsze mieć wartość 1.

  3. Wpisz czasy rozpoczęcia i zakończenia każdego segmentu (w milisekundach), oddzielając każdy z tych czasów przecinkiem.

    Na przykład wpisanie wartości 1, 3, 0, 10000, 50000, 80000, 150000 i 200000 wskazuje, że istnieją trzy segmenty muzyczne; koder-dekoder przełączy się do trybu muzyki pomiędzy 0 a 10 sekundą, pomiędzy 50 a 80 sekundą oraz pomiędzy 150 a 200 sekundą.

  4. Zakoduj plik tekstowy w formacie Unicode.

    Jeżeli plik tworzony jest za pomocą Notatnika, w celu zapisania go w formacie Unicode należy wybrać polecenie Zapisz z menu Plik, a następnie w polu Kodowanie kliknąć pozycję Unicode.

Tematy pokrewne

  • Optymalizowanie audio dla głosu


Określanie języka dla zawartości

Podczas kodowania zawartości język jest automatycznie kojarzony z zawartością. Można też kodować zawartość w innych językach. Następnie można użyć Edytora strumieni Windows Media, aby dodać inne języki do pliku. Później użytkownicy mogą wybrać język, który będzie słyszany podczas odtwarzania zawartości.

Tematy pokrewne

  • Określanie języka dla zawartości


Określanie języka dla zawartości

transparent programu Windows Media Encoder

Aby określić język dla zawartości

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Kliknij przycisk Edytuj.
  3. Z listy Język wybierz język.

Tematy pokrewne

  • Określanie języka dla zawartości


Stosowanie kompresji czasu w zawartości

Stosując kompresję czasu w zawartości wideo podczas jej kodowania, można przyspieszyć lub zwolnić odtwarzanie zawartości. Przyspieszenie zawartości zmniejsza ilość czasu potrzebną do obejrzenia lub wysłuchania całego pliku, co jest przydatne, gdy trzeba dopasować zawartość do określonego przedziału czasu. Zwolnienie zawartości może ułatwić zrozumienie w sytuacji, gdy materiał zawiera złożone kwestie techniczne lub język nie jest ojczystym językiem użytkowników. Użycie kompresji podlega następującym wymaganiom:

  • Źródło musi zawierać zawartość audio.
  • Każde źródło w sesji musi być plikiem.
  • Należy kodować do pliku. (Kompresja czasu nie jest obsługiwana w emisjach.)
  • Należy korzystać z trybu kodowania jednoprzebiegowego (jednoprzebiegowe CBR lub VBR w oparciu o jakość).
  • Razem z kompresją czasu nie można stosować filtru inverse telecine.
  • Razem z kompresją czasu nie można stosować funkcji pętli.
  • Kompresji czasu nie można stosować, jeżeli źródłem jest audio wielokanałowe.

Jeśli źródłem audio i wideo są osobne pliki, kodowanie zostanie zatrzymane po osiągnięciu końca krótszego pliku.

Program Windows Media Encoder ma dwie funkcje kompresji czasu, których można używać niezależnie lub wspólnie:

  • Przyspieszanie i zwalnianie klatek audio i wideo. Przyspieszanie i spowalnianie nie ma wpływu na wysokość dźwięku strumienia audio.
  • Wykrywanie i usuwanie przerw w dźwięku lub ruchu. Z audio usuwane są okresy ciszy, z wideo usuwane są klatki. Jeśli tworzony jest plik dziennika, czasy rozpoczęcia i zakończenia usuniętych segmentów zapisywane są w dzienniku w celu ich trwałej rejestracji.

Przed użyciem kompresji czasu należy rozpocząć od audio o najwyższej możliwej jakości. Artefakty lub szum w zawartości źródłowej zostaną uwypuklone po przyspieszeniu. Szum w zawartości źródłowej obniża także dokładność usuwania pauz.

Należy zawsze sprawdzać zawartość, aby upewnić się, że osiągnięto wymagane wyniki. Aby przeprowadzić test, należy zakodować część zawartości z wykorzystaniem kompresji czasu, a następnie odtworzyć ją. Jeśli wyniki nie są zadowalające, należy dostosować ustawienie kompresji czasu, a następnie zakodować zawartość ponownie.

Tematy pokrewne

  • Dostosowywanie sesji
  • Przyspieszanie lub zwalnianie klatek audio i wideo
  • Usuwanie pauz z zawartości


Przyspieszanie lub zwalnianie klatek audio i wideo

transparent programu Windows Media Encoder

Aby przyspieszać lub zwalniać klatki audio i wideo

  1. Skonfiguruj sesję, w której źródłami są pliki.
  2. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  3. Zaznacz pole wyboru Kompresja czasu, a następnie kliknij przycisk Właściwości.
  4. Przesuń suwak, aby dostosować przyspieszenie stosowane do zawartości. Można zwolnić odtwarzanie maksymalnie o 50 procent lub przyspieszyć maksymalnie o 250 procent.

Tematy pokrewne

  • Stosowanie kompresji czasu w zawartości
  • Pobieranie źródła z pliku


Usuwanie pauz z zawartości

transparent programu Windows Media Encoder

Aby usunąć pauzy z zawartości

  1. Skonfiguruj sesję, której źródłami są pliki.
  2. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  3. Zaznacz pole wyboru Kompresja czasu, a następnie kliknij przycisk Właściwości.
  4. Zaznacz pole wyboru Włącz usuwanie pauz.
  5. Aby utworzyć plik dziennika, który zawierać będzie usunięte segmenty razem z sygnaturami czasowymi, kliknij przycisk Opcje, a następnie wprowadź nazwę pliku dziennika.

Tematy pokrewne

  • Stosowanie kompresji czasu w zawartości
  • Pobieranie źródła z pliku


Korzystanie z kodowania CBR

W kodowaniu CBR określa się szybkość transmisji bitów, która ma zostać utrzymana, a następnie rozmiar buforu. Szybkość transmisji bitów będzie wahać się w różnych miejscach strumienia, ale wahania te są ograniczane przez rozmiar buforu. Jakość zawartości również się zmienia, aby zapewnić, że bufor nie opróżni się ani nie przepełni. (Aby zagwarantować jakość kodowanego wyjścia, należy użyć kodowania VBR w oparciu o jakość.) Rozmiar buforu określa wielkość początkowego opóźnienia podczas odtwarzania zawartości, ale użycie kodowania CBR zapewnia, że zawartość jest odtwarzana płynnie, przy założeniu że szybkość transmisji bitów jest zgodna z szybkością połączenia klienta. Jeśli jest to możliwe, należy używać dwuprzebiegowego kodowania CBR, aby uzyskać najwyższą jakość bez utraty korzyści wynikających z kodowania CBR. Kodowanie dwuprzebiegowe nie jest obsługiwane we wszystkich scenariuszach.

Tematy pokrewne

  • Dostosowywanie sesji
  • Kodowanie CBR lub VBR – informacje
  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Wymagania funkcji
  • Konfigurowanie sesji kodowania CBR


Konfigurowanie sesji kodowania CBR

transparent programu Windows Media Encoder

Aby skonfigurować sesję kodowania CBR

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Na liście Miejsce docelowe kliknij miejsce docelowe, które obsługuje kodowanie CBR i odpowiada scenariuszowi odtwarzania.
  3. W obszarach Wideo i Audio wybierz ustawienia jakości odpowiednie dla audio i wideo.
  4. Jeśli ma być włączone dwuprzebiegowe kodowanie CBR, zaznacz pole wyboru Kodowanie dwuprzebiegowe.

obrazek „Uwaga” Uwaga

  • Kodowanie dwuprzebiegowe nie jest dostępne w pewnych scenariuszach.

Tematy pokrewne

  • Korzystanie z kodowania CBR
  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Wymagania funkcji


Korzystanie z kodowania VBR

Program Windows Media Encoder obsługuje trzy tryby kodowania VBR:

  • Kodowanie VBR w oparciu o jakość. Podczas kodowania VBR w oparciu o jakość użytkownik określa wymagany poziom jakości (od 0 do 100). Następnie podczas kodowania szybkość transmisji bitów zmienia się w zależności od złożoności strumienia – większa szybkość transmisji bitów używana jest w przypadku dużej ilości szczegółów lub ruchu, a mniejsza szybkość transmisji bitów używana jest dla prostej zawartości. Zaletą kodowania VBR w oparciu o jakość jest to, że jakość pozostaje taka sama we wszystkich strumieniach, dla których określono te same ustawienia jakości. Wadą jest to, że przed kodowaniem nie można przewidzieć rozmiaru pliku ani wymagań dotyczących przepustowości dla kodowanej zawartości. Kodowanie VBR w oparciu o jakość wykorzystuje kodowanie jednoprzebiegowe. Tryb ten nadaje się do archiwizacji zawartości.

    Podczas kodowania zawartości audio w tym trybie kodowania, dostępna jest opcja użycia kodera-dekodera Windows Media Audio 9 Lossless. Kodowanie bezstratne daje wyniki najwyższej jakości, stosując jednocześnie pewien stopień kompresji danych.

  • Kodowanie VBR w oparciu o szybkość transmisji bitów. Podczas kodowania VBR w oparciu o szybkość transmisji bitów użytkownik określa wymaganą średnią szybkość transmisji bitów. W dowolnym momencie szybkość transmisji bitów może przekroczyć średnią szybkość transmisji bitów, ale całkowita szybkość transmisji bitów nie przekroczy średniej szybkości transmisji bitów. Kodowanie VBR w oparciu o szybkość transmisji bitów następuje w dwóch przebiegach. W pierwszym przebiegu analizowana jest złożoność danych. Następnie w drugim przebiegu ustawiany jest poziom jakości w celu osiągnięcia średniej szybkości transmisji bitów. Zaletą kodowana VBR w oparciu o szybkość transmisji bitów jest to, że skompresowany strumień osiągnie najwyższy możliwy poziom jakości, jednocześnie utrzymując przewidywalną średnią przepustowość.
  • Kodowanie VBR w oparciu o szczytową szybkość transmisji bitów. Kodowanie VBR w oparciu o szczytową szybkość transmisji bitów jest podobne do trybu w oparciu o szybkość transmisji bitów, z tą różnicą, że należy także podać szczytową szybkość transmisji bitów. Koder określa jakość obrazu, którą można osiągnąć bez przekroczenia szczytowej szybkości transmisji bitów. Szybkość transmisji bitów zmienia się podczas kodowania, ale nie przekracza podanej szczytowej szybkości transmisji bitów. Opcji tej należy użyć, jeśli planowana jest dystrybucja do odtwarzania na urządzeniu o ograniczonej możliwości odczytu, na przykład odtwarzaczu CD lub DVD. Kodowanie VBR w oparciu o szczytową szybkość transmisji bitów wykorzystuje kodowanie dwuprzebiegowe.

obrazek „Uwaga” Uwagi

  • Kodowanie VBR obsługują tylko niektóre koder-dekodery.
  • Tryby kodowania VBR w oparciu o jakość i szybkość transmisji bitów nie są zalecane do użycia w scenariuszu przesyłania z powodu wysokich wartości szczytowych szybkości transmisji bitów w zawartości. W scenariuszu przesyłania strumieniowego, gdy wszystkie odtwarzacze osiągają w strumieniu punkt wysokiej szybkości transmisji bitów mniej więcej w tym samym czasie, występuje wysoka wartość szczytowa żądań. Ta wartość szczytowa może przekroczyć przepustowość sieci, co spowoduje nieprawidłowe odtwarzanie.

Tematy pokrewne

  • Dostosowywanie sesji
  • Kodowanie CBR lub VBR – informacje
  • Korzystanie z kodowania CBR
  • Wymagania funkcji
  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Konfigurowanie sesji kodowania VBR w oparciu o jakość
  • Kodowanie bezstratnego audio
  • Konfigurowanie sesji kodowania VBR w oparciu o szybkość transmisji bitów
  • Konfigurowanie sesji kodowania VBR w oparciu o szczytową szybkość transmisji bitów


Konfigurowanie sesji kodowania VBR w oparciu o jakość

transparent programu Windows Media Encoder

Aby skonfigurować sesję kodowania VBR w oparciu o jakość

  1. Na pasku narzędzi kliknij przyciskWłaściwości, a następnie kliknij kartę Kompresja.
  2. Na liście Miejsce docelowe kliknij pozycję Archiwum plików.
  3. W obszarach Wideo i Audio wybierz ustawienia jakości odpowiednie dla audio i wideo.

    -lub-

    Kliknij przycisk Edytuj, kliknij kartę W oparciu o jakość, a następnie w polu Jakość wideo wpisz wymagane ustawienia jakości. Ustawienia mogą należeć do zakresu od 0 do 100, gdzie 100 oznacza najwyższą jakość.

Tematy pokrewne

  • Korzystanie z kodowania VBR


Kodowanie bezstratnego audio

transparent programu Windows Media Encoder

Aby kodować bezstratne audio

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij pozycję Archiwum plików.
  3. W obszarze Audio kliknij pozycję Audio o bezstratnej jakości.

Tematy pokrewne

  • Korzystanie z kodowania VBR


Konfigurowanie sesji kodowania VBR w oparciu o szybkość transmisji bitów

transparent programu Windows Media Encoder

Aby skonfigurować sesję kodowania VBR w oparciu o szybkość transmisji bitów

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij Pobieranie pliku.
  3. W obszarach Wideo i Audio wybierz ustawienia dla wideo i audio.

    -lub-

    Określ własne ustawienia, klikając przycisk Edytuj.

obrazek „Uwaga” Uwaga

  • Ten tryb VBR używa kodowania dwuprzebiegowego. Kodowanie dwuprzebiegowe nie jest dostępne w niektórych scenariuszach.

Tematy pokrewne

  • Korzystanie z kodowania VBR
  • Kodowanie jedno- i dwuprzebiegowe – informacje


Konfigurowanie sesji kodowania VBR w oparciu o szczytową szybkość transmisji bitów

transparent programu Windows Media Encoder

Aby skonfigurować sesję kodowania VBR w oparciu o szczytową szybkość transmisji bitów

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij opcję Urządzenia sprzętowe.
  3. W obszarze Wideo i Audio wybierz ustawienia dla wideo i audio.

    -lub-

    Określ własne ustawienia, klikając przycisk Edytuj.

obrazek „Uwaga” Uwaga

  • Ten tryb VBR używa kodowania dwuprzebiegowego. Kodowanie dwuprzebiegowe nie jest dostępne w niektórych scenariuszach.

Tematy pokrewne

  • Korzystanie z kodowania VBR
  • Kodowanie jedno- i dwuprzebiegowe – informacje


Konfigurowanie strumienia MBR

Jeśli planowane jest dostarczanie zawartości w postaci strumienia emisji pojedynczej z serwera programu Microsoft Windows Media Services, to kodowanie strumienia z wieloma szybkościami transmisji bitów (MBR) oferuje użytkownikom lepszą jakość zawartości podczas przeciążenia sieci. Gdy zostanie skonfigurowany strumień MBR, zawartość jest kodowana z każdą określoną szybkością transmisji bitów. Gdy odtwarzacz odbiera strumień MBR, odtwarzany jest tylko strumień najodpowiedniejszy dla aktualnych warunków w sieci. Serwer i odtwarzacz Windows Media obsługują proces wybierania odpowiedniego strumienia w sposób niewidoczny dla użytkownika. Ponieważ strumień MBR jest przeznaczony tylko do przesyłania strumieniowego, podczas kodowania strumienia MBR można używać wyłącznie kodowania CBR.

Można kodować strumień MBR zarówno dla zawartości audio, jak i wideo, jednak nie jest konieczne używanie kodowania MBR zarówno dla audio, jak i wideo w strumieniu. Na przykład można przesyłać strumieniowo audio z jedną szybkością transmisji bitów, a wideo z wieloma szybkościami transmisji bitów.

Podczas konfigurowania strumienia MBR należy pamiętać, że im więcej szybkości transmisji bitów zostanie wybranych, tym większa zsumowana przepustowość będzie wymagana do przesyłania strumienia na żywo z kodera do serwera Windows Media. Aby oszacować zsumowaną przepustowość profilu MBR, należy obliczyć sumę wszystkich szybkości transmisji bitów audio i wideo i szybkości transmisji bitów skryptu. Należy również pamiętać, że kodowanie strumienia MBR wykorzystuje więcej mocy obliczeniowej komputera kodującego.

W przypadku korzystania z kodera-dekodera Windows Media Audio 9 Voice w sesji MBR, gdy określony zostanie mieszany tryb z głosem i muzyką, zaleca się pominięcie w sesji wszystkich szybkości transmisji bitów poniżej 8 kilobitów/s (Kb/s). Powodem tego jest fakt, że wszystkie szybkości transmisji bitów poniżej 8 Kb/s zostaną zakodowane w trybie tylko głos, co może spowodować pogorszenie się jakości zawartości audio.

Tematy pokrewne

  • Dostosowywanie sesji
  • Kodowanie strumienia MBR
  • Kodowanie audio o pojedynczej szybkości transmisji bitów z wideo MBR
  • Kodowanie wideo o pojedynczej szybkości transmisji bitów z audio MBR


Kodowanie strumienia MBR

transparent programu Windows Media Encoder

Aby zakodować strumień MBR

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W polu Miejsce docelowe kliknij opcję Serwer Windows Media.
  3. W polach Wideo i Audio wybierz odpowiednie ustawienia jakości.
  4. W polu Szybkości transmisji bitów zaznacz szybkości transmisji bitów dla przesyłania strumieniowego.

    -lub-

    Kliknij przycisk Edytuj, a następnie kliknij przycisk Dodaj. Zostanie wyświetlone okno dialogowe Dodawanie szybkości transmisji bitów. Wpisz szybkość transmisji bitów, którą chcesz uwzględnić w strumieniu o wielu szybkościach.

obrazek „Uwaga” Uwagi

  • Należy wybrać szybkości transmisji bitów, które spełnią wymagania docelowych odbiorców dotyczące odtwarzania.
  • Kodowanie o wielu szybkościach transmisji bitów nie musi być stosowane jednocześnie do audio i do wideo w strumieniu. Można na przykład do strumienia audio zastosować jedną szybkość transmisji bitów, a do składnika wideo w strumieniu — wiele szybkości.

Tematy pokrewne

  • Konfigurowanie strumienia MBR
  • Kodowanie audio o pojedynczej szybkości transmisji bitów z wideo MBR
  • Kodowanie wideo o pojedynczej szybkości transmisji bitów z audio MBR


Kodowanie audio o pojedynczej szybkości transmisji bitów z wideo MBR

transparent programu Windows Media Encoder

Aby kodować audio o pojedynczej szybkości transmisji bitów z wideo MBR

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij pozycję Serwer Windows Media.
  3. W obszarze Wideo i Audio kliknij ustawienia jakości, które mają zostać użyte.
  4. W obszarze Szybkości transmisji bitów wybierz szybkości transmisji bitów dla przesyłania strumieniowego.
  5. Kliknij przycisk Edytuj, a następnie na karcie każdej szybkości transmisji bitów wybierz to samo ustawienie w obszarze Format audio.

Tematy pokrewne

  • Konfigurowanie strumienia MBR
  • Kodowanie wideo o pojedynczej szybkości transmisji bitów z audio MBR


Kodowanie wideo o pojedynczej szybkości transmisji bitów z audio MBR

transparent programu Windows Media Encoder

Aby kodować wideo o pojedynczej szybkości transmisji bitów z audio MBR

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij pozycję Serwer Windows Media.
  3. W obszarach Wideo i Audio kliknij ustawienia jakości, które mają zostać użyte.
  4. W obszarze Szybkości transmisji bitów wybierz szybkości transmisji bitów dla przesyłania strumieniowego.
  5. Kliknij przycisk Edytuj, a następnie na karcie każdej szybkości transmisji bitów wybierz te same ustawienia w obszarze wideo. (Wszystkie ustawienia muszą być zgodne, w przeciwnym przypadku podczas kodowania zostanie użytych wiele szybkości transmisji bitów.)

Tematy pokrewne

  • Konfigurowanie strumienia MBR
  • Kodowanie audio o pojedynczej szybkości transmisji bitów z wideo MBR


Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości

Wykorzystanie kodowanej zawartości można kontrolować przez jej ochronę za pomocą technologii zarządzania prawami cyfrowymi (DRM) podczas kodowania. Technologię DRM można wykorzystać podczas kodowania do pliku lub podczas emisji strumienia. Zawartość jest kodowana, szyfrowana kluczem, a następnie użytkownicy chcący odtwarzać zawartość żądają licencji. Licencja zawiera klucz służący do odblokowania zawartości oraz prawa zarządzające jej wykorzystaniem. Na przykład licencja określa liczbę odtworzeń zawartości przez użytkownika lub czas wygaśnięcia licencji.

obrazek „Ważne” Ważne

  • Licencje są wydawane przez dostawców licencji innych firm, należy więc skonfigurować konto u dostawcy, aby chronić zawartość.

Kroki prowadzące do korzystania z technologii DRM

Podstawowe kroki w korzystaniu z technologii DRM są następujące:

  1. Skonfiguruj sesję kodowania.
  2. Skonfiguruj konto u dostawcy licencji (jeśli jeszcze go nie masz) i utwórz profil DRM.
  3. W sesji określ profil DRM, który ma zostać użyty z zawartością.
  4. Zakoduj i dystrybuuj zawartość, przesyłając ją strumieniowo lub udostępniając pliki do pobrania.
  5. Gdy użytkownicy odtwarzają chronioną zawartość, odtwarzacz pobiera licencję wydaną przez wybranego dostawcę licencji. Użytkownik może następnie odtwarzać zawartość zgodnie z prawami zawartymi w licencji.

    Aby użytkownicy mogli odtwarzać chronioną zawartość, muszą korzystać z odtwarzacza obsługującego technologię DRM firmy Microsoft. Lista odtwarzaczy znajduje się w witrynie sieci Web firmy Microsoft.

Ponowne wykorzystanie profili DRM

Po utworzeniu profilu DRM można go ponownie wykorzystać w kolejnych sesjach. Można także wyeksportować profil, aby możliwe było jego zaimportowanie do wykorzystania w kodowaniu na innym komputerze. Można również zaimportować profil DRM z innego komputera. W celu zapewnienia bezpieczeństwa profile DRM są stosowane dla konkretnego użytkownika. Uniemożliwia to innym użytkownikom oglądanie, edytowanie i korzystanie z utworzonych przez użytkownika profili DRM. Profile DRM mają rozszerzenie nazwy pliku .drm.

Tematy pokrewne

  • Dostosowywanie sesji
  • Konfigurowanie konta dostawcy licencji
  • Ochrona zawartości za pomocą DRM


Ochrona zawartości za pomocą DRM

transparent programu Windows Media Encoder

Aby chronić zawartość za pomocą DRM

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie Zabezpieczenia.
  2. Jeśli jeszcze nie zostało to zrobione, skonfiguruj konto za pomocą dostawcy licencji i utwórz profil.
  3. Zaznacz pole wyboru Użyj DRM, aby chronić zawartość przed nieautoryzowanym użyciem.
  4. Na liście Profil DRM wybierz profil, który ma zostać użyty w tej sesji.

    Po rozpoczęciu kodowania zawartość zostanie zabezpieczona.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości
  • Konfigurowanie konta dostawcy licencji


Konfigurowanie konta dostawcy licencji

Dostawca licencji musi udzielić licencji na zawartość, którą użytkownik będzie chronić. Konieczne jest skonfigurowanie konta dostawcy licencji obsługującego koder Windows Media Encoder Seria 9. Podczas konfigurowania konta należy wybrać prawa, które zostaną dołączone do licencji. W zależności od serwera licencji użytkownik może być monitowany o określenie innych ustawień, takich jak sposób wydania licencji.

Po skonfigurowaniu konta dostawca licencji tworzy profil DRM i zapisuje go na komputerze lokalnym użytkownika. Następnie można używać profilu do ochrony zawartości. Profil zawiera następujące informacje:

  • Identyfikator profilu DRM
  • Nazwa i opis
  • Atrybuty (pary nazwa-wartość)
  • Adres URL witryny sieci Web dostawcy licencji
  • Adresy URL uzyskania licencji

    Odtwarzacze mogą obsługiwać różne wersje technologii Microsoft DRM: Windows Media Rights Manager w wersji 1 lub 7. Dlatego dla każdej wersji są używane różne adresy URL uzyskania licencji. Każdy adres URL uzyskania licencji wskazuje stronę w witrynie sieci Web dostawcy licencji, na której można uzyskać licencję i znajduje się w nagłówku chronionej zawartości. Gdy użytkownik odtwarza chronioną zawartość, odtwarzacz otwiera odpowiedni adres URL uzyskania licencji w celu pobrania licencji.

Podczas tworzenia profilu DRM następujące wartości są również tworzone i przechowywane na komputerze lokalnym użytkownika:

  • Publiczne i prywatne klucze podpisujące. Dostawca licencji wymaga publicznego klucza podpisującego w celu wydania licencji. Prywatny klucz podpisujący nie jest zwracany.
  • Ziarno klucza licencji. Dla każdego chronionego pliku lub strumienia używane jest ziarno do wygenerowania klucza w celu zaszyfrowania zawartości. Ta wartość jest również używana przez dostawcę licencji w celu przywrócenia tego klucza i zawarcia go w licencji, która jest używana przez odtwarzacz użytkownika do odszyfrowywania zawartości.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości
  • Konfigurowanie konta dostawcy licencji


Konfigurowanie konta dostawcy licencji

transparent programu Windows Media Encoder

Aby skonfigurować konto dostawcy licencji

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij pozycję Zabezpieczenia.
  2. Kliknij przycisk Nowy, a następnie kliknij pozycję Dodaj.
  3. Wykonaj następujące czynności:
    • Określ nazwę i adres URL dostawcy, którego chcesz użyć.
    • Kliknij przycisk Znajdź dostawcę, aby przejść do witryny sieci Web zawierającej listę dostawców, których można wybrać.

    Po zidentyfikowaniu dostawcy zostanie wyświetlone okno dialogowe Nowy profil.

  4. Kliknij nazwę dostawcy na liście, a następnie kliknij przycisk Generuj.

    Zostanie wyświetlony interfejs użytkownika dostarczony przez dostawcę.

  5. Postępuj zgodnie z instrukcjami, aby utworzyć profil DRM dla zawartości. Po utworzeniu profilu można go użyć do zabezpieczenia zawartości.

Tematy pokrewne

  • Konfigurowanie konta dostawcy licencji
  • Ochrona zawartości za pomocą DRM


Osadzanie znaku wodnego w zawartości

W strumieniu można osadzić cyfrowy znak wodny. Znaki wodne są metodą dodawania informacji, takich jak prawa autorskie lub nazwisko wykonawcy, do strumienia audio lub wideo, ale nie są słyszalne ani widoczne dla użytkownika. Znak wodny w zakodowanym pliku jest zabezpieczony i nie można go usunąć. Znak wodny może być używany do identyfikacji zawartości, nawet jeśli była kopiowana lub edytowana.

Aby używać znaków wodnych, należy uzyskać i zarejestrować dodatek innej firmy. Aby uzyskać informacje dotyczące uzyskiwania dodatku obsługującego znaki wodne, zobacz witrynę sieci Web firmy Microsoft.

Tematy pokrewne

  • Dostosowywanie sesji
  • Dodawanie znaku wodnego do zawartości


Dodawanie znaku wodnego do zawartości

transparent programu Windows Media Encoder

Aby dodać znak wodny do zawartości

  1. Jeśli jeszcze tego nie zrobiono, zarejestruj dodatek znaków wodnych, którego chcesz użyć.
  2. Uruchom koder, a następnie w menu Widok kliknij panel Właściwości.
  3. Kliknij kartę Zabezpieczenia.
  4. Jeśli chcesz dodać znak wodny do zawartości wideo, zaznacz pole wyboru Wideo, a następnie na liście kliknij dodatek, którego chcesz użyć.
  5. Jeśli chcesz dodać znak wodny do zawartości audio, zaznacz pole wyboru Audio, a następnie na liście kliknij dodatek, którego chcesz użyć.

obrazek „Uwaga” Uwaga

  • Jeśli używany dodatek znaku wodnego wymaga pliku konfiguracyjnego, kliknij przycisk Konfiguruj, aby określić plik.

Tematy pokrewne

  • Osadzanie znaku wodnego w zawartości


Korzystanie z profili sprzętowych

Zawartość oparta na pakiecie Windows Media nie jest już odtwarzana jedynie na komputerach. Teraz można odtwarzać ją na różnych urządzeniach sprzętowych, takich jak przystawki, bezprzewodowe słuchawki i odtwarzacze DVD. Aby zapewnić, że zawartość można będzie odtwarzać na urządzeniach określonego typu, należy zakodować ją za pomocą profilu sprzętowego. Program Windows Media Encoder zawiera wiele profili sprzętowych, które są zaprojektowane tak, aby spełniać wiele wymagań kodowania.

Nawet jeśli do kodowania zawartości nie są używane profile sprzętowe, nadal można sprawdzić, które typy urządzeń sprzętowych będą odtwarzać zawartość. Cała kodowana zawartość jest mapowana na profil sprzętowy; profil użyty do kodowania jest zaznaczony w oknie dialogowym Wyniki kodowania (w sekcji Zgodność profilu), które jest wyświetlane po ukończeniu kodowania.

Profile wideo

Program Windows Media Encoder zawiera następujące profile sprzętowe: prosty niski, prosty średni, główny niski, główny średni i główny wysoki. Aby uzyskać więcej informacji dotyczących każdego profilu, patrz sekcja Profile sprzętowe dla wideo. Dany profil i poziom zawsze obsługują niższe profile i poziomy. Na przykład urządzenie obsługujące profil główny, poziom średni obsługuje również profil główny, poziom niski oraz wszystkie poziomy w profilu prostym.

Profile audio

W poniższej tabeli przedstawiono w kolejności rosnącej profile sprzętowe dla zawartości audio, które są dołączone do kodera.

Profil audio | Opis
L1 | Dla szybkości przesyłania bitów audio od 64 Kb/s do 128 Kb/s (korzysta z kodera-dekodera Windows Media Audio 9)
L2 | Dla szybkości przesyłania bitów audio mniejszych lub równych 160 Kb/s (korzysta z kodera-dekodera Windows Media Audio 9)
L3 | Dla szybkości przesyłania bitów audio mniejszych lub równych 384 Kb/s (korzysta z kodera-dekodera Windows Media Audio 9)
L | Obsługuje wszystkie szybkości przesyłania bitów; przeznaczone do odtwarzania na komputerach jako demonstracja możliwości kodera-dekodera (korzysta z kodera-dekodera Windows Media Audio 9)
S1 | Dla szybkości przesyłania bitów audio mniejszych lub równych 20 Kb/s, dla zawartości głosu o niskiej złożoności (korzysta z kodera-dekodera Windows Media Audio 9 Voice)

Nie ma możliwości wybrania profili wymienionych w poniższej tabeli podczas konfigurowania sesji. Jeśli jednak kodowane audio spełnia parametry wymienione w tabeli, zawartość zostanie odwzorowana na odpowiedni profil sprzętowy.

Profil audio | Opis
S2 | Dla szybkości przesyłania bitów audio, które są mniejsze lub równe 20 Kb/s, dla mieszanej zawartości będącej muzyką i głosem (korzysta z kodera-dekodera Windows Media Audio 9 Voice)
M1 | Dla szybkości przesyłania bitów audio, które są mniejsze lub równe 384 Kb/s, dla szybkości próbkowania mniejszej lub równej 48 KHz, liczby kanałów 5.1 lub mniejszej; zalecane dla dźwięku przestrzennego do filmów o standardowej jakości (korzysta z kodera-dekodera Windows Media Audio 9 Professional)
M2 | Dla szybkości przesyłania bitów audio, które są mniejsze lub równe 768 Kb/s, dla częstotliwości próbkowania mniejszej lub równej 96 KHz, liczby kanałów 5.1 lub mniejszej; zalecane dla dźwięku przestrzennego do filmów o wysokiej jakości (korzysta z kodera-dekodera Windows Media Audio 9 Professional)
M | Obsługuje wszystkie szybkości transmisji bitów, częstotliwości próbkowania i kanały; zalecane do odtwarzania na komputerach jako demonstracja możliwości kodera-dekodera (korzysta z kodera-dekodera Windows Media Audio 9 Professional)

Łączenie profili audio i wideo

W poniższej tabeli przedstawiono zalecane kombinacje profili sprzętowych dla audio i wideo.

Wideo | Audio
Prosty niski | L2 lub S2
Prosty średni | L2 lub S2
Główny niski | L2 lub S2
Główny średni | L3, S2 lub M1
Główny wysoki | L3, S2 lub M2

Tematy pokrewne

  • Dostosowywanie sesji
  • Konfigurowanie profilu sprzętowego
  • Profile sprzętowe dla wideo


Konfigurowanie profilu sprzętowego

transparent programu Windows Media Encoder

Aby skonfigurować profil sprzętowy

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. Na liście Miejsce docelowe kliknij pozycję Profile sprzętowe Windows Media.
  3. W obszarach Wideo i Audio kliknij wybrany profil i poziom kodowania.

Tematy pokrewne

  • Korzystanie z profili sprzętowych


Profile sprzętowe dla wideo

Ten temat zawiera szczegółowe informacje o profilach sprzętowych dostępnych dla zawartości wideo zainstalowanych w programie Windows Media Encoder.

Profil prosty – poziom niski

Element | Wartość
Urządzenia docelowe | Urządzenia bezprzewodowe
Maksymalna rozdzielczość | 176 x 144
Maksymalna szybkość klatek | 15 k/s
Maksymalna szybkość transmisji bitów | 96 Kb/s
Maksymalny rozmiar buforu | Około 3,4 sekundy przy maksymalnej szybkości transmisji bitów

Profil prosty – poziom średni

Element | Wartość
Urządzenia docelowe | Komputery podręczne, urządzenia PDA i wysokiej klasy urządzenia bezprzewodowe
Maksymalna rozdzielczość | 352 x 288
Maksymalna szybkość klatek | 15 k/s przy rozdzielczości 352 x 288 24 k/s przy rozdzielczości 320 x 240
Maksymalna szybkość transmisji bitów | 384 Kb/s
Maksymalna szybkość transmisji bitów | Około 3,3 sekundy przy maksymalnej szybkości transmisji bitów

Profil główny – poziom niski

Element | Wartość
Urządzenia docelowe | Niezaawansowane przystawki typu set-top box
Maksymalna rozdzielczość | 352 x 288
Maksymalna szybkość klatek | 30 k/s
Maksymalna szybkość transmisji bitów | 2 Mb/s
Maksymalny rozmiar buforu | Około 2,5 sekundy przy maksymalnej szybkości transmisji bitów

Profil główny – poziom średni

Element | Wartość
Urządzenia docelowe | Zaawansowane przystawki typu set-top box; odtwarzacze DVD i karty graficzne z obsługą standardu DirectX Video Acceleration (VA)
Maksymalna rozdzielczość | 720 x 576
Maksymalna szybkość klatek | 30 k/s przy rozdzielczości 720 x 576 (NTSC) 25 k/s przy rozdzielczości 720 x 576 (PAL)
Maksymalna szybkość transmisji bitów | 10 Mb/s
Maksymalny rozmiar buforu | Około 1 sekunda przy maksymalnej szybkości transmisji bitów

Profil główny – poziom wysoki

Element | Wartość
Urządzenia docelowe | Odtwarzacze DVD, karty graficzne z obsługą standardu DirectX VA i filmy cyfrowe
Maksymalna rozdzielczość | 1920 x 1080
Maksymalna szybkość klatek | 30 k/s przy rozdzielczości 1920 x 1080 60 k/s przy rozdzielczości 1280 x 720
Maksymalna szybkość transmisji bitów | 20 Mb/s
Maksymalny rozmiar buforu | Około 2 sekund przy maksymalnej szybkości transmisji bitów

Tematy pokrewne

  • Korzystanie z profili sprzętowych


Korzystanie z dodatków transformacji

Interfejs użytkownika programu Windows Media Encoder oferuje możliwość dostosowywania, dzięki czemu programiści mogą tworzyć dodatki transformacji w celu dostosowania i rozszerzenia istniejących funkcji kodowania. Koder obsługuje filtry transformacji Microsoft DirectShow® i DirectX® Media Object DMO. Dodatki można konfigurować dla poszczególnych źródeł.

Więcej informacji na temat technologii DirectShow można znaleźć w witrynie sieci Web firmy Microsoft. Więcej informacji na temat technologii DirectX Media Object można znaleźć w witrynie sieci Web firmy Microsoft.

Tematy pokrewne

  • Dostosowywanie sesji
  • Korzystanie z dodatku transformacji


Korzystanie z dodatku transformacji

transparent programu Windows Media Encoder

Aby korzystać z dodatku transformacji

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Dodatki.
  2. W obszarze Typ dodatku transformacji kliknij opcję Wideo lub Audio.
  3. Kliknij źródło, z którym będzie używany dodatek. (Wymagane tylko w sesjach z wieloma źródłami.)
  4. Jeśli na liście dostępnych dodatków nie jest wyświetlany żaden dodatek, kliknij przycisk Zarejestruj, a następnie zaznacz pola wyboru dla dodatków, które będą używane. (Aby wyrejestrować dodatek, usuń zaznaczenie jego pola wyboru.)

    Aby zarejestrować dodatek, należy mieć na komputerze kodującym uprawnienia administracyjne.

  5. Na liście dostępnych dodatków kliknij dodatek, a następnie kliknij przycisk przenieś w prawo (>>), aby dodać go do listy dodatków dla danego źródła.
  6. Kliknij przycisk Konfiguruj, aby skonfigurować wybrany dodatek.

obrazek „Ostrożnie” Ostrożnie

  • W oknie dialogowym Rejestrowanie/wyrejestrowanie dodatków transformacji wyświetlana jest lista wszystkich dodatków transformacji dostępnych na komputerze kodującym. Niektóre dodatki mogą być nieodpowiednie do użycia z koderem, a próba ich użycia z koderem może wywołać nieoczekiwane skutki.

Tematy pokrewne

  • Korzystanie z dodatków transformacji


Opcje wyjściowe

Zawartość można zakodować do pliku w celu jej późniejszego użycia lub wyemitować ją na żywo. W przypadku emisji można wypychać strumień do serwera z uruchomionym programem Windows Media Services lub można umożliwić serwerom i odtwarzaczom Windows Media ściąganie strumienia bezpośrednio z kodera. Kopię emisji można zarchiwizować w pliku. Przed i po kodowaniu można:

  • Zmienić port wyjściowy emisji.
  • Wybrać lub anulować archiwizowanie do pliku.
  • Zmienić nazwę lub lokalizację pliku wyjściowego.

Podczas kodowania można:

  • Wybrać lub anulować archiwizowanie do pliku.
  • Zmienić nazwę pliku archiwum, jeśli aktualnie nie trwa archiwizacja.

Podczas kodowania nie można:

  • Zmienić numeru portu.
  • Przełączyć się z sesji emisji na sesję kodowania do pliku.

Tematy pokrewne

  • Windows Media Encoder
  • Kodowanie lub archiwizacja emisji do pliku
  • Kodowanie nieskompresowanych plików audio i wideo
  • Emisja zawartości na żywo
  • Testowanie zawartości


Kodowanie lub archiwizacja emisji do pliku

Zawartość można kodować do pliku; można także archiwizować zdarzenie na żywo w celu późniejszego wykorzystania.

Archiwizacja na serwerze Windows Media a archiwizacja na komputerze kodującym

W przypadku emisji przez serwer Windows Media można archiwizować emisję na serwerze zamiast na komputerze kodującym. Archiwizacja na serwerze Windows Media to najlepsze rozwiązanie, jeżeli:

  • Archiwum ma być natychmiast dostępne do przeglądania.
  • Zasoby na komputerze kodującym są wykorzystywane głównie do kodowania.
  • Na serwerze dostępne jest więcej miejsca na dysku niż na komputerze kodującym.

W przypadku archiwizacji emisji na komputerze kodującym wszystkie źródła skonfigurowane w sesji emisji są archiwizowane automatycznie. Jednakże archiwizacja wszystkich źródeł nie zawsze jest pożądana. Jeżeli na przykład jedno ze źródeł jest reklamą, użytkownik może nie chcieć go archiwizować. Koder może automatycznie wstrzymywać archiwizację dla wybranych źródeł.

Włączanie przeszukiwania w pliku wyjściowym

Indeksowanie w każdej klatce kluczowej włączane jest domyślnie w przypadku archiwizacji lub kodowania do pliku, gdy źródło zawiera wideo. Indeksując zawartość, użytkownicy mogą korzystać z funkcji szybkiego przewijania w przód i w tył podczas przeglądania zakodowanej zawartości. Indeksowanie nie jest dostępne dla emisji. Można także włączyć wyszukiwanie na poziomie klatki w pliku wyjściowym przez utworzenie kodu czasowego (lub zachowanie kodu czasowego wcześniej utworzonego w wideo źródłowym). Kod czasowy można utworzyć, jeśli źródło zawiera wideo i dane źródłowe są pobierane z plików cyfrowego wideo (DV) w formacie AVI (Audio-Video Interleaved), z urządzeń przechwytywania i z urządzeń cyfrowych. Aby zachować kod czasowy dla magnetowidu, należy skonfigurować listę EDL dla sesji. Nie można zachować ani utworzyć kodu czasowego w przypadku stosowania filtru inverse telecine.

Tymczasowe przechowywanie zawartości

Podczas kodowania do pliku w przypadku pobierania sygnału źródłowego z urządzeń, proces kodowania może być wolniejszy od procesu przechwytywania, co obniża jakość zakodowanej zawartości. Aby temu zapobiec, można tymczasowo zapisać przechwyconą zawartość, a następnie zakodować ją do pliku. Jeśli ta opcja zostanie wybrana, przechwytywanie i kodowanie będzie przebiegało równolegle, a dane będą przechowywane tymczasowo, jeśli prędkość kodowania spadnie. Aby uzyskać wysoką jakość, szczególnie podczas przechwytywania dużej ilości danych, można najpierw przechwycić dane, a następnie zakodować je po zakończeniu przechwytywania. (Ta opcja jest niedostępna w przypadku przesyłania danych źródłowych z urządzenia cyfrowego. Ponadto, nie ma możliwości przeprowadzenia najpierw przechwytywania, a następnie kodowania w połączeniu z ograniczaniem rozmiaru lub czasu trwania pliku wyjściowego.)

Jeśli ta funkcja zostanie włączona (w tym opcja powodująca najpierw przechwytywanie a potem kodowanie) w sesji z wieloma źródłami, przed zatrzymaniem kodowania należy poczekać aż wszystkie dane zostaną odebrane z pierwszego źródła. Na przykład dostępne są dwa źródła i ma zostać przechwycona tylko część drugiego źródła. Podczas kodowania można przełączyć się do drugiego źródła, ale przed zatrzymaniem kodowania należy poczekać aż podgląd wideo (w panelu Wideo) lub obszar Wejście (karta Ogólne w panelu Monitor) wskaże, że pierwsze źródło zakończyło wysyłanie danych. Umożliwia to przechwycenie całej wymaganej zawartości.

Tematy pokrewne

  • Opcje wyjściowe
  • Rozszerzenia nazw plików .asf, .wma i .wmv – informacje
  • Konfigurowanie listy EDL
  • Kodowanie do pliku
  • Ustawianie opcji archiwizacji dla każdego źródła
  • Włączanie lub wyłączanie indeksowania
  • Włączanie szukania na poziomie klatek
  • Tymczasowe przechowywanie przechwyconej zawartości
  • Kodowanie nieskompresowanych plików audio i wideo


Rozszerzenia nazw plików .asf, .wma i .wmv – informacje

Rozszerzenia nazw plików .asf, .wma i .wmv reprezentują standardowy format plików pakietu Windows Media. Rozszerzenie nazwy pliku .asf jest zazwyczaj używane z zawartością opartą na pakiecie Windows Media, utworzoną przy użyciu programu Windows Media Tools 4.0. Rozszerzenia nazw plików .wma i .wmv zostały wprowadzone jako standard konwencji nazewnictwa programu Windows Media Encoder 7 w celu ułatwienia rozróżniania plików tylko audio (.wma) i plików wideo (.wmv). Jednak te trzy rozszerzenia mogą być używane zamiennie. Niektóre narzędzia i usługi, które zostały stworzone do używania ich z wcześniejszymi wersjami technologii Windows Media Technologies, wymagają rozszerzenia .asf, aby zaakceptować zawartość. Można po prostu zmienić rozszerzenia .wma lub .wmv na rozszerzenie .asf, aby używać ich z tymi narzędziami. (Jednak zalecane jest używanie najnowszych narzędzi lub usług, o ile jest to możliwe.)

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Kodowanie do pliku

transparent programu Windows Media Encoder

Aby kodować do pliku

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Usuń zaznaczenie pól wyboru Wypychaj do serwera i Ściągaj z kodera.
  3. Zaznacz pole wyboru Koduj do pliku.
  4. W polu Nazwa pliku wprowadź nazwę pliku wyjściowego.
  5. Aby ograniczyć rozmiar pliku wyjściowego, kliknij przycisk Ogranicz według rozmiaru, a następnie wpisz maksymalny rozmiar plików i literę K, M lub G odpowiednio dla kilobajtów, megabajtów lub gigabajtów.
  6. Aby ograniczyć czas trwania pliku wyjściowego, kliknij przycisk Ogranicz według czasu trwania, a następnie wpisz maksymalny czas trwania pliku w formacie gg:mm:ss, na przykład 01:30:00.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Ustawianie opcji archiwizacji dla każdego źródła

transparent programu Windows Media Encoder

Aby ustawić opcje archiwizacji dla każdego źródła

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Wybierz metodę emisji (ściąganie lub wypychanie), a następnie zaznacz pole wyboru Archiwizuj do pliku.
  3. W polu Nazwa pliku wpisz nazwę pliku archiwum.
  4. Jeśli planujesz ograniczenie rozmiaru pliku archiwum, kliknij opcję Ogranicz według rozmiaru, a następnie wpisz maksymalny dozwolony rozmiar pliku z literą K (kilobajty), M (megabajty) lub G (gigabajty).
  5. Jeśli planujesz ograniczenie czasu trwania pliku archiwum, kliknij opcję Ogranicz według czasu trwania, a następnie wpisz maksymalny czas trwania pliku w formacie gg:mm:ss, na przykład 01:30:00.
  6. Jeśli nie wszystkie źródła rozpowszechniania mają być archiwizowane, kliknij kartę Źródła i na liście źródeł kliknij źródło, które nie będzie archiwizowane.
  7. W obszarze Archiwizowanie kliknij pozycję Wstrzymaj lub Zatrzymaj, aby zapobiec archiwizacji źródła.

    Te ustawienia można nadpisać za pomocą polecenia Ręczne sterowanie archiwizacją w menu Sterowanie.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Włączanie lub wyłączanie indeksowania

transparent programu Windows Media Encoder

Aby włączyć lub wyłączyć indeksowanie

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Zaznacz pole wyboru Koduj do pliku lub Archiwizuj do pliku.
  3. Zaznacz lub usuń zaznaczenie pola wyboru Dodaj indeks, aby włączyć lub wyłączyć indeksowanie.

obrazek „Uwaga” Uwaga

  • Indeksowanie umożliwia wyszukiwanie klatek kluczowych. Dla niektórych zawartości można włączyć wyszukiwanie na poziomie klatek.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku
  • Włączanie szukania na poziomie klatek


Włączanie szukania na poziomie klatek

transparent programu Windows Media Encoder

Aby włączyć szukanie na poziomie klatek

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Zaawansowane.
  2. Zaznacz pole wyboru Kod czasowy.
  3. Jeżeli źródłowe wideo zawiera już kod czasowy, kliknij opcję Chroń oryginał.

    -lub-

    W celu wygenerowania kodu czasowego kliknij opcję Twórz nowy kod czasowy, a następnie w polu Czas rozpoczęcia wpisz odpowiedni czas rozpoczęcia kodu czasowego w formacie gg:mm:ss:kl. Ponadto w polu Format wideo wybierz format źródłowego wideo.

obrazek „Uwaga” Uwaga

  • Kod czasowy można utworzyć, jeżeli źródło zawiera wideo i pochodzi z plików cyfrowego wideo (DV) w formacie Audio-Video Interleaved (AVI), urządzeń przechwytywania lub urządzeń cyfrowych. Możliwość chronienia kodu czasowego dostępna jest wtedy, gdy źródło zawiera wideo i pochodzi z plików cyfrowego wideo (DV) w formacie Audio-Video Interleaved (AVI) lub urządzeń cyfrowych. W celu ochrony kodu czasowego dla magnetowidu podłączonego przez port COM za pomocą protokołu Sony RS422 należy na potrzeby danej sesji skonfigurować listę EDL. Nie można tworzyć ani chronić kodu czasowego, jeżeli stosowany jest filtr inverse telecine.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Tymczasowe przechowywanie przechwyconej zawartości

transparent programu Windows Media Encoder

Aby tymczasowo przechowywać przechwyconą zawartość

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Zaawansowane.
  2. Zaznacz pole wyboru Tymczasowo przechowaj zawartość na dysku twardym.
  3. Aby najpierw przechwycić zawartość, a potem ją zakodować, zaznacz pole wyboru Przechwyć najpierw na dysk twardy, a następnie koduj.

obrazek „Uwaga” Uwaga

  • Opcja Przechwyć najpierw na dysk twardy, a następnie koduj nie jest dostępna, gdy źródłem jest urządzenie cyfrowe.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Kodowanie nieskompresowanych plików audio i wideo

Za pomocą programu Windows Media Encoder można przechwytywać i archiwizować zawartość o wysokiej jakości w pliku archiwum w celu późniejszego wykorzystania. W większości sytuacji opcja Archiwum plików używająca kodowania VBR opartego o jakość jest najbardziej odpowiednia. Jeśli jednak planowane jest późniejsze edytowanie zawartości, to należy rozważyć kodowanie nieskompresowanych plików.

Wymagania dotyczące przechowywania dla nieskompresowanych plików są znacząco większe, niż dla plików skompresowanych. Zalecane jest, aby zawartość przechowywać na woluminie z systemem plików NTFS. System plików FAT32 posiada ograniczenie wielkości pliku równe 4 GB. Jeśli przewidywany rozmiar zawartości może przekroczyć 4 GB, należy zmienić konfigurację dysku twardego, tak aby używać systemu plików NTFS.

Podczas przechwytywania nieskompresowanej zawartości z urządzenia, takiego jak kamera lub magnetowid, wynikowy film wideo jest tworzony w formacie YV12 YUV, niezależnie od formatu piksela określonego na urządzeniu lub w profilu. Koder-dekoder Windows Media Video 9 jest zoptymalizowany dla formatu YUV, przez co jest on preferowanym formatem dla jakości, rozmiaru i wydajności. Audio wynikowe jest tworzone w formacie modulacji kodowo-impulsowej (PCM).

Aby uzyskać najlepsze wyniki podczas przechwytywania nieskompresowanej zawartości:

  • Należy użyć szybkiego dysku twardego, który może obsłużyć kodowanie z wysoką szybkością transmisji bitów.
  • Należy użyć szybkości 15 klatek na sekundę podczas przechwytywania w rozdzielczości 640 x 480.
  • Należy użyć szybkości 30 klatek na sekundę podczas przechwytywania w rozdzielczości 320 x 240.

Tematy pokrewne

  • Opcje wyjściowe
  • Korzystanie z opcji Archiwum plików
  • Kodowanie nieskompresowanej zawartości


Korzystanie z opcji Archiwum plików

transparent programu Windows Media Encoder

Aby korzystać z opcji Archiwum plików

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Usuń zaznaczenie pól wyboru Wypychaj i Ściągaj, a następnie zaznacz pole wyboru Koduj do pliku.
  3. Kliknij kartę Kompresja, a następnie w obszarze Miejsce docelowe kliknij opcję Archiwum plików.
  4. W obszarach Wideo i Audio zaznacz wybrane ustawienia jakości.

Tematy pokrewne

  • Kodowanie nieskompresowanych plików audio i wideo


Kodowanie nieskompresowanej zawartości

transparent programu Windows Media Encoder

Aby kodować nieskompresowaną zawartość

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Kompresja.
  2. W obszarze Miejsce docelowe kliknij pozycję Serwer Windows Media lub Serwer sieci Web, a następnie kliknij przycisk Edytuj.
  3. W przypadku kodowania audio zaznacz pole wyboru Audio, a następnie w obszarze Koder-dekoder kliknij opcję Brak (PCM).
  4. W przypadku kodowania wideo zaznacz pole wyboru Wideo, a następnie w obszarze Koder-dekoder kliknij opcję Pełne klatki (nieskompresowane).

obrazek „Uwagi” Uwagi

  • W przypadku kodowania zarówno audio, jak i wideo należy użyć opcji nie używającej kompresji.
  • Nie ma możliwości kodowania nieskompresowanej zawartości do strumienia MBR.

Tematy pokrewne

  • Kodowanie nieskompresowanych plików audio i wideo


Emisja zawartości na żywo

Gdy zawartość ma być emitowana na żywo, można wybrać wypychanie strumienia z kodera do serwera Windows Media lub umożliwić klientom (serwerom lub odtwarzaczom Windows Media) ściąganie zawartości. Użycie danej metody uzależnione jest od sytuacji.

Scenariusze wypychania

Wypychanie strumienia z kodera jest przydatne, jeśli koder znajduje się za zaporą lub jeśli chcesz nawiązać połączenie z kodera. Załóżmy, że w ostatniej chwili odebrano informacje o tym, że prezes firmy chce przesłać strumieniowo przemówienie do pracowników. Serwer Windows Media znajduje się w lokalizacji zdalnej, poza zaporą firmy. Dla administratora sieci jest to środek nocy. Wypychając strumień z kodera, można przesłać go poza zaporę, spełniając tym samym wymagania prezesa i unikając wykonania pilnego telefonu do osoby, która mogłaby administrować w danej chwili serwerem. Dystrybucja wypychania jest dostępna tylko w programie Windows Media Services Seria 9 w systemie Windows .NET Server 2003.

Scenariusze ściągania

Umożliwienie serwerom Windows Media ściągania strumienia jest przydatne w kilku przypadkach. Po pierwsze, jeśli dostępnych jest wiele serwerów dystrybucji, które łączą się o innych porach, każdy serwer może nawiązywać połączenie z koderem, gdy serwer jest gotowy do przesyłania strumieniowego. Po drugie, ściąganie z serwera jest przydatne, jeśli istotne jest zminimalizowanie użycia przepustowości między serwerem a koderem. Na przykład administrator serwera może dodać punkt publikacji i skonfigurować go do automatycznego uruchamiania na żądanie klienta, co oznacza, że serwer nie inicjuje połączenia z koderem do chwili połączenia pierwszego klienta. Eliminuje to zbędne użycie przepustowości pomiędzy serwerem a koderem. (Ten scenariusz jest dostępny tylko w programie Windows Media Services Seria 9 w systemie Windows .NET Server 2003.) I wreszcie, ściąganie z serwera jest również przydatne, gdy serwer znajduje się za zaporą. Załóżmy, że skonfigurowano koder w sieci publicznej, ponieważ zdarzenia są przesyłane strumieniowo na konferencji. Należy przesłać strumień do serwera dystrybucji w sieci chronionej. Administrator serwera może ściągnąć strumień poprzez zaporę.

Umożliwienie odtwarzaczom ściągania strumienia jest przydatne, gdy strumień nie będzie oglądany przez wielu klientów. Program Windows Media Encoder umożliwia połączenie do pięciu klientów podczas emisji. W przypadku umożliwienia klientom ściągania strumienia można ograniczyć dostęp do zawartości do adresów IP lub grup adresów IP.

Tematy pokrewne

  • Opcje wyjściowe
  • Porównanie serwerów Windows Media i serwerów sieci Web
  • Wypychanie strumienia z kodera
  • Umożliwianie klientom ściągania strumienia z kodera
  • Tworzenie anonsu dla multiemisji
  • Ograniczanie dostępu do emisji


Wypychanie strumienia z kodera

Podczas wypychania strumienia z kodera należy określić serwer Windows Media, do którego będzie odbywało się przesyłanie strumieniowe i punkt publikacji emisji (nowy lub już istniejący), przez który będzie odbywać się przesyłanie strumieniowo. Serwer Windows Media udostępnia kilka opcji służących do konfigurowania punktu publikacji, włączając w to ustawienia limitów dotyczących liczby odtwarzaczy mogących odtwarzać strumień, sterowanie dostępem do zawartości i konfigurowanie rejestrowania. Jeśli konfiguracja ma być powtarzana, można dodać punkt publikacji emisji na serwerze, skonfigurować go według potrzeb, a następnie kopiować ustawienia z tego punktu publikacji za każdym razem, gdy strumień jest wypychany do serwera. Więcej informacji na temat konfigurowania punktów publikacji emisji znajduje się w Pomocy programu Windows Media Services. Dystrybucja wypychania jest dostępna tylko w programie Windows Media Services Seria 9 w systemie Windows .NET Server 2003.

Zawartość może być dostarczana z serwera Windows Media jako strumień multiemisji lub emisji pojedynczej.

Anons wymagany dla strumienia multiemisji

Jeśli zawartość z serwera ma być dostarczana jako strumień multiemisji, można utworzyć i dystrybuować anons przed rozpoczęciem kodowania. Anons jest sposobem powiadamiania, że zawartość jest dostępna dla odtwarzaczy. Do utworzenia anonsu można użyć Kreatora anonsu multiemisji w koderze. Można także utworzyć anons na serwerze. Utworzenie anonsu na serwerze wymaga uprawnień dostępu do usług Windows Media Services przez rozproszoną wersję specyfikacji Component Object Model (DCOM). Jeśli dokonasz zmian w konfiguracji sesji po utworzeniu anonsu, przed rozpoczęciem kodowania musisz utworzyć kolejny anons.

Uzyskiwanie dostępu do serwera Windows Media

Aby wypchnąć strumień do serwera Windows Media, na serwerze musi być włączony dodatek protokołu kontroli serwera WMS HTTP. Dodatkowo musisz mieć uprawnienia zapisu na serwerze za pośrednictwem dodatku autoryzacji ACL punktów publikacji WMS. Musisz także posiadać uprawnienia tworzenia w dodatku, jeśli wolisz dodawać punkt publikacji z kodera niż z serwera. Uprawnienia myszą być określone zarówno na poziomie serwera jak i na poziomie punktu publikacji. Aby skonfigurować dodatek, musisz posiadać dostęp do usługi Windows Media Services za pośrednictwem specyfikacji DCOM.

Lokalni administratorzy na serwerze automatycznie uzyskują uprawnienia zapisu i tworzenia na serwerze.

Po rozpoczęciu kodowania koder zainicjuje połączenie z serwerem.

Można użyć z Kreatora nowej sesji lub funkcji szybkiego uruchamiania emisji, aby wypychać do serwera Windows Media lub można skonfigurować sesję wypychania na panelu Właściwości.

Więcej informacji na temat konfigurowania strumienia multiemisji lub emisji pojedynczej na serwerze Windows Media znajduje się w Pomocy programu Windows Media Services.

Tematy pokrewne

  • Emisja zawartości na żywo
  • Tworzenie anonsu dla multiemisji
  • Wypychanie strumienia do serwera Windows Media


Wypychanie strumienia do serwera Windows Media

transparent programu Windows Media Encoder

Aby wypychać strumień do serwera Windows Media

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Zaznacz pole wyboru Wypychaj do serwera i usuń zaznaczenie pola wyboru Ściągaj z kodera.
  3. W polu Nazwa serwera wpisz nazwę serwera Windows Media, z którego ma być dystrybuowana zawartość. Można użyć nazwy netBIOS (network basic input/output system), adresu IP lub nazwy DNS (Domain Name System) serwera.

    Koder używa protokołu HTTP do przesyłania strumienia do serwera. Domyślnie serwer używa portu 80 dla protokołu HTTP. Jeśli serwer jest skonfigurowany do używania portu o innym numerze, koder musi być zgodny z tym numerem portu. Można używać formatu Nazwa_serwera:Numer_portu w polu Nazwa serwera – w przypadku posiadania uprawnień dostępu do usługi Windows Media Services za pomocą interfejsu DCOM, numer portu zostanie wykryty automatycznie.

  4. W polu Punkt publikacji wpisz nazwę istniejącego lub nowego punktu publikacji, przez który ma następować przesyłanie strumieniowe. W przypadku tworzenia punktu publikacji należy używać tylko znaków alfanumerycznych. Ponadto następujące znaki nie są dozwolone w nazwie punktu publikacji: * < > \ ? % & # " { } | ^ [ ] `

    Aby utworzyć punkt publikacji z kodera, należy mieć uprawnienia tworzenia za pomocą dodatku WMS Publishing Points ACL Authorization (zarówno na poziomie serwera jak i punktu publikacji) w serwerze Windows Media.

  5. W przypadku tworzenia punktu publikacji można użyć konfiguracji domyślnego punktu publikacji lub skopiować konfigurację istniejącego punktu publikacji do tworzonego punktu publikacji. Aby to zrobić, w polu Kopiuj ustawienia z wpisz nazwę istniejącego punktu publikacji, którego konfiguracja ma zostać skopiowana.
  6. Aby usunąć punkt publikacji, przez który następuje przesyłanie strumieniowe, po zamknięciu kodera (lub po upływie określonej liczby minut), zaznacz pole wyboru Automatycznie usuwaj.

    Limit czasu umożliwia zatrzymanie i ponowne uruchomienie kodowania bez potrzeby tworzenia punktu publikacji. Jest to przydatne, jeśli na przykład chcesz dostosować ustawienia sesji i kontynuować kodowanie.

obrazek „Uwaga” Uwaga

  • W przypadku dostarczania zawartości w postaci strumienia multiemisji należy utworzyć anons.

Tematy pokrewne

  • Wypychanie strumienia z kodera
  • Tworzenie anonsu dla multiemisji


Tworzenie anonsu dla multiemisji

W przypadku wypychania strumienia do serwera Windows Media i jego dystrybucji jako strumienia multiemisji należy utworzyć plik anonsu (.asx) i plik z informacjami o multiemisji (.nsc). Anons to metaplik Windows Media, który wskazuje odtwarzaczowi plik z informacjami o multiemisji. Plik z informacjami o multiemisji zawiera informacje, które umożliwiają odtwarzaczom uzyskiwanie dostępu i dekodowanie strumienia multiemisji, w tym adres IP, port i informacje o formacie strumienia.

Tworzenie anonsu

Do utworzenia anonsu można użyć Kreatora anonsu multiemisji w koderze lub można go utworzyć na serwerze Windows Media. Tworzenie anonsu w koderze wymaga uprawnień dostępu do usługi Windows Media Services za pomocą technologii DCOM. W przypadku wprowadzenia zmian w konfiguracji sesji po utworzeniu anonsu, przed rozpoczęciem kodowania należy utworzyć nowy anons.

Po uruchomieniu kreatora w koderze tworzony jest plik anonsu, plik z informacjami o multiemisji i strona sieci Web zawierająca osadzony odtwarzacz i łącze do anonsu. Użytkownik proszony jest o podanie nazw plików i ich zapisanie w lokalizacji przechowywania dostępnej dla odtwarzaczy (lub w lokalizacji tymczasowej, jeśli ma być ona emitowana później). Lokalizacja przechowywania może znajdować się na serwerze sieci Web przy dostępie za pomocą protokołu HTTP lub w publicznym udziale w przypadku udostępniania z wykorzystaniem ścieżki UNC (Universal Naming Convention). Jeżeli udostępniasz pliki z serwera sieci Web, musisz skonfigurować serwer sieci Web tak, aby nie zezwalał na buforowanie pliku lub wymagał sprawdzania odświeżania podczas buforowania przez klienta w celu uniknięcia wykorzystywania przez odtwarzacze nieaktualnych informacji o multiemisji.

Dystrybucja pliku anonsu

Dostępnych jest kilka opcji udostępniania użytkownikom strumienia multiemisji. Można umieścić łącze do pliku anonsu na stronie sieci Web, udostępnić anons w folderze udostępnionym lub wysłać anons w wiadomości e-mail. Użytkownicy mogą uzyskać dostęp do anonsu, klikając jego łącze na stronie sieci Web lub bezpośrednio otwierając anons. Gdy użytkownik otwiera plik anonsu (.asx) w odtwarzaczu, odtwarzacz wyodrębnia adres URL w pliku anonsu; adres URL wskazuje plik z informacjami o multiemisji. Następnie odtwarzacz pobiera plik z informacjami o multiemisji oraz adresem URL i rozpoczyna odtwarzanie zawartości.

Tematy pokrewne

  • Emisja zawartości na żywo
  • Uzyskiwanie dostępu do Kreatora anonsu multiemisji


Uzyskiwanie dostępu do Kreatora anonsu multiemisji

transparent programu Windows Media Encoder

Aby uzyskać dostęp do Kreatora anonsu multiemisji

  1. Skonfiguruj sesję wypychania z serwerem Windows Media, która będzie dystrybuować zawartość jako strumień multiemisji.
  2. W menu Narzędzia kliknij polecenie Anonsuj emisję.
  3. Postępuj zgodnie z instrukcjami w kreatorze, aby utworzyć pliki dla sesji.

Tematy pokrewne

  • Wypychanie strumienia z kodera
  • Tworzenie anonsu dla multiemisji


Umożliwianie klientom ściągania strumienia z kodera

Aby umożliwić klientom ściąganie strumienia z kodera, można po prostu skonfigurować sesję i rozpocząć emisję bezpośrednio z kodera. Klienci (odtwarzacze lub serwery Windows Media) mogą połączyć się ze strumieniem w dowolnym momencie, używając adresu URL w następującym formacie: http://adres_IP:port (dla połączeń w sieci Internet) lub http://nazwa_komputera_kodującego:port (dla połączeń w sieci LAN). Domyślnie koder obsługuje maksymalnie pięć połączeń bezpośrednich podczas emisji. Edytując klucz rejestru, można zwiększyć tę wartość do 50. (Aby edytować klucz, należy posiadać uprawnienia administracyjne na komputerze kodującym.)

Format strumieniowy wymagany do transmisji multiemisji

Jeśli planowane jest dostarczanie zawartości w postaci strumienia z serwera Windows Media, serwer musi mieć możliwość rozpoznania formatu strumieniowego z kodera. Format strumieniowy zawiera informacje używane przez odtwarzacze do dekodowania strumienia multiemisji, takie jak kodery-dekodery, szybkości transmisji bitów i rozmiary klatek; format jest przechowywany w nagłówku strumienia. Jeśli kodowanie rozpoczęło się, zanim serwer zainicjował połączenie z koderem, serwer automatycznie wykryje format strumieniowy. Jeśli jednak użytkownik nie chce najpierw rozpoczynać kodowania, to można utworzyć plik formatu strumieniowego i udostępnić go administratorowi serwera. Administrator może dodać plik do listy obsługiwanych formatów strumieniowych w punkcie publikacji serwera.

obrazek „Ostrożnie” Ostrożnie

  • Nieprawidłowe edytowanie rejestru może spowodować poważne uszkodzenie systemu. Przed wprowadzeniem zmian w rejestrze należy wykonać kopie zapasowe wszystkich cennych danych w komputerze.

obrazek „Uwaga” Uwaga

  • W tym temacie przedstawiono tylko kroki, które należy wykonać z poziomu kodera, gdy serwer Windows Media inicjuje strumień. Aby uzyskać szczegółowe informacje dotyczące kroków, które należy wykonać z poziomu serwera Windows Media, zobacz Pomoc programu Windows Media Services.

Tematy pokrewne

  • Emisja zawartości na żywo
  • Umożliwianie klientom ściągania strumienia z kodera
  • Tworzenie pliku formatu strumieniowego
  • Porównanie serwerów Windows Media i serwerów sieci Web
  • Zwiększanie maksymalnej liczby połączeń bezpośrednich


Umożliwianie klientom ściągania strumienia z kodera

transparent programu Windows Media Encoder

Aby umożliwić klientom ściąganie strumienia z kodera

  1. Na pasku narzędzi kliknij przycisk Właściwości, a następnie kliknij kartę Wyjście.
  2. Zaznacz pole wyboru Ściągaj z kodera.

Tematy pokrewne

  • Umożliwianie klientom ściągania strumieni z kodera


Tworzenie pliku formatu strumieniowego

transparent programu Windows Media Encoder

Aby utworzyć plik formatu strumieniowego

  1. Skonfiguruj sesję zezwalającą serwerowi Windows Media na ściąganie strumienia z kodera.
  2. W menu Narzędzia kliknij polecenie Generuj plik formatu strumieniowego.
  3. W polu Nazwa pliku wpisz nazwę i lokalizację pliku, a następnie kliknij przycisk Zapisz.
  4. Dostarcz plik administratorowi serwera Windows Media.

obrazek „Uwaga” Uwaga

  • Po każdej zmianie ustawień w konfiguracji kodera konieczne jest utworzenie nowego pliku formatu strumieniowego i dostarczenie go administratorowi serwera Windows Media.

Tematy pokrewne

  • Umożliwianie klientom ściągania strumieni z kodera
  • Umożliwianie klientom ściągania strumienia z kodera


Zwiększanie maksymalnej liczby połączeń bezpośrednich

transparent programu Windows Media Encoder

Aby zwiększyć maksymalną liczbę połączeń bezpośrednich

  1. W Edytorze rejestru użyj widoku drzewa w celu przejścia do następującego podklucza: HKEY_CLASSES_ROOT\Software\Microsoft\Windows Media Tools\Encoder\MaxClientConnections.
  2. Przeprowadź edycję podklucza, aby odpowiadał maksymalnej liczbie bezpośrednich połączeń, które można nawiązać. Maksymalna możliwa wartość to 50.

obrazek „Ostrożnie” Ostrożnie

  • Nieprawidłowa edycja rejestru może poważnie uszkodzić system. Przed wprowadzeniem zmian w rejestrze należy wykonać kopię zapasową ważnych danych na komputerze.

Tematy pokrewne

  • Umożliwianie klientom ściągania strumienia z kodera


Ograniczanie dostępu do emisji

Podczas umożliwiania klientom ściągania strumienia z kodera można zezwolić lub odmówić dostępu do emisji na podstawie statycznego adresu IP lub grupy adresów IP. Domyślnie wszyscy użytkownicy mogą łączyć się z emisją. Jeśli użytkownik chce określić, którzy klienci mogą się łączyć, może dodać adresy IP do listy dozwolonych. Po wykonaniu tej czynności klienci nieznajdujący się na liście nie będą mogli nawiązywać połączeń. Można też uniemożliwić określonym klientom dostęp do emisji, dodając adresy IP klientów do listy zabronionych.

Jeśli podczas kodowania wprowadzono zmiany na liście adresów, to zmiany będą miały wpływ tylko na klientów łączących się po zastosowaniu zmian. Na przykład, jeśli do listy zabronionych dodano adres IP klienta, który jest połączony, to klient nie zostanie rozłączony. Jeśli jednak klient rozłączy się i podejmie próbę ponownego połączenia z tą samą emisją, to użytkownik ten spotka się z odmową dostępu. Jeśli bardzo ważne jest, aby natychmiast rozłączyć użytkownika, należy zatrzymać kodowanie.

W poniższej tabeli przedstawiono przykładową kolejność udzielania lub odmawiania dostępu dla poszczególnych adresów IP, zgodnie ze skonfigurowanymi ograniczeniami.

Lista dozwolonych | Lista zabronionych | Wynik
Pusta | Pusta | Dozwolone są wszystkie adresy IP
Pusta | Adres IP 1 | Zabroniony jest adres IP 1, wszystkie inne są dozwolone
Adres IP 1 | Pusta | Dozwolony jest adres IP 1, wszystkie inne są zabronione
Adres IP 1 | Adres IP 2 | Dozwolony jest adres IP 1, wszystkie inne są zabronione
Adres IP 1 | Adres IP 1 | Wszystkie adresy IP są zabronione
Adres IP 1, adres IP 2 | Adres IP 1 | Dozwolony jest adres IP 2, wszystkie inne są zabronione

Podczas ograniczania dostępu do emisji według adresu IP można określić zarówno adres protokołu Internet Protocol w wersji 6 (IPv6), jak i adres Internet Protocol w wersji 4. Protokół IPv6 jest najnowszą wersją Internet Protocol i został zaprojektowany do obsługi gwałtownie zwiększającej się puli unikatowych adresów IP. Protokół IPv6 zwiększa rozmiar adresu IP z 32 bitów do 128 bitów w celu obsługi większej liczby poziomów hierarchii adresów i większej liczby adresowalnych węzłów. Aby uzyskać więcej informacji dotyczących protokołu IPv6, zobacz stronę protokołu IPv6 w witrynie sieci Web firmy Microsoft.

obrazek „Uwaga” Uwaga

  • Można śledzić, które adresy IP są podłączone do emisji, włączając na karcie Dziennik zdarzeń w panelu monitorowania rejestrowanie w pliku.

Tematy pokrewne

  • Emisja zawartości na żywo
  • Zezwalanie lub odmawianie dostępu do emisji


Zezwalanie lub odmawianie dostępu do emisji

transparent programu Windows Media Encoder

Aby zezwolić lub odmówić dostępu do emisji

  1. W menu Narzędzia kliknij pozycję Zabezpieczenia emisji.
  2. Wykonaj jedną z następujących czynności:
    • Aby umożliwić dostęp do komputera kodującego, w obszarze Zezwól kliknij przycisk Dodaj.
    • Aby odmówić dostępu do komputera kodującego, w obszarze Odmów kliknij przycisk Dodaj.
  3. W polu Adres IP wpisz adres IP komputera, dla którego chcesz zezwolić lub odmówić dostępu.

    -lub-

    W polu Maska IP wpisz zakres adresów IP, dla których chcesz zezwolić lub odmówić dostępu.

  4. Kliknij przycisk Dodaj.
  5. Powtarzaj kroki 3 i 4, aby dodać wszystkie adresy IP.

Tematy pokrewne

  • Ograniczanie dostępu do emisji


Testowanie zawartości

Dobrym pomysłem jest przetestowanie zawartości przed dostarczeniem jej użytkownikom. Aby rozpocząć test, należy skonfigurować sesję i zakodować zawartość. Gdy zawartość jest kodowana, za pomocą adresu URL określonego na karcie Połączenia w panelu monitorowania należy połączyć odtwarzacz z koderem i przejrzeć strumień. Jeśli zawartość jest kodowana do pliku, należy zatrzymać koder i następnie odtworzyć plik wyjściowy.

Jeśli planowane jest dystrybuowanie zawartości za pomocą serwera Windows Media, można przeprowadzić test końcowy. Aby to zrobić, należy skonfigurować serwer Windows Media do połączenia z koderem za pomocą adresu URL określonego na karcie Połączenia w panelu monitorowania.

Podczas przeglądania strumienia należy sprawdzić następujące rzeczy:

  • Czy uzyskiwana jest spodziewana szybkość klatek?
  • Czy wydajność przepustowości jest akceptowalna?
  • Czy akceptowalna jest jakość odbieranego audio i wideo?

Aby uzyskać informacje dotyczące przesyłania strumieniowego z serwera Windows Media, zobacz Pomoc programu Windows Media Services.

Tematy pokrewne

  • Opcje wyjściowe


Opcje konfiguracji systemu

W tej części znajdują się informacje dotyczące opcji służących do konfigurowania systemu kodowania, łącznie z informacjami, w jaki sposób zabezpieczyć komputer kodujący i kodowaną zawartość, czynnościami, które należy wykonać, aby osiągnąć optymalną wydajność systemu, w jaki sposób uruchomić wiele wystąpień kodera na komputerze oraz informacjami dotyczącymi kodowania wsadowego.

Tematy pokrewne

  • Windows Media Encoder
  • Zabezpieczenia i program Windows Media Encoder
  • Osiąganie optymalnej wydajności systemu
  • Właściwe dobieranie ustawień kompresji
  • Uruchamianie wielu koderów na jednym komputerze
  • Kodowanie wsadowe


Zabezpieczenia i program Windows Media Encoder

Zagadnienia związane z zabezpieczeniami programu Windows Media Encoder dotyczą zarówno zabezpieczeń komputera kodującego, jak i ochrony kodowanej zawartości. Aby dowiedzieć się więcej o zagadnieniach zabezpieczeń związanych z komputerem kodującym, należy zapoznać się z częścią poświęconą zabezpieczeniom w dokumentacji systemu operacyjnego.

Aby chronić zawartość, można użyć podczas kodowania zarządzania prawami cyfrowymi (DRM).

Podczas emisji można ograniczyć dostęp do kodera według adresów IP. Ponadto można użyć protokołu Internet Protocol Security (IPSec), który jest branżowym zestawem standardów weryfikujących, uwierzytelniających i opcjonalnie szyfrujących dane na poziomie pakietów IP. Aby uzyskać więcej informacji dotyczących zabezpieczeń IPSec, patrz Pomoc i obsługa techniczna systemu Windows.

Jeśli kodowana jest zawartość, która będzie emitowana z serwera Windows Media, zobacz Pomoc programu Windows Media Services, aby uzyskać informacje dotyczące zabezpieczeń i serwera Windows Media.

Tematy pokrewne

  • Opcje konfiguracji systemu
  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości
  • Ograniczanie dostępu do emisji


Osiąganie optymalnej wydajności systemu

Aby osiągnąć optymalną wydajność systemu:

  • Należy używać komputera z szybkim procesorem lub wieloma procesorami. Kodowanie w wysokiej jakości wymaga większej mocy obliczeniowej, dlatego też zalecane jest używanie komputera z szybkim procesorem lub wieloma procesorami, szczególnie w przypadku zdarzeń na żywo. Program Windows Media Encoder może używać maksymalnie dwóch procesorów do kodowania audio i maksymalnie czterech procesorów do kodowania wideo, aby wydajnie dystrybuować obciążenie kodowania. Jeśli użytkownik używa kodera-dekodera Windows Media Video 9, można również dostosować ustawienia wydajności, tak aby pomyślnie kodować. Z reguły, jeśli ciągle jest osiągany lub przekraczany poziom 80 procent obciążenia procesora (zgodnie ze wskazaniami karty Ogólne w panelu Monitor), wskazane jest rozważenie decyzji o uaktualnieniu komputera.
  • Należy używać obsługiwanych kart audio i wideo. Aby zapoznać się z kompletną listą obsługiwanych kart, zobacz witrynę sieci Web firmy Microsoft.
  • Należy używać systemu Microsoft Windows XP Professional. System Windows XP Professional wykorzystuje w pełni komputery wieloprocesorowe, automatycznie rozdzielając odrębne wątki w celu umożliwienia jednoczesnego przetwarzania różnych części programów na różnych procesorach. Taki podział pracy umożliwia wykonywanie zaawansowanych zadań kodowania bez maksymalizowania obciążenia procesora.
  • Należy sprawdzić przepustowość sieci. Rzadko zdarza się, aby istniała potrzeba osiągnięcia 100 procent wydajności podczas przesyłania zawartości poprzez sieć. Aby osiągnąć optymalne wyniki, należy się upewnić, że sieć może pomieścić zsumowaną przepustowość, wymaganą przez sesję emisji oraz zapas dla protokołu HTTP.
  • Należy używać dysków twardych o wysokiej wydajności. Do archiwizacji lub konwersji plików należy używać dysku twardego o wysokiej wydajności, takiego jak dysk twardy standardu SCSI o szybkości 15 000 obrotów na minutę. Używanie dysku twardego o wysokiej wydajności może pomóc w zmniejszeniu wymagań dotyczących wydajności głównego procesora, zwalniając więcej mocy procesora na kodowanie. Dodatkowo przydatne jest używanie dysku twardego tylko w celu kodowania.
  • Należy przechowywać koder na dedykowanym komputerze. Jeśli zawartość jest przesyłana strumieniowo z serwera, na którym uruchomiony jest program Windows Media Services, zalecane jest uruchamianie kodera na komputerze innym, niż serwer programu Windows Media.
  • Należy wyłączyć podgląd wideo przed i po kodowaniu. Obszary Wejście i Wyjście w głównym oknie kodera pokazują wygląd zawartości przed i po kodowaniu. Wyłączenie tych podglądów zwiększa wydajność kodowania. Aby osiągnąć mniejszą poprawę wydajności, można zmniejszyć te widoki.
  • Należy tymczasowo przechowywać przechwyconą zawartość. Jeżeli kodowanie do pliku jest wykonywane podczas pobierania z urządzeń, należy tymczasowo przechowywać zawartość na dysku twardym. Ponadto należy używać innego dysku twardego niż ten, który jest przeznaczony na potrzeby kodowania.

Tematy pokrewne

  • Opcje konfiguracji systemu
  • Dostosowywanie ustawień wydajności kodera
  • Wyłączanie lub zmniejszanie podglądu wideo
  • Poprawianie wydajności podczas kodowania ekranów
  • Tymczasowe przechowywanie przechwyconej zawartości


Wyłączanie lub zmniejszanie podglądu wideo

transparent programu Windows Media Encoder

Aby wyłączyć lub zmniejszyć podgląd wideo

  1. W menu Widok kliknij polecenie Panel wideo.
  2. Aby wyłączyć podgląd wideo, w obszarze Ekran kliknij opcję Wyjście.

    -lub-

    Aby zmniejszyć rozmiar podglądu, w obszarze Powiększ kliknij opcję 50%.

Tematy pokrewne

  • Osiąganie optymalnej wydajności systemu


Dostosowywanie ustawień wydajności kodera

Kodowanie jest procesem intensywnie obciążającym procesor. Jeśli ciągle są przekraczane możliwości komputera kodującego, można przejrzeć najnowsze wymagania dotyczące sprzętu i oprogramowania, aby zdecydować, czy istnieje konieczność uaktualnienia komputera w celu zwiększenia jego możliwości. Jeżeli uaktualnienie nie jest możliwe, można dostosować ustawienia wydajności kodera, aby zapewnić pomyślne kodowanie. (Ustawienia można zastosować tylko w sesjach, w których jest używany koder-dekoder Windows Media Video 9.) Wybór wydajności polega na tym, czy należy położyć nacisk na lepszą wydajności czy na lepszą jakość. Ustawienie lepszej wydajności powoduje mniejsze obciążenie procesora; ustawienie lepszej jakości powoduje większe obciążenie procesora. Przy wyborze ustawień wydajności należy pamiętać o następujących wskazówkach:

  • Jeśli nie jest ważny czas kodowania, można używać ustawienia lepszej jakości. Jest to najbardziej odpowiednie dla scenariusza, w którym następuje pobieranie z pliku i kodowanie do pliku. Koder zużywa tyle czasu, ile jest potrzebne do kodowania.
  • Jeśli jest ważne, aby kodowanie było równoczesne z przechwytywaniem, należy użyć ustawienia lepszej wydajności. Jest to odpowiednie dla scenariusza, w którym następuje emisja lub dla scenariusza, w którym następuje pobieranie z urządzeń i kodowanie do pliku. W scenariuszu kodowania do pliku można również włączyć tymczasowe przechowywanie przechwyconej zawartości. Przechwycone dane są przechowywane w lokalizacji tymczasowej, jeśli proces kodowania nie nadąża za procesem przechwytywania.

Dla wszystkich scenariuszy można wypróbować różne ustawienia wydajności, aby znaleźć równowagę pomiędzy jakością i wydajnością komputera. Należy pamiętać, że podczas kodowania inne czynniki wpływają na procesor. Na przykład ustawienia sesji, takie jak szybkość klatek, szybkość transmisji bitów i rozmiar klatki określają, jak wiele pracy musi wykonać procesor, aby wykonać kodowanie. Ponadto inne programy uruchomione na komputerze kodującym pozostawiają mniej mocy procesora dla kodera.

Tematy pokrewne

  • Osiąganie optymalnej wydajności systemu
  • Wymagania dotyczące sprzętu i oprogramowania
  • Kodowanie lub archiwizacja emisji do pliku
  • Dostosowywanie ustawień wydajności
  • Tymczasowe przechowywanie przechwyconej zawartości


Dostosowywanie ustawień wydajności

transparent programu Windows Media Encoder

Aby dostosować ustawienia wydajności

  1. W menu Narzędzia kliknij polecenie Opcję, a następnie kliknij kartę Wydajność.
  2. W sekcji Podczas emisji przesuń suwak na żądane ustawienie.
  3. W sekcji Podczas kodowania do pliku przesuń suwak na żądane ustawienie.

Tematy pokrewne

  • Dostosowywanie ustawień wydajności kodera


Właściwe dobieranie ustawień kompresji

Różne ustawienia kompresji są od siebie zależne. Koder zawiera wiele uprzednio zdefiniowanych ustawień miejsca docelowego, wideo i audio (profile), które uwzględniają te zależności. Korzystając z uprzednio zdefiniowanego profilu, można łatwo zdefiniować sesję kodowania. Jeżeli ustawienia te mają zostać dostosowane, poniższe akapity zawierają informacje o ustawieniach wraz ze wskazówkami, które warto wziąć pod uwagę.

  • Bufor. Większy bufor pozwala osiągnąć lepszą jakość obrazu, ale użytkownik musi dłużej czekać na rozpoczęcie odtwarzania wideo, ponieważ odtwarzacz nie rozpoczyna odtwarzania do czasu wypełnienia buforu. Zazwyczaj opóźnienie buforu odpowiada czasowi, w sekundach, rozmiaru buforu ustawionego w koderze. Jeżeli jednak użytkownik zamierza przesyłać strumieniowo z serwera Windows Media, może ustawić większy rozmiar buforu w koderze. Funkcja szybkiego startu w programie Windows Media Services umożliwia odtwarzaczowi wypełnienie buforu szybciej niż w czasie rzeczywistym, o ile przepustowość jest wystarczająca. Oznacza to, że wstępne opóźnienie buforu może być o wiele krótsze. Jeżeli na przykład użytkownik usiłuje odtworzyć zawartość zakodowaną z szybkością 56-Kb/s przez modem DSL lub kablowy, opóźnienie rozpoczęcia odtwarzania może wynosić tylko sekundę lub dwie, nawet jeśli rozmiar buforu ustawiony podczas kodowania był o wiele większy. Więcej informacji o funkcji szybkiego startu zawiera Pomoc programu Windows Media Services.

    Jeśli skonfigurowana została sesja, która używa kodowania VBR w oparciu o szczytową szybkość transmisji bitów, szczytowy rozmiar bufora dla audio powinien być mniejszy niż rozmiar bufora dla wideo (w przypadku używania kodowania CBR dla wideo) lub szczytowy rozmiar bufora dla wideo (w przypadku używania kodowania w oparciu o szczytową szybkość transmisji bitów dla wideo).

  • Szybkość transmisji bitów. Wyższa szybkość transmisji bitów daje lepszą jakość obrazu. Jeśli wartość szybkości transmisji bitów jest zbyt mała, koder-dekoder będzie opuszczał klatki w celu wyświetlenia obrazu wyższej jakości, mimo że nie będzie to widoczne dla użytkownika. (Należy zauważyć, że w przypadku kodowania wideo zawierającego niewielką ilość ruchu, rzeczywista szybkość transmisji bitów może być o wiele mniejsza od oczekiwanej.)
  • Szybkość klatek. Między jakością obrazu a szybkością klatek istnieje zależność, według której jakość obrazu zwiększa się, gdy zmniejsza się szybkość klatek. Jeśli zachowanie szybkości klatek jest ważniejsze, można zmniejszyć jakość obrazu.
  • Jakość obrazu (płynność). Jakość obrazu można dostosować tak, aby był płynniejszy lub wyraźniejszy. W zależności od wideo, obraz bardziej wyraźny może wpłynąć na szybkość klatek. Jeżeli na przykład wideo zawiera dużo ruchu, wyraźniejszy obraz może zmniejszyć szybkość klatek. Ponadto wyraźniejszy obraz zwiększa wymagania co do szybkości transmisji bitów i może wymagać zwiększenie rozmiaru buforu.
  • Rozmiar klatki. Po zwiększeniu rozmiaru klatki zwiększają się wymagania dotyczące szybkości transmisji bitów.
  • Klatki kluczowe. Jeżeli używany jest większy odstęp między klatkami kluczowymi, tam, gdzie jest to wymagane, wstawiane są dodatkowe klatki kluczowe, na przykład gdy zmienia się ujęcie. W przypadku zawartości z małą ilością ruchu zazwyczaj odpowiednie jest ustawienie 20 sekund. W przypadku zawartości o większej szybkości transmisji bitów należy zmniejszyć odstęp między klatkami kluczowymi.
  • Kodery-dekodery. W sesji należy używać właściwego kodera-dekodera. Jeżeli na przykład źródło audio zawiera głos lub głównie głos, należy użyć kodera-dekodera Windows Media Audio 9 Voice. W sesji przechwytywania obrazu należy użyć kodera-dekodera Windows Media Video 9 Screen.
  • Kodowanie dwuprzebiegowe. Zazwyczaj kodowanie dwuprzebiegowe pozwala osiągnąć wyższą jakość, ponieważ w pierwszym przebiegu koder może przeanalizować zawartość.
  • Zmienianie rozmiaru wideo. Wejściowy i wyjściowy rozmiar klatek powinien być taki sam. Nie należy zmieniać rozmiaru wideo źródłowego za pomocą kodera.

Tematy pokrewne

  • Opcje konfiguracji systemu
  • Osiąganie optymalnej wydajności systemu
  • Optymalizowanie audio dla głosu
  • Poprawianie wydajności podczas kodowania ekranów
  • Opis koderów-dekoderów
  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Dopasowanie rozmiaru klatki do źródłowego wideo


Uruchamianie wielu koderów na jednym komputerze

Na jednym komputerze można uruchomić wiele wystąpień programu Windows Media Encoder, pod warunkiem, że komputer dysponuje wystarczającą mocą obliczeniową do ich obsługi. Uruchamiając wiele wystąpień kodera, można:

  • Emitować jednocześnie odrębne strumienie z różnymi szybkościami transmisji bitów.
  • Jednocześnie konwertować wiele plików do formatu Windows Media.
  • Używać jako źródła urządzenia wieloportowego i przesyłać strumieniowo zawartość z każdego portu do innej lokalizacji.

Jeśli podjęto decyzję o uruchomieniu wielu koderów na jednym komputerze, należy pamiętać, że urządzenia wejściowe mogą być używane tylko w jednym procesie w danej chwili, więc może okazać się konieczne zainstalowanie kilku kart przechwytujących audio lub wideo. Aby uzyskać optymalną wydajność, należy używać komputera z dwoma lub więcej procesorami.

Tematy pokrewne

  • Opcje konfiguracji systemu


Kodowanie wsadowe

Jeśli ma być kodowanych wiele plików audio i wideo, można użyć skryptu Windows Media Encoding Script zawartego w programie Windows Media Encoder. Można także zautomatyzować pracę kodera w celu kodowania wsadowego, korzystając ze skryptu i Hosta skryptów systemu Windows.

Więcej informacji o Hoście skryptów systemu Windows i kodowaniu wsadowym zawiera pakiet SDK programu Windows Media Encoder Seria 9.

Tematy pokrewne

  • Opcje konfiguracji systemu
  • Narzędzia kodera – informacje


Często zadawane pytania i rozwiązywanie problemów

Aby uzyskać najnowsze informacje dotyczące pracy z koderem, zobacz stronę Windows Media w witrynie sieci Web firmy Microsoft Web.


Ułatwienia dostępu dla osób niepełnosprawnych

Firma Microsoft jest zaangażowana w tworzenie swoich produktów i usług, tak aby były one łatwiejsze w użyciu dla każdego użytkownika. Następujące tematy dostarczają informacji o funkcjach, produktach i usługach, które ułatwiają osobom niepełnosprawnym dostęp do programu Windows Media Encoder:

  • Funkcje ułatwień dostępu w programie Windows Media Encoder
  • Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder
  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu

obrazek „Uwaga” Uwaga

  • Informacje zawarte w tej sekcji dotyczą tylko użytkowników, którzy uzyskali licencję na produkty firmy Microsoft w Stanach Zjednoczonych. Jeśli uzyskano ten produkt poza granicami Stanów Zjednoczonych, pakiet użytkownika zawiera kartę z informacjami o lokalnych przedstawicielstwach firmy Microsoft, na której znajdują się adresy i numery telefonów obsługi technicznej firmy Microsoft. Można skontaktować się z lokalnym przedstawicielstwem firmy Microsoft, aby dowiedzieć się, czy produkty i usługi opisane w tej sekcji są dostępne w regionie zamieszkania użytkownika. Informacje o dostępności są przetłumaczone na inne wybrane języki, łącznie z francuskim i japońskim. Aby uzyskać więcej informacji, zobacz witrynę sieci Web firmy Microsoft.


Funkcje ułatwień dostępu w programie Windows Media Encoder

Oprócz funkcji i narzędzi ułatwień dostępu w systemie Windows, następujące funkcje ułatwiają użytkownikom niepełnosprawnym dostęp do programu Windows Media Encoder:

  • Korzystanie ze skrótów klawiaturowych

Tematy pokrewne

  • Ułatwienia dostępu dla osób niepełnosprawnych


Korzystanie ze skrótów klawiaturowych

Korzystając z niżej wymienionych skrótów klawiaturowych, w programie Windows Media Encoder można szybko wykonać wiele typowych czynności.

Czynność… | Skrót klawiaturowy…
Wyświetlenie Pomocy kontekstowej. | F1
Przejście do kolejnej opcji w oknie dialogowym lub na arkuszu właściwości. | TAB
Przejście do poprzedniej opcji w oknie dialogowym lub na arkuszu właściwości. | SHIFT+TAB
Przewinięcie o jeden element w górę w polu pokrętła lub liście rozwijanej. | STRZAŁKA W GÓRĘ
Przewinięcie o jeden element w dół w polu pokrętła lub liście rozwijanej. | STRZAŁKA W DÓŁ
Przejście do następnej karty. | STRZAŁKA W PRAWO
Przejście do poprzedniej karty. | STRZAŁKA W LEWO
Odświeżenie aktualnego okna dialogowego lub regulatora (odświeżenie listy dodatków, odświeżenie widoku listy odtwarzania). | F5 lub CTRL+R
Zamknięcie arkusza właściwości, okna dialogowego lub anulowanie kreatora. | ESC
Wykonanie polecenia odpowiadającego aktywnej opcji lub przyciskowi. | ENTER
Wycięcie zaznaczonych elementów i skopiowanie ich do Schowka. | CTRL+X
Skopiowanie zaznaczonych elementów do Schowka. | CTRL+C
Wklejenie zawartości Schowka we wskazanej lokalizacji. | CTRL+V
Wyświetlenie lub ukrycie panelu Właściwości sesji. | ALT+ENTER
Zamknięcie aktualnego okna. | ALT+F4
Wyświetlenie menu skrótów. | SHIFT+F10
Zaznaczenie lub usunięcie zaznaczenia elementu. | SPACJA
Wyświetlenie menu kontekstowego. | Klawisz aplikacji
Przełączenie do trybu wysokiego kontrastu. | LEFT ALT+LEFT SHIFT+PRINT SCREEN

Tematy pokrewne

  • Ułatwienia dostępu dla osób niepełnosprawnych


Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder

Pomoc programu Windows Media Encoder zawiera funkcje, które umożliwiają dostęp do programu znacznej grupie użytkowników, włącznie z użytkownikami, którzy mają ograniczoną zręczność, słaby wzrok lub są niepełnosprawni w inny sposób.

Ponadto Pomoc programu Windows Media Encoder jest dostępna w witrynie sieci Web firmy Microsoft.

Tematy pokrewne

  • Ułatwienia dostępu dla osób niepełnosprawnych


Skróty klawiaturowe do korzystania z okna Pomocy

Korzystając z poniższych skrótów klawiaturowych w Pomocy, można szybko wykonać typowe zadania.

Aby to zrobić… | Użyj tych skrótów klawiaturowych…
Wyświetlić okno Pomocy. | F1
Przełączać się między tematami Pomocy oraz kartami Spis treści, Wyszukaj i Indeks. | F6
Zaznaczyć następny tekst ukryty lub hiperłącze. | TAB
Zaznaczyć poprzedni tekst ukryty lub hiperłącze. | SHIFT+TAB
Wykonać akcję dla wybranego polecenia Pokaż wszystkie, Ukryj wszystkie, tekstu ukrytego lub hiperłącza. | ENTER
Wyświetlić menu Opcje w celu uzyskania dostępu do poleceń paska narzędzi Pomocy. | ALT+O
Ukryć lub wyświetlić okienko zawierające karty Spis treści, Wyszukaj i Indeks. | ALT+O, a następnie T
Wyświetlić poprzednio otwarty temat | ALT+O, a następnie B
Wyświetlić następny temat w poprzednio wyświetlonej serii tematów. | ALT+O, a następnie F
Powrócić do podanej strony głównej. | ALT+O, a następnie H
Wstrzymać otwieranie tematu Pomocy w oknie Pomocy (przydatne jeśli chcesz wstrzymać pobieranie strony sieci Web). | ALT+O, a następnie S
Otworzyć okno dialogowe Opcje internetowe w programie Microsoft Internet Explorer, gdzie można zmienić ustawienia ułatwień dostępu. | ALT+O, a następnie I
Odświeżyć temat (przydatne w przypadku połączenia ze stroną sieci Web). | ALT+O, a następnie R
Wydrukować wszystkie tematy w książce lub tylko wybrany temat. | ALT+O, a następnie P
Zamknąć okno Pomoc. | ALT+F4

Tematy pokrewne

  • Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder


Zmienianie wyglądu tematu Pomocy

transparent programu Windows Media Encoder

Aby zmienić wygląd tematu Pomocy

  1. Aby dostosować kolory, style oraz rozmiary czcionek używanych w Pomocy, otwórz okno Pomocy.
  2. Kliknij menu Opcje, a następnie kliknij polecenie Opcje internetowe.
  3. Na karcie Ogólne kliknij pozycję Dostępność. Zaznacz opcje Ignoruj kolory określone na stronach sieci Web, Ignoruj style określone na stronach sieci Web i Ignoruj rozmiary czcionek określone na stronach sieci Web. Można również użyć ustawień określonych we własnym arkuszu stylów.
  4. Aby zmienić kolory używane w Pomocy, patrz sekcja Zmienianie koloru tła lub tekstu w Pomocy. Aby zmienić czcionkę, patrz sekcja Zmienianie czcionki w Pomocy.

Tematy pokrewne

  • Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder


Zmienianie koloru tła lub tekstu w Pomocy

transparent programu Windows Media Encoder

Aby zmienić kolor tła lub tekstu w Pomocy

  1. Otwórz okno Pomocy.
  2. Kliknij menu Opcje, a następnie kliknij polecenie Opcje internetowe.
  3. Na karcie Ogólne kliknij przycisk Dostępność. Następnie zaznacz opcję Ignoruj kolory określone na stronach sieci Web. Możesz również użyć ustawień określonych we własnym arkuszu stylów.
  4. Aby dostosować kolory używane w Pomocy, na karcie Ogólne kliknij przycisk Kolory. Usuń zaznaczenie pola wyboru Użyj kolorów systemu Windows, a następnie wybierz kolory czcionki i tła, których chcesz użyć.

obrazek „Uwaga” Uwaga

  • Jeśli zmienisz kolor tła tematów Pomocy w oknie Pomocy, zmiany będą miały także wpływ na kolor tła używany podczas przeglądania strony sieci Web w programie Microsoft Internet Explorer.

Tematy pokrewne

  • Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder


Zmienianie czcionki w Pomocy

transparent programu Windows Media Encoder

Aby zmienić czcionkę w Pomocy

  1. Otwórz okno Pomocy.
  2. Kliknij menu Opcje, a następnie kliknij polecenie Opcje internetowe.
  3. Na karcie Ogólne kliknij przycisk Dostępność. Aby używać tych samych ustawień, jak te używane w instancji programu Microsoft Internet Explorer, zaznacz opcję Ignoruj style czcionek określone na stronach sieci Web i Ignoruj rozmiary czcionek określone na stronach sieci Web. Możesz również użyć ustawień określonych we własnym arkuszu stylów.
  4. Aby dostosować style czcionek używane w Pomocy, na karcie Ogólne kliknij przycisk Czcionki, a następnie kliknij styl czcionki, którego chcesz użyć.

obrazek „Uwaga” Uwaga

  • Jeśli zmienisz czcionkę tematów Pomocy w oknie Pomocy, zmiany będą miały także wpływ na czcionkę używaną podczas wyświetlania strony sieci Web w programie Microsoft Internet Explorer.

Tematy pokrewne

  • Funkcje ułatwień dostępu w Pomocy programu Windows Media Encoder


Produkty i usługi firmy Microsoft z ułatwieniami dostępu

Poniższe tematy zawierają informacje na temat funkcji, produktów i usług, dzięki którym ten produkt firmy Microsoft jest łatwiej dostępny dla osób niepełnosprawnych:

  • Ułatwienia dostępu w systemie Microsoft Windows
  • Dostosowywanie produktów firmy Microsoft dla osób potrzebujących ułatwień dostępu
  • Bezpłatne samouczki wykonywane krok po kroku
  • Dokumentacja firmy Microsoft w alternatywnych formatach
  • Technologia wspomagania dla systemu Windows
  • Obsługa klienta dla osób niesłyszących lub słabo słyszących
  • Uzyskiwanie dodatkowych informacji o ułatwieniach dostępu

Informacje zawarte w tej sekcji dotyczą tylko użytkowników, którzy uzyskali licencję na produkty firmy Microsoft w Stanach Zjednoczonych. Jeśli uzyskano ten produkt poza granicami Stanów Zjednoczonych, pakiet użytkownika zawiera kartę z informacjami o lokalnych przedstawicielach firmy Microsoft, na której znajdują się adresy i numery telefonów obsługi technicznej firmy Microsoft. Można skontaktować się z lokalnym przedstawicielem firmy Microsoft, aby dowiedzieć się, czy typy produktów i usług opisane w tej sekcji są dostępne w regionie użytkownika. Ułatwienia dostępu są przetłumaczone na inne wybrane języki, łącznie z francuskim i japońskim. Aby uzyskać więcej informacji, zobacz witrynę sieci Web firmy Microsoft.

Tematy pokrewne

  • Ułatwienia dostępu dla osób niepełnosprawnych


Ułatwienia dostępu w systemie Microsoft Windows

W systemy Microsoft Windows wbudowano wiele funkcji ułatwień dostępu, począwszy od wprowadzenia systemu Windows 95. Funkcje te są użyteczne dla osób mających problemy z pisaniem na klawiaturze lub używaniem myszy, które są niewidome lub mają słaby wzrok, są niesłyszące lub mają problemy ze słuchem. Te funkcje można zainstalować podczas instalacji systemu. Więcej informacji na temat funkcji ułatwień dostępu w produktach firmy Microsoft, takich jak systemy Microsoft Windows XP Professional, Windows XP Home Edition, Windows Millennium Edition, Windows 2000, Windows 98 i Windows 95 znajduje się w witrynie sieci Web firmy Microsoft.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Dostosowywanie produktów firmy Microsoft dla osób potrzebujących ułatwień dostępu

Opcje i funkcje ułatwień dostępu są wbudowane w wiele produktów firmy Microsoft, włączając w to system operacyjny Windows. Opcje i funkcje ułatwień dostępu są przydatne dla użytkowników, którzy mają problemy z pisaniem na klawiaturze lub używaniem myszy, są niewidomi lub mają słaby wzrok, są niesłyszący lub mają słaby słuch.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Bezpłatne samouczki wykonywane krok po kroku

Firma Microsoft udostępnia serię opracowanych samouczków typu krok po kroku, dzięki którym użytkownik może nauczyć się dostosowywać opcje i ustawienia ułatwień dostępu. W samouczkach zawarte są szczegółowe procedury dotyczące takiego dopasowania opcji, funkcji i ustawień, które spełni wymagania osób niepełnosprawnych i potrzebujących ułatwień dostępu. Informacje są przedstawione w formie równoległej, dzięki czemu można szybko dowiedzieć się, jak korzystać z myszy, klawiatury lub myszy w powiązaniu z klawiaturą.

Aby znaleźć samouczki wykonywane krok po kroku dotyczące produktów firmy Microsoft, należy przejść do sekcji Ułatwienia dostępu w witrynie sieci Web firmy Microsoft.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Dokumentacja firmy Microsoft w alternatywnych formatach

Poza standardowymi formatami dokumentacja dla wielu produktów firmy Microsoft dostępna jest w innych formatach w celu ułatwienia dostępu. W przypadku problemów z czytaniem lub obsługą materiałów drukowanych można uzyskać dokumentację dla wielu produktów firmy Microsoft w innych, łatwiej dostępnych formatach. Większość z tych podręczników można pobrać z witryny sieci Web firmy Microsoft.

Firma Microsoft tworzy indeks dostępnej dokumentacji w sekcji Ułatwienia dostępu w witrynie sieci Web firm Microsoft.

Ponadto dodatkowe publikacje firmy Microsoft można uzyskać w firmie Recording for the Blind & Dyslexic, Inc. Dokumenty te dystrybuowane są do zarejestrowanych, uprawnionych członków usługi dystrybucyjnej na kasetach audio lub dyskietkach. Kolekcja zawiera ponad 80000 tytułów, w tym dokumentację produktów Microsoft i podręczniki wydawnictwa Microsoft Press. Więcej informacji o możliwości uzyskania i dostępności dokumentacji produktów firmy Microsoft i książek wydawnictwa Microsoft Press można uzyskać pod adresem:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540

Numer telefonu w Stanach Zjednoczonych: (800) 221-4792
Numer telefonu poza Stanami Zjednoczonymi i Kanadą: (609) 452-0606
Faks: (609) 987-8116

Witryna sieci Web firmy Recording for the Blind & Dyslexic

Adresy witryn sieci Web mogą ulec zmianie, więc połączenie z witryną sieci Web lub innymi wymienionymi witrynami może być niemożliwe.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Technologia wspomagania dla systemu Windows

Aby ułatwić osobom niepełnosprawnym korzystanie z komputera, dostępna jest szeroka gama ułatwień dostępu lub produktów wykorzystujących technologie wspomagające.

Firma Microsoft udostępnia katalog ułatwień dostępu, który można przeszukiwać, działający w systemach operacyjnych Microsoft Windows, w sekcji Ułatwienia dostępu witryny sieci Web firmy Microsoft.

Gama różnych produktów dostępnych dla systemów MS-DOS, Windows i Windows NT obejmuje:

  • Programy powiększające wyświetlane informacje lub zmieniające ich kolor dla osób z wadami wzroku.
  • Programy opisujące informacje wyświetlane na ekranie w alfabecie Braille'a lub za pomocą syntezy mowy dla osób niewidomych lub mających problemy z czytaniem.
  • Rozwiązania sprzętowe i programowe modyfikujące działanie myszy i klawiatury.
  • Pogramy umożliwiające pisanie za pomocą myszy lub głosu.
  • Oprogramowanie do prognozowania słowa lub frazy umożliwiające użytkownikom szybsze pisanie z wykorzystaniem mniejszej ilości naciśnięć klawiszy.
  • Alternatywne urządzenia wejściowe, na przykład z jednym przyciskiem lub wykorzystujące ciśnienie wdychanego i wydychanego powietrza, dla osób które nie mogą korzystać z klawiatury ani myszy.

Aktualizowanie

Jeśli użytkownik korzysta z technologii wspomagającej, przed uaktualnieniem oprogramowania lub sprzętu należy skontaktować się z dostawcą technologii wspomagającej, aby sprawdzić zgodność z produktami zainstalowanymi na komputerze. Dostawca technologii wspomagającej może pomóc użytkownikowi nauczyć się, jak dostosować ustawienia w celu optymalizacji zgodności z wersją systemu Windows lub innymi produktami firmy Microsoft.


Obsługa klienta dla osób niesłyszących lub słabo słyszących

Jeśli użytkownik jest niesłyszący lub niedosłyszący, to poprzez usługę telefonu tekstowego (TTY/TDD) możliwy jest pełen dostęp do produktów firmy Microsoft i obsługi klienta.

Obsługa klienta

Można skontaktować się z centrum informacji o sprzedaży firmy Microsoft za pośrednictwem telefonu tekstowego, wybierając numer (800) 892-5234 pomiędzy godziną 6:30 a 17:30 czasu pacyficznego, od poniedziałku do piątku, z wyłączeniem świąt.

Pomoc techniczna

W celu uzyskania pomocy technicznej na terenie Stanów Zjednoczonych, można skontaktować się z Pomocą techniczną firmy Microsoft za pośrednictwem telefonu tekstowego pod numerem (800) 892-5234 pomiędzy godziną 6:00 a 18:00 czasu pacyficznego, od poniedziałki do piątku, z wyłączeniem świąt. Na terenie Kanady należy wykręcić numer (905) 568-9641 pomiędzy godziną 8:00 a 20:00 czasu wschodniego, od poniedziałku do piątku, z wyłączeniem świąt. Pomoc techniczna firmy Microsoft zależy od cen, terminów i warunków na miejscu oraz czasu skorzystania z usługi.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Uzyskiwanie dodatkowych informacji o ułatwieniach dostępu

Sekcja Ułatwienia dostępu witryny sieci Web firmy Microsoft zawiera informacje o technologii ułatwień dostępu, która pomaga ludziom niepełnosprawnym lepiej wykorzystać komputer do pracy, edukacji i rekreacji. Informacje w tej witrynie przynoszą korzyści ludziom niepełnosprawnym, ich przyjaciołom i członkom rodzin, ludziom w organizacjach pozarządowych, nauczycielom i adwokatom.

Darmowy comiesięczny biuletyn jest dostępny za pomocą poczty e-mail, dzięki czemu użytkownik szybko poznaje najnowsze tematy dotyczące ułatwień dostępu w produktach firmy Microsoft i w sekcji Ułatwienia dostępu witryny sieci Web firmy Microsoft.

Tematy pokrewne

  • Produkty i usługi firmy Microsoft z ułatwieniami dostępu


Słownik

Aby wyszukać termin w słowniku, należy kliknąć literę alfabetu, która jest pierwszą literą szukanego terminu.

Można również przeczytać definicje terminów słownika w tekście Pomocy, klikając podkreślone łącza do terminów słownika. Po kliknięciu łącza słownika, termin słownika i jego definicja zostaną wyświetlone w oknie podręcznym. Aby zamknąć okno, należy kliknąć w dowolnym miejscu ekranu.

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

Symbole

.prx

Rozszerzenie nazwy pliku profilu.

.weu

Rozszerzenie nazwy pliku konfiguracyjnego używanego przez program Skrypt kodowania Windows Media.

.wma

Rozszerzenie nazwy pliku audio w formacie Windows Media. Zawartość audio pliku jest zakodowana za pomocą kodera-dekodera Windows Media Audio.

.wme

Rozszerzenie nazwy pliku sesji programu Windows Media Encoder.

.wmv

Rozszerzenie nazwy pliku wideo w formacie Windows Media.

Powrót do początku

A

Anons

Metaplik pakietu Windows Media udostępniający odtwarzaczowi informacje wymagane do odebrania zawartości. Pliki anonsów zawierają skrypty języka Extensible Markup Language (XML).

Audio Video Interleaved (AVI)

Format plików multimedialnych służących do przechowywania dźwięku i obrazu w formacie RIFF.

Audio wielokanałowe

System reprodukcji dźwięku, w którym obsługiwanych jest kilka, zazwyczaj więcej niż dwa, kanałów dźwięku. Na przykład termin wielokanałowe audio 5.1 odnosi się do systemu dźwięku przestrzennego, w którym występuje pięć kanałów podstawowych i jeden kanał głośnika niskotonowego.

AVI

Zobacz definicję dla: Audio Video Interleaved (AVI)

Powrót do początku

B

Bez przeplotu

Połączenie pól przeplotu w klatce wideo, dzięki czemu podczas odtwarzania linie klatki wideo są rysowane po kolei.

Zobacz też: Z przeplotem

Buforowanie typu postroll

Rozszerzenie rozmiaru kodowanego wideo o określoną liczbę klatek.

Buforowanie typu preroll

Przechwytywanie lub odtwarzanie liczby klatek wideo lub porcji danych audio przez rozpoczęciem kodowania lub renderowania w celu ustabilizowania źródła. Termin używany też jako rzeczownik opisujący porcję danych, która będzie w ten sposób buforowana.

Powrót do początku

C

CBR

Zobacz definicję dla: Stała szybkość transmisji bitów (CBR)

Czas oczekiwania

Opóźnienie występujące podczas przetwarzania lub dostarczania danych.

Częstotliwość próbkowania

Częstotliwość próbkowania. Wyższa częstotliwość próbkowania (czyli więcej próbek pobranych w jednostce czasu) powoduje, że wynik cyfrowy jest bliższy oryginałowi.

Powrót do początku

E

Edytor profili

Narzędzie dostarczane z programem Windows Media Encoder, które służy do tworzenia i edytowania profili kodowania.

Zobacz też: Profil

Emisja pojedyncza

Metoda używana przez serwery multimediów do dostarczania zawartości do połączonych klientów, w której każdy klient odbiera osobny strumień. Żaden inny klient nie ma dostępu do tego strumienia.

Powrót do początku

F

Format piksela

Rozmiar i rozmieszczenie składników koloru piksela. Format jest określony przez całkowitą liczbę bitów używanych na jeden piksel i liczbę bitów używaną do przechowywania składowych kolorów: zielonego, czerwonego, niebieskiego i alfa.

Format strumieniowy

Informacje o właściwościach strumienia, takie jak użyte kodery-dekodery, szybkość i rozmiar klatek. Odtwarzacz używa formatu strumieniowego do dekodowania strumienia.

Format Windows Media

Format używany przez technologie Microsoft Windows Media (lub produkty firm trzecich zawierające licencjonowaną technologię Windows Media) do publikowania, składowania, edytowania, dystrybuowania, przesyłania strumieniowego lub odtwarzania zawartości opartej na osi czasu.

Powrót do początku

I

IEEE 1394

Zobacz definicję dla: Institute of Electrical and Electronics Engineers (IEEE) 1394

Institute of Electrical and Electronics Engineers (IEEE) 1394

Standard magistrali szeregowej o wysokiej szybkości oferujący ulepszoną łączność między komputerem a szeroką gamą urządzeń, łącznie z konsumenckimi urządzeniami audio/wideo, dodatkowymi urządzeniami magazynowania, innymi komputerami i urządzeniami przenośnymi.

Inteligentne przesyłanie strumieniowe

Typ przesyłania strumieniowego, który wykrywa warunki w sieci i dostosowuje właściwości strumienia audio lub wideo w celu uzyskania najlepszej jakości.

Internet Protocol w wersji 6 (IPv6)

Zweryfikowana wersja protokołu Internet Protocol (IP) przeznaczona do zwiększenia liczby adresów w sieci Internet. Ulepszenia obejmują 128-bitowy rozmiar adresu IP, rozszerzone możliwości routingu oraz obsługę uwierzytelniania i prywatności.

Inverse telecine

Służy do usuwania klatek, które zostały dodane podczas konwersji 24-klatkowego filmu do filmu wideo o szybkości 30 klatek na sekundę.

IPv6

Zobacz definicję dla: Internet Protocol w wersji 6 (IPv6)

Powrót do początku

K

Klatka kluczowa

Klatka wideo zawierająca wszystkie dane wymagane do skonstruowania obrazu bez odniesień do poprzednich klatek.

Zobacz też: Klatka różnicowa

Klatka różnicowa

Klatka wideo, która zawiera tylko zmiany w porównaniu do poprzedniej klatki. Odwrotnie, klatka kluczowa zawiera wszystkie dane wymagane do skonstruowania takiej klatki.

Kod czasowy

Sygnał cyfrowy stosowany dla strumienia. Sygnał przypisuje do każdej klatki wideo liczbę, która przedstawia godziny, minuty, sekundy i klatki.

Koder-dekoder

Inna nazwa to kompresor/dekompresor. Oprogramowanie lub sprzęt używane do kompresowania i dekompresowania multimediów cyfrowych.

Koder-dekoder Windows Media Audio

Koder-dekoder używany do kompresji i dekompresji strumieni audio.

Koder-dekoder Windows Media Screen

Koder-dekoder używany do kompresji i dekompresji sekwencji obrazów ekranu.

Koder-dekoder Windows Media Video

Koder-dekoder używany do kompresji i dekompresji strumieni wideo.

Kodowanie

Konwersja zawartości audio lub wideo do określonego formatu cyfrowego.

Kodowanie dwuprzebiegowe

Metoda kodowania, w której zawartość jest analizowana podczas pierwszego przebiegu, a podczas drugiego jest kodowana. Zobacz też kodowanie jednoprzebiegowe.

Kodowanie jednoprzebiegowe

Metoda kodowania, w której zawartość jest analizowana i kompresowana podczas jednego przebiegu kodera.

Zobacz też: Kodowanie dwuprzebiegowe

Kompresja

Proces usuwania nadmiarowych danych z cyfrowych plików multimedialnych lub strumienia multimediów cyfrowych w celu zmniejszenia jego rozmiaru lub lepszego wykorzystania przepustowości.

Kompresja bezstratna

Proces kompresji danych, w którym informacje są organizowane w bardziej zwartej formie i są przywracane do oryginalnego stanu podczas dekompresji.

Kompresja stratna

Proces kompresji danych, w którym informacje uznane za niewymagane są usuwane i nie można ich przywrócić podczas dekompresji. Zazwyczaj używana z plikami danych audio i wideo, w których akceptowany jest nieznaczny spadek jakości.

Powrót do początku

L

Letterbox

Format wyświetlania wideo, w którym czarne paski są wyświetlane u dołu i u góry odtwarzanego obrazu wideo. Format letterbox zachowuje oryginalny współczynnik proporcji obrazu podczas wyświetlania w oknie o innym współczynniku proporcji.

Licencja

Dane dołączone do chronionej zawartości, opisujące sposób używania zawartości.

Powrót do początku

M

MBR

Zobacz definicję dla: Wiele szybkości transmisji bitów (MBR)

Metadane

Dane dotyczące danych. Tytuł, temat, autor i rozmiar są przykładami metadanych pliku.

Metaplik pakietu Windows Media

W technologii Windows Media Technologies, plik zawierający informacje o plikach pakietu Windows Media i ich prezentacji. Rozszerzenia nazw metaplików pakietu Windows Media obejmują .asx, .wax, .wvx, .wmx i .nsc.

Modulacja kodowo-impulsowa (PCM)

Technika digitalizacji dźwięku w nieskompresowanym formacie, polegająca na przypisywaniu wartości do amplitudy sygnału w ustalonych interwałach.

Multiemisja

Metoda dostarczania zawartości, w której pojedynczy strumień jest przesyłany z serwera multimediów do wielu klientów. Klienci nie nawiązują połączenia z serwerem. Zamiast tego serwer wysyła poprzez sieć pojedynczą kopię strumienia do routerów obsługujących multiemisję, które replikują dane. Klienci mogą potem odebrać strumień, monitorując określony port i adres IP multiemisji.

Powrót do początku

N

Nagłówek

Część struktury pliku, która zawiera informacje wymagane przez aplikację do dekompresowania i renderowania zawartości. Nagłówek w pliku chronionym zawiera też informacje wymagane do pobrania licencji.

National Television Standards Committee (NTSC)

Wiodący standard telewizyjny w Stanach Zjednoczonych i Japonii. W standardzie NTSC wyświetlanych jest 30 klatek na sekundę z przeplotem, przy rozdzielczości 525 linii.

NTSC

Zobacz definicję dla: National Television Standards Committee (NTSC)

Powrót do początku

P

PAL

Zobacz definicję dla: Phase Alternating Line (PAL)

PCM

Zobacz definicję dla: Modulacja kodowo-impulsowa (PCM)

Pętla

Ciągłe powtarzanie strumienia.

Phase Alternating Line (PAL)

Wiodący standard telewizyjny w Chinach i Europie. W standardzie PAL wyświetlanych jest 25 klatek na sekundę z przeplotem, przy rozdzielczości 625 linii.

Plik formatu strumieniowego

Plik używany przez odtwarzacz do dekodowania strumienia multiemisji.

Zobacz też: Format strumieniowy

Plik konfiguracyjny

Plik tekstowy używany przez Skrypt kodowania Windows Media określający zawartość, która będzie kodowana i opcje wiersza poleceń, które zostaną wywołane.

Plik pakietu Windows Media

Plik zawierający dane audio, wideo lub skryptów w formacie Windows Media. W zależności od zawartości i przeznaczenia pliki pakietu Windows Media mają różne rozszerzenia nazw, takie jak: .wma, .wme, .wms, .wmv, .wmx, .wmz lub .wvx.

Podpis

Tekst towarzyszący obrazom lub filmom wideo, będący dodatkowym opisem lub transkrypcją tekstu mówionego.

Polecenia skryptów

Nazwane dane skojarzone z określonym czasem w zawartości opartej na formacie Windows Media. Dane mogą być wykorzystywane przez odtwarzacze do wykonania określonej akcji, takiej jak otwieranie strony sieci Web.

Profil

Grupa ustawień pasujących do typu zawartości i szybkości przesyłania bitów w odpowiednich koderach-dekoderach audio i wideo.

Próbkowanie

Proces pomiaru amplitudy sygnału analogowego w regularnych odstępach czasu w celu konwersji sygnału analogowego do formatu cyfrowego.

Przepustowość

Zdolność sieci do przesyłania określonej ilości danych w określonym czasie.

Punkt publikacji

Zorganizowana lokalizacja w pamięci, która dokonuje translacji żądań klientów dotyczących zawartości na ścieżkę fizyczną na serwerze przechowującym zawartość. Punkt publikacji w istocie działa jako przekierowywacz.

Powrót do początku

R

RGB

Model koloru opisujący informacje o kolorze za pomocą wartości intensywności kolorów – czerwonego (R), zielonego (G) i niebieskiego (B) – z których powstaje kolor.

Powrót do początku

S

Stała szybkość transmisji bitów (CBR)

Charakterystyka strumienia danych, w której szybkość transmisji bitów pozostaje prawie jednorodna w całym strumieniu.

Zobacz też: Zmienna szybkość transmisji bitów (VBR)

Strumień

Multimedia cyfrowe, które są dostarczane w sposób ciągły przez sieci.

Szybkość klatek

Liczba klatek wideo wyświetlanych w ciągu sekundy. Większa szybkość klatek przeważnie sprawia, że ruch w filmie jest płynniejszy.

Szybkość transmisji bitów

Liczba bitów przesyłanych w ciągu sekundy.

Ściąganie

Dostarczanie danych do klienta tylko na jego żądanie.

Powrót do początku

T

Telecine

System konwersji filmu do wideo, który dodaje ramki do wideo w celu kompensacji różnic w szybkościach klatek między filmem a wideo.

Powrót do początku

U

UDP

Zobacz definicję dla: User Datagram Protocol (UDP)

UNC

Zobacz definicję dla: Universal Naming Convention (UNC)

Universal Naming Convention (UNC)

Pełna nazwa zasobu w sieci. Odpowiada składni \\nazwaserwera\nazwaudziału, gdzie nazwaserwera jest nazwą serwera, a nazwaudziału jest nazwą udostępnionego zasobu. Nazwy plików i katalogów w konwencji UNC mogą zawierać również ścieżkę do katalogu pod nazwą zasobu, według następującej składni: \\nazwaserwera\nazwaudziału\katalog\nazwapliku.

User Datagram Protocol (UDP)

Protokół transportu bezpołączeniowego w stosie protokołu TCP/IP, używany gdy dopuszczalna jest utrata niektórych pakietów, na przykład w strumieniach multimediów cyfrowych.

Powrót do początku

V

VBR

Zobacz definicję dla: Zmienna szybkość transmisji bitów (VBR)

Powrót do początku

W

Wiele szybkości transmisji bitów (MBR)

Charakterystyka strumienia dźwięku, w której zawartość jest kodowana z kilkoma różnymi szybkościami transmisji bitów w celu optymalizacji dostarczania zawartości.

Współczynnik proporcji

Stosunek szerokości obrazu do jego wysokości.

Wypychanie

Dostarczanie danych do klienta bez żądania klienta dotyczącego tych danych.

Powrót do początku

Y

YUV

Model koloru opisujący informacje o kolorze za pomocą składników jego jaskrawości (luminancja lub Y) i koloru (chrominancja lub U i V).

Powrót do początku

Z

Z przeplotem

Wyświetlanie klatki wideo w dwóch polach. Jedno pole zawiera parzyste linie klatki, a drugie pole zawiera nieparzyste linie klatki. Podczas odtwarzania najpierw wyświetlane są linie jednego pola, a następnie linie drugiego pola.

Zakres dynamiki

Różnica (w decybelach) między najcichszym i najgłośniejszym dźwiękiem w pojedynczym elemencie zawartości audio.

Zawartość

Audio, wideo, obrazy, tekst lub inne informacje znajdujące się w cyfrowym pliku multimedialnym lub strumieniu.

Zmienna szybkość transmisji bitów (VBR)

Charakterystyka strumienia danych, w której szybkość transmisji bitów zmienia się w zależności od złożoności danych.

Znacznik

Ciąg tekstowy skojarzony z odpowiednim czasem w zawartości opartej na formacie Windows Media. Znaczniki często wskazują odpowiednie punkty rozpoczęcia odtwarzania, takie jak początek nowej sceny.

Źródło

Zawartość audio i wideo, która może zostać przechwycona lub zakodowana z pliku lub urządzeń zainstalowanych w komputerze.

Powrót do początku

© 2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.


Dodawanie dostawcy

Określanie nowego dostawcy usług licencyjnych, który zostanie dodany.

  • Nazwa. Należy wpisać przyjazną nazwę dla dostawcy.
  • Adres URL. Należy wpisać adres URL witryny sieci Web dostawcy.
  • Znajdź dostawcę. Należy kliknąć to łącze, aby przejść do witryny sieci Web zawierającej listę dostawców, których można wybrać.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości


Rozmiar wideo

Przycinanie, zmienianie rozmiaru i zachowywanie współczynnika proporcji pikseli wideo źródłowego.

  • Przycinanie. Należy kliknąć domyślną metodę przycinania wejściowego wideo lub kliknąć opcję Niestandardowe, aby ręcznie przyciąć obraz wideo. Przycięta szerokość i wysokość muszą mieć parzystą liczbę pikseli (na przykład 300 x 320 pikseli, ale nie 300 x 321 pikseli).

    W przypadku gdy źródłem jest plik, koder może wykryć rozmiar źródła wideo przed rozpoczęciem kodowania; gdy źródłem są urządzenia lub programy do przechwytywania ekranu, rozmiar wejścia nie może zostać wykryty przed kodowaniem. Z tego względu, gdy źródłem są urządzenia lub programy do przechwytywania ekranu, należy określić rozmiar wejścia podczas przycinania lub zmiany rozmiaru wideo. Gdy zostanie to zrobione, koder wykryje bieżący rozmiar wejścia po rozpoczęciu kodowania. Jeśli rzeczywisty rozmiar wejścia będzie inny niż określony, do bieżącego rozmiaru wejścia zostanie zastosowana procentowa wartość przycięcia (a nie bieżąca wartość w pikselach).

    Po zastosowaniu zmian w sesji, ale przed rozpoczęciem kodowania, w obszarze Wejście na panelu Wideo głównego okna kodera jest wyświetlany obraz przed przycięciem. (Jeśli źródłem jest urządzenie obsługujące przycinanie sprzętowe, to wyświetlany jest obraz przycięty.) Podczas kodowania przycięty obraz wyświetlany jest w obszarach Wejście i Wyjście.

  • Współczynnik proporcji pikseli. Należy wybrać wartość odpowiadającą współczynnikowi proporcji źródła lub wybrać opcję Niestandardowy. Kodowane wyjście będzie odpowiadać wybranemu współczynnikowi proporcji. (W przypadku opcji DV i anamorficznej, wartości przedstawiające współczynnik proporcji klatek i współczynnik proporcji pikseli są wyświetlane w nawiasach). To pole jest dostępne, jeśli zaznaczono pole wyboru Zezwalaj na wyjście o niekwadratowych pikselach w oknie dialogowym Ustawienia kodowania niestandardowego, które jest dostępne na karcie Kompresja.
  • Zmienianie rozmiaru. Jeśli dla źródła zawartości wideo można wykryć rozmiar (źródło plikowe), należy kliknąć opcję Automatyczne, aby rozmiar wideo został automatycznie zmieniony na podstawie wykonanego przycinania i dostępnej przepustowości określonej w profilu. (Gdy źródłem są urządzenia, opcja Automatyczne działa tak samo jak Bez zmiany rozmiaru.) Należy kliknąć opcję Bez zmiany rozmiaru, jeśli wymiary obrazu wyjściowego mają odpowiadać przyciętemu obrazowi wejściowemu. Należy kliknąć opcję Taki sam jak profil, jeśli obraz wyjściowy ma zostać rozciągnięty do wymiarów określonych na karcie szybkości transmisji bitów. (Aby uzyskać dostęp do karty szybkości transmisji bitów, należy kliknąć kartę Kompresja, kliknąć przycisk Edytuj, a następnie kliknąć kartę szybkości transmisji bitów, dla której przeprowadzana jest zmiana rozmiaru.) Jeśli kodowana jest zawartość MBR, z listy Szybkość transmisji bitów można wybrać szybkość transmisji bitów, dla której zostanie przeprowadzona zmiana rozmiaru, a następnie osobno zmieniać rozmiar każdej szybkości transmisji bitów. (Szybkość transmisji bitów można zmieniać, tylko gdy wybrano opcję zmiany rozmiaru Niestandardowa lub Taki sam jak profil.)

Tematy pokrewne

  • Przycinanie i zmienianie rozmiaru wideo przed zakodowaniem


Anulowany anons

Jeśli zawartość w postaci strumienia multiemisji ma być przesyłana z serwera korzystającego z programu Windows Media Services, należy najpierw utworzyć anons strumienia. Jeśli użytkownik ma uprawnienia dostępu do usługi Windows Media Services za pomocą technologii DCOM, może użyć Kreatora anonsu multiemisji w koderze do utworzenia anonsu; można także utworzyć anons na serwerze Windows Media. Informacje na temat tworzenia anonsów z wykorzystaniem kodera zawiera sekcja Tworzenie anonsu dla multiemisji. Informacje na temat tworzenia anonsu na serwerze zawiera Pomoc programu Windows Media Services.

Jeśli zawartość w postaci strumienia emisji pojedynczej ma być przesyłana z serwera Windows Media, nie jest konieczne tworzenie anonsu.


Wymagany format HTTP

Adres URL w formacie HTTP ma postać http://nazwa_serwera_sieci_Web.


Wymagany format UNC

Ścieżka UNC ma postać \\nazwa_komputera\nazwa_folderu.


Publikowanie plików

Należy określić tymczasową lokalizację plików. Po zakończeniu pracy Kreatora anonsu multiemisji można zapisać pliki na serwerze sieci Web, a następnie rozpocząć strumieniowe przesyłanie emisji.


Tworzenie anonsu

Utworzono punkt publikacji, który będzie dystrybuować zawartość jako zawartość strumieniową multiemisji z serwera wykorzystującego program Windows Media Services. Przed rozpoczęciem przesyłania strumieniowego z serwera należy utworzyć anons dla strumienia. Do utworzenia anonsu można użyć Kreatora anonsu multiemisji w koderze; można też utworzyć anons na serwerze Windows Media. Informacje na temat tworzenia anonsu z wykorzystaniem kodera zawiera sekcja Tworzenie anonsu dla multiemisji. Informacje na temat tworzenia anonsu na serwerze zawiera Pomoc programu Windows Media Services.


Rozpoczynanie archiwizacji podczas emisji

Jeśli archiwizacja została skonfigurowana przed rozpoczęciem kodowania sesji emisji, archiwizacja rozpoczyna się automatycznie po rozpoczęciu kodowania. Jednakże jeśli decyzja o rozpoczęciu archiwizacji zostanie podjęta po rozpoczęciu kodowania sesji emisji, należy rozpocząć archiwizację ręcznie, klikając opcję Uruchom archiwizację w menu Sterowanie.


Panel audio

Panel audio zawiera regulatory do monitorowania i dopasowywania poziomu głośności kodowanego strumienia audio. Regulatory są następujące:

  • Miernik poziomu nagrywania. Wyświetla w formie graficznej poziom dźwięku zawartości podczas kodowania. Wraz ze wzrostem poziomu dźwięku, kolor miernika zmienia się z zielonego, przez żółty, do czerwonego. Nagrywanie przy zbyt wysokim (głównie czerwonym) lub zbyt niskim (głównie zielonym) poziomie da nieodpowiedni wynik. Aby uzyskać najlepsze wyniki, należy utrzymywać stały poziom sygnału.
  • Regulator poziomu nagrywania. Ten regulator jest podobny do głównego regulatora poziomu nagrywania w aplikacji miksera dostarczanej wraz z kartą dźwiękową. Aby dostosować poziom dźwięku kodowanej zawartości, należy przesunąć suwak. Po ustawieniu tego regulatora w koderze, jednocześnie zmienia się ustawienie w aplikacji miksera. Jeśli karta dźwiękowa nie obsługuje głównego regulatora poziomu nagrywania, regulator ten jest niedostępny.
  • Przycisk Wycisz. Aby wyciszyć ścieżkę audio podczas kodowania, należy kliknąć ten przycisk. Dostępność przycisku zależy od karty przechwytywania. Jeśli karta nie zawiera regulatora wyciszania, przycisk Wycisz na koderze jest niedostępny.
  • Przycisk Mikser. Aby dostosować głośność dla różnych urządzeń wejściowych, na przykład kamery, mikrofonu i stacji dysków CD, należy kliknąć ten przycisk. Można także użyć głównego regulatora w celu dostosowania głośności wszystkich urządzeń wejściowych. Kliknięcie przycisku Mikser uruchamia aplikację miksera nagrywania dostarczoną z kartą do przechwytywania. Przycisk Mikser dostępny jest tylko po wybraniu urządzenia audio.


Format jest nieprawidłowy

Co najmniej jedno ustawienie w tej sesji jest niezgodne z używanym koderem-dekoderem. Na przykład koder-dekoder może wymagać jednakowej szerokości i wysokości klatki źródłowego wideo (lub wyjścia, w przypadku przycinania). Ewentualnie wybrany format audio jest niezgodny z koderem-dekoderem. Jeżeli na przykład użytkownik używa kodera-dekodera Windows Media Audio 9 Professional w trybie kodowania opartego na jakości VBR, najwyższe możliwe ustawienie jakości to 98. Być może format audio wykorzystuje format 5.1 kanałów, ale audio źródłowe jest 2-kanałowe. Aby zmienić format audio, należy na karcie Kompresja panelu Właściwości kliknąć polecenie Edytuj. Następnie należy kliknąć kartę szybkości transmisji bitów i w obszarze Format audio wybrać z listy format audio.


Zmienianie marginesów przycinania

Szerokość i wysokość przyciętego wideo muszą być większe niż 16 pikseli.


Wpisywanie nazwy punktu publikacji

Wpisz nazwę istniejącego lub nowego punktu publikacji, przez który ma być przesyłany strumień.

Tematy pokrewne

  • Wypychanie strumienia z kodera


Może być wymagany anons dla multiemisji

Jeśli jest planowana dystrybucja zawartości w postaci strumienia multiemisji z serwera, na którym działa program Windows Media Services, najpierw należy utworzyć anons dla tego strumienia. Jeśli użytkownik ma uprawnienia dostępu do usługi Windows Media Services za pośrednictwem technologii DCOM, może użyć Kreatora anonsu multiemisji w koderze; w przeciwnym razie musi utworzyć anons na serwerze Windows Media. Informacje na temat tworzenia anonsu z wykorzystaniem kodera znaleźć można w sekcji Tworzenie anonsu dla multiemisji. Informacje na temat tworzenia anonsu na serwerze znaleźć można w Pomocy programu Windows Media Services.

Jeżeli planujesz dystrybucję zawartości w postaci strumienia emisji pojedynczej z serwera Windows Media, nie trzeba tworzyć anonsu.


Konfigurowanie urządzeń

Wymienione są tutaj wszystkie urządzenia używane w bieżącej sesji. Urządzenia, które zostały zainstalowane na komputerze, ale obecnie nie są używane, nie są wyświetlane. Urządzenia mogą być używane tylko przez jedno źródło w każdej sesji.

Aby edytować właściwości urządzenia, wybierz to urządzenie, kliknij przycisk Konfiguruj, a następnie poddaj edycji właściwości. Właściwości, które można edytować, zależą od marki używanego urządzenia.

obrazek „Uwaga” Uwaga

  • Urządzenia do przechwytywania ekranu nie są wymienione. Można je skonfigurować w panelu Właściwości.


Kończenie pracy Kreatora anonsu

Kliknij przycisk Zakończ, aby zakończyć pracę kreatora. Kreator może utworzyć następujące typy plików:

  • Plik z informacjami o multiemisji (.nsc). Jest to plik, który zawiera informacje o formacie strumienia i adres multiemisji.
  • Plik anonsu (.asx). Plik przekierowania, który wskazuje odtwarzaczowi plik z informacjami o multiemisji.
  • (Opcjonalne) Strona sieci Web (.htm). Strona sieci Web z osadzonym odtwarzaczem i łączem do pliku anonsu.


Ustawienia kompresji dla wielokanałowego audio

W przypadku kodowania wielokanałowego audio należy użyć kodera-dekodera Windows Media Audio 9 Professional lub Windows Media Audio 9 Lossless i formatu audio obsługującego wiele kanałów.

Tematy pokrewne

  • Pobieranie źródła z plików wielokanałowego audio


Ustawienia kompresji dla przechwytywania ekranu

Podczas przechwytywania ekranu należy użyć profilu przechwytywania ekranu. Profil korzysta z ustawień, które są zoptymalizowane dla przechwytywania obrazu, na przykład z kodera-dekodera Windows Media Video Screen. Aby użyć profilu przechwytywania obrazu, kliknij kartę Kompresja. W polu Cel kliknij opcję Serwer Windows Media lub Serwer sieci Web, a następnie kliknij opcję Przechwytywanie obrazu.

Dostępnych jest wiele opcji konfigurowania sesji kodowania i komputera w celu zwiększenia wydajności podczas przechwytywania obrazów. Więcej informacji znaleźć można w sekcji Poprawianie wydajności podczas kodowania ekranów.


Karta Połączenia

Karta Połączenia zawiera listę adresów IP wszystkich klientów aktualnie połączonych z koderem podczas bezpośredniej emisji z kodera. Klientami mogą być serwery Windows Media, serwery sieci Web lub odtwarzacze.

Aby skopiować adres IP lub adres URL sieci LAN komputera kodującego do odtwarzacza, kliknij polecenie Kopiuj internetowy adres URL lub Kopiuj adres URL sieci LAN. Odtwarzacze używają adresów URL do łączenia się z koderem, dzięki czemu możliwe jest przetestowanie strumienia.


Tworzenie plików

Należy podać nazwę dla plików tworzonych za pomocą kreatora. Wszystkie pliki będą miały tę samą nazwę, ale do nazwy pliku zostaną dołączone odpowiednie rozszerzenia. Kreator utworzy co najmniej plik anonsu (.asx) i plik informacji o multiemisji (.nsc). Plik anonsu jest to metaplik pakietu Windows Media, który wskazuje odtwarzaczowi plik informacji o multiemisji. Plik informacji o multiemisji zawiera informacje, które umożliwiają odtwarzaczom uzyskanie dostępu i dekodowanie strumienia multiemisji, łącznie z adresem IP, portem i informacjami o formacie strumienia.

Należy wybrać, czy utworzyć stronę sieci Web (.htm), która zawiera łącze do anonsu i osadzony odtwarzacz.


Ustawienia

To okno dialogowe służy do wybierania urządzenia, które będzie używane w tej sesji sterowania urządzeniem.


Panel urządzenia

Panel Urządzenia zawiera przyciski, których można używać do sterowania urządzeniem, dla którego włączono sterowanie urządzeniem.

Tematy pokrewne

  • Włączanie sterowania urządzeniem
  • Konfigurowanie listy EDL


Ustawienia urządzenia

To okno dialogowe oferuje zaawansowane opcje konfigurowania listy EDL.

  • Buforowanie typu preroll. Określa liczbę klatek w odniesieniu do znacznika początkowego, które będą odtwarzane przed rozpoczęciem kodowania. Buforowanie typu preroll stabilizuje taśmę, dzięki czemu linie, brak synchronizacji i inne artefakty powstające podczas uruchamiania urządzenia nie są kodowane. Buforowanie typu preroll powinno występować przed czasem oczekiwania na uruchomienie, tak więc podczas obliczania liczby klatek użytych w buforowaniu typu preroll należy wziąć pod uwagę opóźnienie systemu.
  • Czas oczekiwania na zatrzymanie. Określa liczbę klatek w odniesieniu do znacznika końcowego, które zostaną zakodowane. Zapewnia to, że koder przechwyci ostatnią klatkę klipu przed zakończeniem pracy.
  • Czas oczekiwania na uruchomienie. Określa liczbę klatek w odniesieniu do znacznika początkowego, które zostaną zakodowane przez koder. To ustawienie kompensuje opóźnienie występujące między wydaniem polecenia kodowania, a rzeczywistym rozpoczęciem kodowania. Aby określić opóźnienie w klatkach, należy poeksperymentować z systemem. Po wyznaczeniu długości opóźnienia w klatkach można uruchamiać koder szybciej o tę liczbę klatek w odniesieniu do znacznika początkowego. Na przykład, jeśli komputer rozpoczyna kodowanie po 10 klatkach, a użytkownik chce rozpocząć kodowanie od pierwszej klatki, należy ustawić czas oczekiwania na połączenie na -9 (9 klatek przed rzeczywistą klatką, od której ma się rozpocząć kodowanie).
  • Format wideo. Określa format wideo źródłowego.


Poufność informacji DRM

Aby utworzyć lub edytować profil zarządzania prawami cyfrowymi (DRM), należy uzyskać dostęp do innego dostawcy w sieci Internet. Częścią tworzenia profilu może być podanie informacji osobistych wymaganych przez innego dostawcę, takich jak informacje bilingowe. Zalecane jest, aby przez podaniem informacji sprawdzić, czy witryna sieci Web dostawcy oferuje bezpieczne połączenie.

Po ukończeniu tworzenia lub edytowania profilu można go używać do chronienia zawartości podczas kodowania.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości


Lista decyzji dotyczących edycji

To okno dialogowe umożliwia określenie za pomocą sygnatury czasowej dokładnych punktów rozpoczęcia i zakończenia kodowania zawartości audio lub wideo.

W obszarze Urządzenie należy kliknąć przycisk odtwarzania zawartości z urządzenia. Aby znaleźć wymaganą klatkę punktu początkowego lub końcowego, można użyć przycisków szybkiego przewijania do przodu lub przewijania do tyłu, lub klikać przyciski Poprzednia klatka i Następna klatka.

Aby ustawić szybkość przeszukiwania urządzenia, należy wybrać opcję Najwolniej, Wolno, Normalnie, Szybko lub Najszybciej. Urządzenie może nie obsługiwać wszystkich wymienionych szybkości. Jeśli znana jest sygnatura czasowa poszukiwanej klatki, należy wpisać ją w polu Wyszukaj, a następnie kliknąć przycisk Przejdź!.

Aby zmieniać kolejność wpisów na liście EDL, należy klikać przyciski strzałek.

Po ukończeniu konfigurowania listy EDL można rozpocząć kodowanie, klikając przycisk Uruchom kodowanie na pasku narzędzi.


Karta EDL

Na karcie EDL wyświetlane są czasy znacznika początkowego i znacznika końcowego dla wszystkich klipów na liście EDL. Wyświetlane są również procentowe statystyki ukończenia dla każdego klipu.


Karta Dziennik zdarzeń

Na karcie Dziennik zdarzeń wyświetlane są wszystkie zdarzenia, które wystąpiły podczas bieżącej sesji kodowania.

Jeśli zostanie wybrana opcja rejestrowania w pliku, należy określić nazwę pliku dziennika. Jeśli kodowanie zostanie zatrzymane, a następnie uruchomione ponownie, nowe zdarzenia zostaną dołączone do pliku dziennika.

Gdy zostanie osiągnięty maksymalny rozmiar pliku dziennika (1 024 znaki), w pliku nie będą rejestrowane nowe zdarzenia. Aby wznowić rejestrowanie, należy utworzyć plik dziennika, usuwając zaznaczenie i zaznaczając ponownie pole wyboru Rejestruj w pliku.


Karta Ogólne

Na karcie Ogólne wyświetlane są następujące informacje:

  • Wejście. Identyfikuje aktualnie wybrane źródło.
  • Kodowanie. Zawiera następujące informacje: ustawienia kodowania używane w tej sesji; czy zawartość jest chroniona za pomocą DRM; rozmiar obrazu wideo; czy zastosowano filtry wstępnego przetwarzania; szybkość transmisji bitów; oczekiwana i rzeczywista (średnia) szybkość klatek; całkowita liczba poleceń skryptów wstawionych do strumienia.
  • Wyjście. Dla sesji kodowania (lub archiwizowania) do pliku wyświetla listę tworzonych plików. Dla emisji wyświetla porty emisji i liczbę połączonych klientów. Dla emisji przez serwer Windows Media wyświetla adres URL używany przez klientów do łączenia się z emisją z serwera.
  • Postęp. Identyfikuje czas, który upłynął od rozpoczęcia kodowania. Dla źródeł plikowych identyfikuje szacowany czas do ukończenia kodowania zawartości i procentową wartość ukończenia.
  • System. Identyfikuje ilość pozostałego miejsca na dysku twardym, procentową wartość zasobów procesora używanych w tej sesji i czas, po upływie którego dysk twardy zostanie zapełniony.


Wyjście

Wybierz opcję dla dystrybucji zawartości:

  • Wypychaj do serwera Windows Media. Wybierz tę opcję, aby koder zainicjował połączenie za pomocą protokołu HTTP z serwerem programu Windows Media Services. Należy podać nazwę serwera i punktu publikacji. Jeśli punkt publikacji nie istnieje na serwerze, jest tworzony automatycznie w zależności od tego, czy użytkownik ma odpowiednie uprawnienia dostępu do serwera Windows Media. (Podczas tworzenia punktu publikacji należy używać tylko znaków alfanumerycznych. Ponadto w nazwie punktu publikacji niedozwolone jest stosowanie następujących znaków: * < > \ ? % & # " { } | ^ [ ] `). Aby użyć właściwości ustawionych w innym punkcie publikacji, możesz wpisać nazwę istniejącego punktu publikacji w polu Kopiuj ustawienia z (opcjonalnie). Kliknij polecenie Automatycznie usuwaj, aby usunąć punkt publikacji z serwera po zamknięciu kodera lub po upłynięciu kilkuminutowego limitu czasu. (Limit czasu umożliwia zatrzymanie a następnie ponowne uruchomienie kodowania bez konieczności tworzenia punktu publikacji. Jest to przydatne, na przykład gdy chcesz dostosować ustawienia w sesji, a następnie kontynuować kodowanie.)
  • Ściągnij z kodera. Wybierz tę opcję, jeśli chcesz, aby odtwarzacz lub serwer Windows Media inicjalizował połączenie z koderem za pomocą protokołu HTTP. Domyślnie wykorzystywany jest port 8080. Koder obsługuje do pięciu połączeń bezpośrednich. Karta Połączenia na Panelu monitorowania zawiera listę adresów URL, których klienci mogą używać do łączenia się z koderem.
  • Koduj do pliku. Zaznacz tę opcję, jeśli zamierzasz dystrybuować w późniejszym czasie lub archiwizować kopię transmisji. Możesz ograniczyć rozmiar lub czas trwania pliku. Limit jest stosowany w pliku wyjściowym a nie źródłowym. W przypadku ograniczania rozmiaru pliku należy wpisać odpowiedni rozmiar, a następnie literę K (kilobajty), M (megabajty) lub G (gigabajty). W przypadku ograniczania czasu trwania pliku należy wprowadzić czas trwania pliku wyjściowego w godzinach, minutach i sekundach. Domyślnie plik jest indeksowany przy każdej klatce kluczowej, co umożliwia użytkownikom odtwarzanie zawartości w określonym punkcie z wykorzystaniem funkcji przeszukiwania w odtwarzaczu. Można zmienić moment ostrzegania przez koder o małej ilości miejsca na dysku; wartością domyślną jest jeden megabajt. W polu Ostrzegaj przy małej ilości miejsca na dysku wpisz liczbę, a następnie literę K, M lub G, odpowiednio dla kilobajtów, megabajtów lub gigabajtów.

    obrazek „Uwaga” Uwaga

    • Jeżeli ograniczysz czas trwania pliku wyjściowego i użyjesz w sesji funkcji kompresji czasu, plik wyjściowy może mieć mniejszą lub większą zawartość od oczekiwanej. Jeżeli na przykład ograniczysz plik wyjściowy do 30 minut, a następnie przyspieszysz odtwarzanie pliku 2 razy, plik wyjściowy będzie trwał 30 minut, ale będzie zawierał 60 minut zawartości.

Tematy pokrewne

  • Opcje wyjściowe
  • Stosowanie kompresji czasu w zawartości


Niestandardowe ustawienia kodowania – ogólne

Wyświetlanie lub modyfikowanie ustawień profilu.

  • Nazwa i Opis. Podczas tworzenia profilu należy wpisać nazwę profilu. W nazwie nie należy używać gwiazdki (*). Opis jest opcjonalny.
  • Język. Wybierz język zawartości. (Domyślnym jest język ustawiony na komputerze kodującym.) Jeśli zawartość jest kodowana w kilku językach, użytkownicy mogą wybrać swój język podczas odtwarzania.
  • Importuj i Eksportuj. Kliknij polecenie Importuj, aby zaimportować istniejący profil do edycji. Profile mają nazwę z rozszerzeniem .prx. Kliknij przycisk Eksportuj, aby zapisać zmiany wprowadzone w profilu.
  • Typy multimediów. Należy określić kombinację typów źródła, które ma obsługiwać ten profil. Po wybraniu skryptów podczas kodowania można wstawić polecenia skryptów do strumienia. Każdy typ źródłowy zajmuje część przepustowości używanej do kodowania. Z listy należy wybrać tryb VBR, którego chcesz użyć dla audio i wideo. Aby użyć jednoprzebiegowego kodowania CBR, kliknij polecenie CBR. (Aby użyć dwuprzebiegowego kodowania CBR należy także zaznaczyć pole wyboru Kodowanie dwuprzebiegowe na karcie Kompresja.) Można także wybrać kodery-dekodery, których chcesz użyć. Należy pamiętać, że nie wszystkie kodery-dekodery obsługują tryby VBR lub dwuprzebiegowe kodowanie CBR.
  • Szybkości transmisji bitów. Zawiera listę wszystkich aktualnie wybranych szybkości transmisji bitów (oprócz opartego na jakości kodowania VBR, ponieważ określenie szybkości transmisji bitów z góry jest niemożliwe). Aby utworzyć inną szybkość transmisji bitów dla zawartości, należy kliknąć przycisk Dodaj. (W przypadku trybów kodowania VBR, ta opcja jest niedostępna, jeśli na liście znajduje się szybkość transmisji bitów.) Aby dostosować szybkość transmisji bitów, należy ją wybrać, a następnie kliknąć przycisk Edytuj. Należy wybrać co najmniej jedną szybkość transmisji bitów.
  • Format wideo. Należy określić format źródłowego wideo (NTSC lub PAL). Po zmianie szybkości klatek lub rozmiaru wideo na ustawienie niestandardowe format jest automatycznie ustawiany jako Niestandardowy.
  • Zezwalaj na przetwarzanie z przeplotem. Opcję tę należy wybrać, jeśli zawartość zawiera przeplot i zakodowane dane wyjściowe także mają go zawierać. (Należy również zaznaczyć opcję Zachowaj przeplot na karcie Przetwarzanie.)
  • Zezwalaj na wyjście o niekwadratowych pikselach. Opcję tę należy wybrać, jeśli wideo źródłowe używa kwadratowych pikseli (na przykład, jeśli źródło pochodzi z wideo cyfrowego) lub jeśli źródło wideo ma współczynnik proporcji inny niż 4:3, który ma zostać zachowany w zakodowanym wyjściu. Współczynnik proporcji można zmienić na karcie Rozmiar wideo.

Tematy pokrewne

  • Standardowe ustawienia dla systemów NTSC i PAL
  • Kodowanie CBR lub VBR – informacje
  • Optymalizowanie wideo i audio
  • Zachowywanie współczynnika proporcji pikseli w wideo


Kompresja

Należy wybrać miejsce docelowe oraz ustawienia wideo i audio, których chcesz użyć w tej sesji kodowania.

  • Miejsce docelowe, Audio i Wideo. Należy wybrać docelowy scenariusz dystrybucji. Wybór wpływa na dostępność ustawień opcji Audio i Wideo. Kombinacja wybranych opcji wpływa na ustawienia (na przykład tryb kodowania, stopień kompresji, kodery-dekodery, szybkość transmisji bitów i szybkość klatek) używane w sesji. Zbiór tych ustawień to profil. Aby dostosować profil, zaimportować go lub wyeksportować, należy kliknąć przycisk Edytuj.
  • Szybkości transmisji bitów. Zawiera listę aktualnie wybranych szybkości transmisji bitów. (W przypadku miejsc docelowych Archiwum plików i Pobieranie pliku wyświetlane jest ustawienie jakości wideo.) Jeśli opcja Serwer Windows Media jest zaznaczona w sekcji Miejsce docelowe, możesz kliknąć więcej niż jedną szybkość transmisji bitów w celu skonfigurowania sesji z różnymi szybkościami transmisji bitów.
  • Kodowanie dwuprzebiegowe. Wybierane automatycznie w zależności od miejsca docelowego wybranego dla sesji. Kodowanie dwuprzebiegowe można także wybrać, jeśli ma zostać skonfigurowana sesja kodowania dwuprzebiegowego ze stałą szybkością transmisji bitów (CBR). Należy pamiętać, że w niektórych przypadkach kodowanie dwuprzebiegowe jest nieodpowiednie.
  • Kompresja czasu. Należy wybrać tę opcję, aby przyspieszyć lub zwolnić zawartość podczas odtwarzania. Aby ustawić wartość przyspieszenia lub zwolnienia zawartości, lub usunąć pauzy z audio, należy kliknąć polecenie Właściwości. Nie można zastosować kompresji czasu do źródła zawierającego tylko wideo.

    Jeśli kompresja czasu używana jest razem z opcją Ogranicz według czasu trwania na karcie Wyjście, należy pamiętać, że ograniczenie stosowane jest w pliku wyjściowym, nie w źródle. W związku z tym plik wyjściowy może mieć mniejszą lub większą zawartość od oczekiwanej. Jeżeli na przykład ograniczysz plik wyjściowy do 30 minut, a następnie przyspieszysz odtwarzanie pliku 2 razy, plik wyjściowy będzie trwał 30 minut, ale będzie zawierał 60 minut zawartości.

Tematy pokrewne

  • Kodowanie jedno- i dwuprzebiegowe – informacje
  • Stosowanie kompresji czasu w zawartości


Źródła

Dodaj nowe źródła do bieżącej sesji kodowania, edytuj właściwości istniejących źródeł lub usuwaj źródła, których nie chcesz dołączyć do sesji.

  • Nazwa. Należy wpisać nazwę źródła. Kliknij przycisk Usuń, jeśli nie chcesz dołączać źródła do sesji. (Należy pamiętać, że sesja musi zawierać co najmniej jedno źródło.)
  • Źródło. Należy wybrać źródła (urządzenia, pliki lub oba), a następnie wybrać typ kodowanego źródła (wideo audio i skrypty). Jeśli kodujesz z urządzenia cyfrowego, urządzenie musi być włączone, w przeciwnym razie nie zostanie wyświetlone na liście urządzeń. Po przypisaniu urządzenia do źródła nie można użyć go dla innego źródła w sesji.
  • Na końcu. Jeśli sesja zawiera wiele źródeł, należy wybrać akcję, która ma nastąpić po osiągnięciu końca źródła. (Ta opcja dostępna jest tylko wtedy, gdy źródło jest plikiem z rozszerzeniem .avi, .wav, .wmv, .wma lub .mp3.) Można włączyć pętlę źródła, przeskoczyć do następnego źródła na liście po osiągnięciu końca źródła lub przeskoczyć do pierwszego źródła na liście po osiągnięciu końca źródła. Domyślnie kodowanie zatrzymuje się po osiągnięciu końca źródła.
  • Znacznik początkowy/końcowy (tylko źródła plików). Kliknij, aby określić, w którym miejscu pliku chcesz rozpocząć i zakończyć kodowanie.
  • Archiwizowanie. Jeśli kodowana jest emisja, wybrano archiwizację jej kopii i sesja zawiera wiele źródeł, należy wybrać opcję archiwizacji dla każdego źródła. Możesz na przykład archiwizować główne zdarzenie i wstrzymać archiwizację podczas przerywnika.

Źródła można dodać przed lub po rozpoczęciu kodowania. Jeśli chcesz zmienić kolejność wyświetlania źródeł w głównym oknie kodera, należy wybrać źródło, a następnie należy kliknąć przycisk strzałki w górę strzałka w górę lub strzałki w dół strzałka w dół.

Tematy pokrewne

  • Pobieranie źródła z pliku


Karta Kodowanie VBR w oparciu o jakość

Podczas kodowania VBR w oparciu o jakość można stosować poniższe ustawienia.

  • Format audio. Należy kliknąć poziom jakości, jaki chcesz zachować w zawartości audio. Ustawienie to wpływa także na częstotliwość próbkowania oraz na to, czy audio ma być odtwarzane przez głośniki mono czy stereo. Ustawienie wyższej jakości powoduje otrzymanie wyższej jakości audio, ale zwiększa rozmiaru pliku wyjściowego.
  • Rozmiar wideo. Należy wpisać rozmiar (w pikselach), jaki ma być używany dla kodowanego wideo. Można użyć liczb od 16 do 2000. Rozmiar klatki kodowanego wideo zostanie zmieniony w celu dopasowania do podanego rozmiaru. Aby dopasować rozmiar klatki do źródłowego wideo, należy zaznaczyć pole wyboru Taki sam jak wejście wideo.
  • Szybkość klatek. Należy wpisać liczbę klatek na sekundę (k/s) dla zawartości wideo. Ustawiana wartość opcji zależy od szybkości procesora komputera i kodowania wideo z dużą lub małą ilością ruchu. Wideo z dużą ilością ruchu jest zazwyczaj płynniejsze, jeżeli użyjesz większej szybkości klatek, ale większa szybkość klatek zwiększa ilość pracy, jaką musi wykonać procesor. Podane ustawienie oznacza maksymalną ilość klatek na sekundę. W zależności od czynników, takich jak rozmiar wideo i ustawienie jakości kodera-dekodera, rzeczywista ilość klatek na sekundę może być mniejsza.
  • Interwał klatek kluczowych. Należy wpisać liczbę sekund, która ma następować między klatkami kluczowymi. Wszystkie klatki pomiędzy klatkami kluczowymi to klatki różnicowe, które są o wiele mniejsze od klatek kluczowych, ale ich jakość jest niska. Po zwiększeniu okresu czasu pomiędzy klatkami kluczowymi rozmiar wideo (w bajtach) zmniejszy się, ponieważ używanych będzie mniej klatek. Po zmniejszeniu okresu czasu między klatkami kluczowymi rozmiar wideo zwiększa się. Interwał klatek kluczowych należy zwiększyć w przypadku zawartości ze statycznym tłem, na przykład filmów rysunkowych. Interwał klatek kluczowych należy zmniejszyć w przypadku zawartości z dużą ilością ruchu, na przykład relacji z wydarzeń sportowych.
  • Jakość wideo. Należy określić jakość obrazu, jaką chcesz zachować, wpisując wartość od 0 do 100. Podczas kodowania, jeśli jest to konieczne, szybkość transmisji bitów ustawiana jest tak, aby osiągnąć podany poziom jakości bez opuszczania klatek. Obecnie dostępnych jest 30 dyskretnych ustawień jakości, więc każdego ustawienia jakości dotyczy kilka poziomów jakości. Poniższe poziomy jakości dotyczą dyskretnych ustawień jakości: 1, 4, 8, 11, 15, 18, 22, 25, 29, 33, 36, 40, 43, 47, 50, 54, 58, 61, 65, 68, 72, 75, 79, 83, 86, 90, 93, 97 i 100. Liczby pomiędzy dwoma wartościami oznaczają to samo ustawienie jakości co mniejsza liczba. Na przykład 2 i 3 oznaczają to samo ustawienie jakości co 1.
  • Złożoność dekodera. Jeśli urządzeniem docelowym nie jest komputer, możesz określić kategorię złożoności kodowanej zawartości. Niektóre urządzenia obsługują tylko wybrane kategorie. (Więcej informacji zawiera dokumentacja urządzenia.) Należy zauważyć, że opcja Złożony jest przeznaczona do odtwarzania na komputerze. Zazwyczaj należy wybrać opcję Automatyczna, co umożliwia automatyczne wybranie prawidłowego ustawienia złożoności podczas kodowania.
  • Szybkość transmisji bitów skryptu. Należy wpisać szybkość transmisji bitów (w bitach na sekundę), która ma zostać użyta w skryptach. Wartość musi zawierać się w przedziale od 1000 b/s do 10000 b/s. W przypadku kilobajtów należy wpisać literę K.


Atrybuty

Atrybuty to zbiory opcjonalnych wpisów, zwanych także metadanymi, zawierające informacje na temat zawartości. Atrybuty zawarte są w kodowanym strumieniu i można je wyodrębnić, korzystając z narzędzi do przeszukiwania lub innych aplikacji utworzonych w oparciu o pakiet Microsoft Windows Media Format Software Development Kit (SDK). Atrybuty domyślne obejmują tytuł, autora, prawa autorskie i opis zawartości. Atrybuty te wyświetlane są, gdy zawartość jest odtwarzana w programie Windows Media Player lub w innym programie do odtwarzania utworzonym w oparciu o pakiet Windows Media Format SDK. Można tworzyć niestandardowe atrybuty, na przykład data edycji zawartości, nazwa producenta itd. Atrybuty niestandardowe nie są wyświetlane w programie Windows Media Player, ale można je wyodrębnić, korzystając z narzędzi do przeszukiwania lub innych programów utworzonych z wykorzystaniem zestawu Windows Media Format SDK.

Aby dodać atrybut, należy kliknąć przycisk Dodaj. Aby edytować lub usunąć atrybut, wybierz atrybut z listy, a następnie kliknij odpowiednio przycisk Edytuj lub Usuń.


Dodawanie szybkości transmisji bitów

Należy wpisać szybkość transmisji bitów w bitach na sekundę. Wpisz literę K w przypadku kilobitów, M w przypadku megabitów lub G w przypadku gigabitów. Należy pamiętać, że rzeczywista szybkość transmisji bitów będzie nieco większa od podanej liczby, ponieważ do szybkości transmisji bitów dodawany jest narzut.


Uwaga prawna

Informacje zawarte w tym dokumencie, w tym również adresy URL i inne odwołania do witryn sieci Web, mogą ulec zmianie bez powiadomienia. O ile nie zaznaczono inaczej, przykładowe firmy, organizacje, produkty, osoby i zdarzenia opisane w tym dokumencie są fikcyjne i istnienie jakiegokolwiek związku z rzeczywistymi firmami, organizacjami, produktami, osobami lub zdarzeniami nie jest zamierzone i nie powinno być zakładane. Za przestrzeganie wszelkich odpowiednich praw autorskich odpowiada użytkownik. Niezależnie od praw wchodzących w zakres praw autorskich, żadnej części tego dokumentu nie można powielać, przechowywać lub wprowadzać do systemów wyszukiwania informacji ani też przekazywać w żadnej formie lub za pomocą jakichkolwiek urządzeń (elektronicznych, mechanicznych, fotokopiujących, rejestrujących lub innych) w jakimkolwiek celu, bez pisemnej zgody firmy Microsoft Corporation.

Firma Microsoft może posiadać patenty, zgłoszenia patentowe, znaki towarowe, prawa autorskie lub inne prawa własności intelektualnej dotyczące treści tego dokumentu. Z wyjątkiem przypadków wyraźnie określonych w jakiejkolwiek pisemnej umowie licencyjnej firmy Microsoft, udostępnienie tego dokumentu nie jest równoznaczne z udzieleniem użytkownikowi jakichkolwiek licencji na wymienione patenty, znaki towarowe, prawa autorskie lub inną własność intelektualną.

© 2000-2002 Microsoft Corporation. Wszelkie prawa zastrzeżone.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 i Win32s są zastrzeżonymi znakami towarowymi lub znakami towarowymi firmy Microsoft Corporation, zarejestrowanymi w Stanach Zjednoczonych i/lub w innych krajach.

Nazwy rzeczywistych firm i produktów wymienionych w tym dokumencie mogą być znakami towarowymi ich odpowiednich właścicieli.


Dwuprzebiegowe kodowanie z urządzeń

Kodowania dwuprzebiegowego można użyć, gdy źródłem są urządzenia i wykonano jedną z poniższych czynności:

  • Włączono sterowanie urządzeniem
  • Wybrano kodowanie do pliku
  • Wybrano tymczasowe składowanie zawartości
  • Ustawiono listę EDL dla zawartości

Tematy pokrewne

  • Włączanie sterowania urządzeniem


Nowy profil

Zarządzanie usługodawcami licencji i tworzenie nowego profilu.

  • Dodaj lub Usuń. Kliknij, aby dodać lub usunąć.
  • Generuj. Po wybraniu dostawcy z listy, kliknij, aby utworzyć profil DRM.

obrazek „Uwaga” Uwaga

  • Profile są wydawane przez innych dostawców. Informacje udostępniane podczas tworzenia lub edycji profilu są przesyłane w Internecie.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości


Koder nie obsługuje transferu plików

Załadowany plik sesji został utworzony przez program transferu plików. Koder nie obsługuje transferu plików. Dlatego, aby zakodować zawartość za pomocą tego pliku sesji, należy użyć programu do transferu plików, w którym utworzono plik sesji.


Musisz wybrać opcję wyjścia

Zakodowaną zawartość należy zapisać do pliku lub emisji.

Tematy pokrewne

  • Opcje wyjściowe


Wpisywanie nazwy serwera

Należy wpisać prawidłową nazwę serwera Windows Media. Można użyć nazwy systemu netBIOS (network basic input/output system), adresu IP lub nazwy serwera w systemie DNS (Domain Name System).

Tematy pokrewne

  • Wypychanie strumienia z kodera


Standardowe ustawienia dla systemów NTSC i PAL

Poniższa tabela zawiera informacje o szybkościach klatek i rozmiarach wideo ze standardem NTSC.

Ustawienie | Możliwe wartości
Szybkość klatek w klatkach na sekundę (k/s) | 60; 30; 15; 10 i 7,5
Rozmiar klatki | 160 x 120 176 x 120 240 x 180 320 x 240 352 x 240 640 x 480 720 x 480

Poniższa tabela zawiera informacje o szybkości klatek i rozmiarach wideo ze standardem PAL.

Ustawienie | Możliwe wartości
Szybkość klatek w klatkach na sekundę | 50; 25; 12,5; 8,3 i 6,25
Rozmiar klatki | 176 x 144 192 x 144 288 x 216 352 x 288 384 x 288 720 x 576 768 x 576

Tematy pokrewne

  • Niestandardowe ustawienia kodowania – ogólne


Optymalizowanie wydajności

Dostępnych jest szereg opcji pozwalających uzyskać optymalną wydajność systemu podczas kodowania.

Tematy pokrewne

  • Uzyskiwanie optymalnej wydajności systemu


Karta kodowania VBR opartego na szczytowej szybkości transmisji bitów

Poniższe ustawienia stosowane są w profilu wykorzystującego kodowanie VBR oparte na szczytowej szybkości transmisji bitów.

  • Format audio. Należy kliknąć ustawienie zawartości audio. Ustawienie to określa docelową szybkość transmisji bitów audio, częstotliwość próbkowania oraz to, czy audio ma być odtwarzane przez głośniki mono czy stereo. Wyższa częstotliwość próbkowania oferuje audio wyższej jakości, ale wymaga większej przepustowości lub powoduje zwiększenie wartości rozmiaru pliku. Zazwyczaj użytkownik chce osiągnąć kompromis między szybkością transmisji bitów a częstotliwością próbkowania.
  • Szczytowa szybkość transmisji bitów audio. Należy wpisać szczytową szybkość transmisji bitów, która ma zostać użyta dla zawartości audio. Podczas kodowania koder określa jakość audio, którą można osiągnąć bez przekraczania szczytowej szybkości transmisji bitów.
  • Szczytowy rozmiar buforu audio. Należy wpisać maksymalny rozmiar buforu (w sekundach), przez jaką klient powinien oczekiwać przed otworzeniem zawartości zakodowanej ze szczytową szybkością transmisji bitów audio. W przypadku kodowania w celu odtwarzania na urządzeniu, należy wpisać rozmiar buforu w sekundach, odpowiadający rozmiarowi buforu urządzenia. Domyślny szczytowy rozmiar buforu to 3 sekundy. Aby uzyskać najlepsze wyniki, liczba ta powinna zawsze być równa lub mniejsza od rozmiaru bufora (w przypadku korzystania z kodowania CBR dla wideo) lub szczytowego rozmiaru bufora dla wideo (w przypadku korzystania z kodowania w oparciu o szczytową szybkość przesyłania bitów dla wideo).
  • Rozmiar wideo. Należy wpisać rozmiar (w pikselach), który ma zostać użyty dla zakodowanego wideo. Użyj liczb od 16 do 2000. Rozmiar klatki zakodowanego wideo zostanie zmieniony w celu dopasowania do podanego rozmiaru. Zaznacz pole wyboru Taki sam jak wejście wideo, aby dopasować rozmiar klatki źródłowego wideo.
  • Częstotliwość klatek. Należy wpisać liczbę klatek na sekundę (k/s) dla strumienia wideo. Ustawiana wartość opcji zależy od prędkości procesora komputera i kodowania wideo z dużą lub małą ilością ruchu. Wideo z dużą ilością ruchu jest zazwyczaj płynniejsze, jeśli używana jest większa szybkość klatek, ale konieczna jest większa ilość pracy, jaką musi wykonać procesor. Podane ustawienie oznacza maksymalną ilość klatek na sekundę; rzeczywista wartość może być niższa.
  • Interwał klatek kluczowych. Należy wpisać liczbę sekund, która ma następować między klatkami kluczowymi. Wszystkie klatki pomiędzy klatkami kluczowymi to klatki różnicowe, które są o wiele mniejsze od klatek kluczowych, ale ich jakość jest niska. Po zwiększeniu okresu czasu pomiędzy klatkami kluczowymi rozmiar wideo (w bajtach) zmniejszy się, ponieważ używanych będzie mniej klatek. Po zmniejszeniu czasu między klatkami kluczowymi rozmiar wideo zwiększy się. Interwał klatek kluczowych należy zwiększyć w przypadku zawartości ze statycznym tłem, na przykład filmów rysunkowych. Interwał klatek kluczowych należy zmniejszyć w przypadku zawartości z dużą ilością ruchu, na przykład relacji z wydarzeń sportowych.
  • Szybkość transmisji bitów (średnia). Należy wpisać średnią szybkość transmisji bitów (w bitach na sekundę), która ma zostać użyta dla części wideo zawartości. Wpisz literę K w przypadku kilobitów, M w przypadku megabitów lub G w przypadku gigabitów. W dowolnym momencie szybkość transmisji bitów może przekroczyć średnią szybkość transmisji bitów, ale ogólna szybkość transmisji bitów nie przekroczy szybkości średniej.
  • Szczytowa szybkość transmisji bitów wideo. Należy wpisać szczytową szybkość transmisji bitów wideo (w bitach na sekundę), która ma zostać użyta dla zawartości wideo. Podczas kodowania koder określa jakość obrazu, jaką można osiągnąć bez przekraczania szczytowej szybkości transmisji bitów. W przypadku kodowania do odtwarzania na urządzeniu, na przykład odtwarzaczu DVD, należy wpisać prędkość odczytu urządzenia.
  • Szczytowy rozmiar buforu wideo. Należy wpisać maksymalny rozmiar buforu (w sekundach) określający czas, przez jaki klient powinien oczekiwać przed odtworzeniem zawartości zakodowanej ze szczytową szybkością transmisji bitów wideo. W przypadku kodowania w celu odtwarzania na urządzeniu, należy wpisać rozmiar buforu w sekundach, odpowiadający rozmiarowi buforu urządzenia. Domyślny szczytowy rozmiar buforu to 5 sekund.
  • Złożoność dekodera. Jeśli urządzeniem docelowym nie jest komputer, można określić kategorię złożoności kodowanej zawartości. Niektóre urządzenia obsługują tylko wybrane kategorie. (Więcej informacji zawiera dokumentacja urządzenia.). Należy zwrócić uwagę, że opcja Złożony jest przeznaczona do odtwarzania na komputerach. Zazwyczaj należy wybrać opcję Automatycznie, co umożliwia automatyczne wybranie prawidłowego ustawienia złożoności podczas kodowania.
  • Szybkość transmisji bitów skryptu. Należy wpisać szybkość transmisji bitów (w bitach na sekundę), która ma zostać użyta w skryptach. Wartość musi zawierać się w przedziale od 1000 b/s do 10000 b/s. W przypadku kilobajtów należy wpisać literę K.


Ustawienia szybkości transmisji bitów, strumienie zawierające tylko audio

Poniższe ustawienia stosowane są tylko do profilu kodującego strumienie zawierające tylko audio.

Należy kliknąć ustawienie zawartości audio. Wyższa częstotliwość próbkowania oferuje audio wyższej jakości, ale wymaga większej przepustowości.

Dla audio kodowanego z wykorzystaniem kodowania VBR opartego na szczytowej wartości szybkości transmisji bitów, należy wpisać szczytową szybkość transmisji bitów (w bitach na sekundę), która ma zostać użyta do zawartości audio. Wpisz literę K w przypadku kilobitów, M w przypadku megabitów lub G w przypadku gigabitów. Podczas kodowania koder określa jakość audio, jaką można osiągnąć bez przekraczania szczytowej szybkości transmisji bitów. Należy także wpisać ustawienie szczytowej wartości buforu.


Ustawienia szybkości transmisji bitów, karta CBR

Następujące ustawienia można stosować w profilu wykorzystującym kodowanie CBR.

  • Format Audio. Kliknij ustawienie zawartości audio. To ustawienie określa docelową szybkość transmisji bitów audio, częstotliwość próbkowania oraz czy audio ma być odtwarzane na głośnikach monofonicznych lub stereofonicznych. Wyższa częstotliwość próbkowania oferuje wyższą jakość audio, ale wymaga większej przepustowości, a pliki wynikowe pliki są większe. W idealnej sytuacji użytkownik chce uzyskać równowagę między szybkością transmisji bitów i częstotliwością próbkowania. Należy pamiętać, ze strumień audio musi współdzielić dostępną przepustowość sieci z innymi strumieniami wideo lub skryptów.
  • Rozmiar wideo. Należy wpisać rozmiar (w pikselach), jaki ma być stosowany w kodowanym wideo. Można używać liczb z zakresu od 16 do 2000. Rozmiar klatki kodowanego wideo zostanie zmieniony, aby dopasować go do określonego rozmiaru. Należy zaznaczyć pole wyboru Taki sam jak wejście wideo, aby dopasować do rozmiaru klatki źródła wideo.
  • Szybkość klatek. Należy wpisać liczbę klatek na sekundę (k/s) w strumieniu wideo. Liczba, jaką można nadać tej wartości, zależy od szybkości procesora w komputerze oraz od tego, czy kodowane jest wideo z dużą czy z małą ilością ruchu. Wideo z dużą ilością ruchu odtwarzane jest płynniej, jeśli użyta zostanie wyższa szybkość klatek, ale wyższa szybkość klatek spowoduje większe obciążenie procesora. Określone ustawienie oznacza maksymalną szybkość klatek na sekundę. W zależności od czynników, takich jak ustawienie rozmiaru wideo i dostępna przepustowość, uzyskana szybkość klatek może być niższa.
  • Interwał klatek kluczowych. Należy wpisać liczbę sekund, jakie mają rozdzielać klatki kluczowe. Wszystkie klatki pomiędzy klatkami kluczowymi to klatki różnicowe, które są mniejsze od klatek kluczowych, ale jakość obrazu jest w nich niższa. Jeśli czas pomiędzy klatkami kluczowymi zostanie zwiększony, rozmiar wideo (w bajtach) zostanie zmniejszony, ponieważ użytych zostanie mniej klatek kluczowych. Jeśli czas pomiędzy klatkami kluczowymi zostanie zwiększony, rozmiar wideo zwiększy się. Interwał klatek kluczowych należy zwiększyć dla zawartości z nieruchomym tłem, jak kreskówki. Interwał klatek kluczowych należy zmniejszyć dla zawartości z dużą ilością ruchu, jak transmisje sportowe.
  • Szybkość transmisji bitów wideo. Należy wpisać szybkość transmisji bitów (w bitach na sekundę), jaka ma być użyta w części wideo zawartości; litera K oznacza kilobity, M oznacza megabity, a G oznacza gigabity. Liczba nie obejmuje zapasu wymaganego dla ruchu w sieci. Należy pamiętać, że strumień wideo musi współdzielić dostępną przepustowość sieci z innymi strumieniami audio lub skryptów.
  • Rozmiar buforu. Należy wpisać liczbę sekund, przez jaką zawartość ma być przechowywana przed rozpoczęciem kodowania. Większy bufor daje zawartość o wyższej jakości, ale wymaga więcej pamięci. Podczas kodowania zawartości proces kodowania jest opóźniany o czas określony w buforze; zawartość jest także opóźniana o ten sam czas podczas przesyłania strumieniowego do odtwarzacza. Podczas przesyłania strumieniowego emisji zawartość odtwarzana w odtwarzaczu uruchamiana jest po zdarzeniu na żywo w odstępie czasu określonym w opcji Rozmiar buforu. Domyślnym rozmiarem buforu jest 5 sekund.
  • Płynność obrazu wideo. Należy wpisać liczbę z zakresu od 0 do 100, gdzie 0 oznacza najpłynniejszy obraz, a 100 oznacza najczystszy. Wideo jest płynne, gdy obiekty przesuwają się gładko z jednego położenia do innego na ekranie, a krawędzie obiektów nie są poszarpane. Wideo jest czyste, gdy obrazy i ruch są dobrze zdefiniowane i wyraźnie zarysowane. Wraz ze zwiększeniem czystości, wideo jest mniej płynne. Należy pamiętać, że zwiększenie czystości może mieć wpływ na szybkość klatek w zależności od wideo. Jeśli na przykład wideo zawiera dużo ruchu, to zwiększenie czystości może zmniejszyć liczbę klatek na sekundę.
  • Złożoność dekodera. Jeśli docelowym urządzeniem sprzętowym nie jest komputer, można określić kategorię złożoności kodowanej zawartości. Niektóre urządzenia sprzętowe obsługują tylko pewne kategorie. (Więcej informacji znajduje się w dokumentacji urządzenia.) Należy zwrócić uwagę, że opcja Złożony jest przeznaczona do odtwarzania na komputerze. Typowo należy wybrać opcję Automatycznie, co pozwoli na automatyczny wybór ustawienia właściwej złożoności podczas kodowania.
  • Szybkość transmisji bitów skryptu. Należy wpisać szybkość transmisji bitów (w bitach na sekundę), jaka ma być stosowana dla skryptów. Wartość musi być w przedziale od 1000 b/s do 10000 b/s. Litera K oznacza kilobity.


Dodatki

Wybierz dodatki transformacji, które chcesz zastosować do źródeł w sesji.

  • Lista źródeł. Wybierz źródło, do którego chcesz dodać dodatek. (Wymagane tylko w sesjach z wieloma źródłami.)
  • Typ dodatku transformacji. Kliknij przycisk Audio lub Wideo, aby wyświetlić aktualnie zainstalowane i zarejestrowane na kodującym komputerze dodatki transformacji.
  • Zarejestruj. Kliknij ten przycisk, aby wyświetlić okno dialogowe Rejestrowanie/wyrejestrowanie dodatków transformacji. W oknie dialogowym wyświetlone są dodatki transformacji, które są aktualnie zainstalowane na kodującym komputerze. Przed użyciem dodatku należy go zarejestrować. Aby zarejestrować dodatek, zaznacz go w oknie dialogowym i kliknij przycisk OK.
  • Przenieś w prawo i Przenieś w lewo. Kliknij przycisk Przenieś w prawo (>>), aby dodać dodatek do źródła. Kliknij przycisk Przesuń w lewo (<<), aby usunąć dodatek ze źródła. Za pomocą przycisków ze strzałkami w górę i w dół zmień kolejność, w jakiej dodatki będą stosowane w źródle.
  • Konfiguruj. Kliknij ten przycisk, aby edytować właściwości zaznaczonego dodatku.

    obrazek „Ostrożnie” Ostrożnie

    • W oknie dialogowym Rejestrowanie/wyrejestrowanie dodatków transformacji wyświetlone są wszystkie dodatki transformacji, które są dostępne na kodującym komputerze. Niektóre dodatki mogą być nieodpowiednie dla kodera i mogą generować nieoczekiwane wyniki, jeśli zostaną zastosowane w koderze.


Zabezpieczenia

Należy wybrać, czy do ochrony zawartości ma być używane zarządzanie prawami cyfrowymi czy znak wodny osadzony w zawartości.

  • Użyj DRM, aby chronić zawartość przed nieautoryzowanym użyciem. Zaznacz tę opcję, aby chronić zawartość za pomocą technologii DRM. Przed użyciem DRM musisz utworzyć profil.
  • Profil DRM. Kliknij profil DRM, który ma zostać użyty dla zawartości kodowanej w tej sesji. Profil DRM zawiera klucz, identyfikator klucza, adres URL do serwera licencjonującego, identyfikator zawartości oraz inne informacje potrzebne do szyfrowania zawartości. Jeśli nie masz jeszcze profilu lub chcesz go utworzyć, kliknij przycisk Nowy. Aby usunąć istniejący profil, kliknij przycisk Usuń. Aby edytować profil, kliknij przycisk Edytuj. Aby użyć profilu umieszczonego na innym komputerze, kliknij przycisk Importuj, a następnie wpisz ścieżkę do profilu, którego chcesz użyć. Aby udostępnić profil innemu komputerowi, kliknij przycisk Eksportuj, a następnie wpisz odpowiednią ścieżkę.
  • Identyfikator klucza. Identyfikator klucza wyświetlany jest tylko podczas tworzenia profilu. Nie możesz edytować tego identyfikatora. Identyfikator klucza znajduje się w pliku nagłówka, który jest dołączony do kodowanej zawartości. Odtwarzacz odczytuje plik nagłówka, odszukuje identyfikator klucza i przekazuje go do licencjonującego serwera. Jeśli licencjonujący serwer rozpozna identyfikator klucza, wyda licencję.
  • Osadź znak wodny. Zdecyduj, czy zastosować znak wodny w strumieniu audio, strumieniu wideo, czy w obu strumieniach. Znak wodny osadza w strumieniu cyfrowy odcisk. Ta informacja może być dekodowana przez różne narzędzia programowe w celu uzyskania takich informacji, jak prawa autorskie, warunki użytkowania i autor. Znak wodny wskazuje autentyczność zawartości audio lub wideo. Musisz uzyskać i zarejestrować dodatek innej firmy, aby pracować ze znakami wodnymi. Informacje dotyczące uzyskiwania dodatku znaku wodnego znajdują się w witrynie sieci Web firmy Microsoft.
  • Konfiguruj. Kliknij tę opcję, jeśli używany dodatek znaku wodnego wymaga określenia pliku konfiguracji.

Tematy pokrewne

  • Korzystanie z zarządzania prawami cyfrowymi w celu ochrony zawartości


Hasło emisji

Aby uzyskać dostęp do serwera Windows Media, należy wpisać nazwę użytkownika oraz hasło. Te poświadczenia należy podać podczas wypychania strumienia do serwera Windows Media, na którym włączony jest dodatek uwierzytelniania.


Publikowanie plików

Jeśli użytkownik jest gotowy do rozpoczęcia przesyłania strumieniowego zawartości po ukończeniu kreatora, może zapisać pliki bezpośrednio w udostępnionym folderze. W przeciwnym wypadku może zapisać pliki w lokalizacji tymczasowej. Następnie przed rozpoczęciem przesyłania strumieniowego może skopiować pliki do udostępnionego folderu.


Zabezpieczenia emisji

Program Windows Media Encoder obsługuje do pięciu bezpośrednich połączeń z emisją. Można ograniczyć dostęp do emisji, określając, które adresy IP mogą uzyskać dostęp lub które nie mogą uzyskać dostępu do emisji.

Tematy pokrewne

  • Ograniczanie dostępu do emisji


Rejestrowanie dodatku

W tym oknie dialogowym wyświetlane są dodatki dostępne na komputerze. Nie wszystkie dodatki są odpowiednie dla programu Windows Media Encoder.

Aby zarejestrować dodatek, należy mieć na komputerze kodującym uprawnienia administracyjne.


Panel skryptów

Panel skryptów zawiera regulatory, których można używać do wstawiania poleceń skryptów, takich jak podpisy (ciągi tekstowe), adresy URL lub niestandardowe polecenia skryptów, podczas kodowania do strumienia. Wpis Liczba skryptów w panelu monitorowania zwiększa się z każdym wstawionym skryptem.


Zabezpieczenia emisji

Program Windows Media Encoder zezwala na maksymalnie pięć połączeń bezpośrednich podczas emisji. Można określić, który komputer lub zakres komputerów będzie mieć dostęp do kodera. Aby zezwolić lub odmówić dostępu pojedynczym komputerom, należy użyć adresów IP. Aby zezwolić lub odmówić dostępu zakresowi komputerów, należy użyć maski IP.

Podczas ograniczania dostępu do emisji według adresu IP można określić zarówno adres protokołu Internet Protocol w wersji 6 (IPv6), jak i w wersji 4. Protokół IPv6 jest najnowszą wersją protokołu Internet Protocol i został zaprojektowany do obsługi gwałtownie zwiększającej się puli unikatowych adresów IP. Protokół IPv6 zwiększa rozmiar adresu IP z 32 bitów do 128 bitów w celu obsługi większej liczby poziomów hierarchii adresów i większej liczby adresowalnych węzłów. Aby uzyskać więcej informacji dotyczących protokołu IPv6, zobacz stronę protokołu IPv6 w witrynie sieci Web firmy Microsoft.

W zakresie adresów każdy bit maski IP jest porównywany z odpowiednim bitem adresu IP. Gdy wartość w masce wynosi 1 odpowiedni bit w adresie IP jest dołączany do zakresu. Gdy wartość w masce wynosi 0, dopuszczalna jest dowolna wartość. Na przykład w notacji dziesiętnej, jeśli adres IP na liście jest równy 134.123.123.20, a maska jest równa 255.255.255.0, to wszystkie adresy IP od 134.123.123.0 do 134.123.123.255 są dołączane do zakresu. Jeśli maska równa jest 255.255.255.128, to wszystkie adresy IP od 134.123.123.0 do 134.123.123.127 są dołączane do zakresu. Jeśli określono nieprawidłową maskę, adres IP jest ignorowany.


Karta Wydajność

Jeśli podczas kodowania ciągle przekraczane są możliwości komputera kodującego, można użyć ustawień na tej karcie, aby zapewnić pomyślne kodowanie. Można wybrać, czy większy nacisk zostanie położony na lepszą wydajność, czy na lepszą jakość zawartości. Ustawienie lepszej jakości powoduje większe obciążenie procesora; ustawienie lepszej wydajności powoduje mniejsze obciążenie procesora. Te ustawienia mają zastosowanie tylko do sesji z użyciem koderów-dekoderów Windows Media Video 9 i Windows Media Video 8.1.

Może być konieczne wykonanie kilku eksperymentów, aby osiągnąć równowagę między jakością a wydajnością. Aby powrócić do ustawień używanych przez kodery-dekodery, należy zaznaczyć pole wyboru Użyj domyślnych .

Zmiany można zastosować do wszystkich sesji lub można zmienić ustawienia tylko dla bieżącej sesji.

obrazek „Uwaga” Uwaga

  • Aby podczas kodowania osiągnąć optymalną wydajność, można użyć wielu innych opcji.

Tematy pokrewne

  • Osiąganie optymalnej wydajności systemu


Karta Serwer

Na karcie Serwer wyświetlane są informacje o stanie serwera Windows Media podczas wypychania strumienia przez serwer Windows Media. Wyświetlana jest również liczba odtwarzaczy aktualnie połączonych z serwerem Windows Media (tylko dla strumieni emisji pojedynczej).

Aby odbierać informacje o stanie, należy mieć uprawnienia dostępu do usługi Windows Media Services przez interfejs DCOM.


Zaawansowane

Zmienianie nazwy kodera, używanie niestandardowych rozmiarów pakietów, tworzenie kodu czasowego lub włączanie tymczasowego przechowywania zawartości.

  • Nazwa identyfikacyjna. Nazwa kodera jest przypisywana automatycznie, ale jeśli jest to niezbędne, można ją edytować. Nazwa jest używana, aby pomóc w rozróżnianiu koderów, gdy na jednym komputerze uruchomiono wiele wystąpień kodera.
  • Maksymalny rozmiar pakietu. Określa, w bajtach, maksymalny rozmiar pakietów protokołu User Datagram Protocol (UDP), które są przesyłane strumieniowo w sieci. To ustawienie ma zastosowanie do zawartości o pojedynczej szybkości transmisji bitów, która jest przesyłana strumieniowo z serwera Windows Media. Domyślny maksymalny rozmiar pakietu to 16 000 bajtów. Rzeczywisty rozmiar pakietu jest obliczany podczas kodowania. Jeśli wykryto, że pakiety są podczas emisji gubione lub fragmentowane, można użyć ustawienia Niestandardowe, aby zmniejszyć maksymalny rozmiar pakietów. Należy zauważyć, że podczas kodowania zawartości audio z bardzo wysokimi szybkościami transmisji bitów maksymalny rozmiar pakietu może zostać przekroczony.
  • Kod czasowy. Należy wybrać tę opcję, jeśli planowane jest włączenie wyszukiwania na poziomie klatek. Można zabezpieczyć kod czasowy już istniejący w wideo źródłowym lub utworzyć kod czasowy. Jeśli tworzony jest kod czasowy, można wpisać czas rozpoczęcia kodu czasowego w formacie gg:mm:ss:kl; ponadto można wybrać format wideo źródłowego, taki jak NTSC.
  • Tymczasowo przechowaj zawartość na dysku twardym. Podczas przechwytywania z urządzeń do pliku dane mogą być przechwytywane do lokalizacji tymczasowej, jeśli kodowanie nie nadąża za procesem przechwytywania. Należy zaznaczyć pole wyboru Przechwyć najpierw na dysk twardy, a następnie koduj, aby w jednym kroku przechwycić wszystkie dane, a w następnym je zakodować. Zapobiega to gubieniu klatek podczas przechwytywania bardzo dużej ilości danych. Kodowanie jest zatrzymywane, gdy zostanie osiągnięta minimalna ilość wolnego miejsca na dysku. Przechowywanie jednej godziny danych przechwyconych z urządzenia cyfrowego wymaga około 15 GB miejsca na dysku. Kodowanie zostanie automatycznie zatrzymane po osiągnięciu małej ilości miejsca na dysku.

Tematy pokrewne

  • Kodowanie lub archiwizacja emisji do pliku


Karta Ogólne

Następujące opcje mają wpływ na wygląd głównego okna kodera. Wiele z tych opcji jest wybieranych domyślnie, ale można je zmienić, jeśli jest to potrzebne.

  • Automatycznie pokaż panele wymagane dla bieżącej sesji. Należy wybrać tę opcję, aby w oknie głównym kodera wyświetlać panele na podstawie wyborów dokonanych w Kreatorze nowej sesji. Należy usunąć zaznaczenie tego pola wyboru, jeśli do wybierania wyświetlanych paneli ma być używane menu Widok w głównym oknie kodera.
  • Zmień rozmiar okna głównego, jeśli obraz jest zbyt powiększony. Należy wybrać tę opcję, aby zmienić rozmiar głównego okna kodera w celu dopasowania powiększanych widoków Wejście i Wyjście. Jeśli zaznaczenie tego pola wyboru zostanie usunięte, to wyświetlane obrazy mogą być częściowo zaciemnione. To ustawienie nie ma wpływu na rozmiar kodowanego obrazu.

    obrazek „Uwaga” Uwaga

    • Duże rozmiary wyświetlania wejścia i wyjścia mogą negatywnie wpływać na wydajność procesora podczas kodowania.
  • Minimalizuj okno kodera w sesji przechwytywania ekranu. Należy wybrać tę opcję, aby koder był automatycznie minimalizowany podczas przechwytywania ekranu. Podczas sesji kodowania do pliku przywrócenie okna kodera powoduje jego wstrzymanie. W przypadku sesji emisji kodowanie jest kontynuowane, nawet jeśli okno kodera zostanie przywrócone.
  • Ostrzegaj przed zatrzymaniem kodowania. Należy wybrać tę opcję, aby podczas każdego zatrzymywania kodera był wysyłany komunikat ostrzeżenia.
  • Wyświetl okno dialogowe Nowa sesja przy uruchamianiu. Należy wybrać tę opcję, aby podczas uruchamiania kodera wyświetlane było okno dialogowe. Okno dialogowe Nowa sesja umożliwia wybranie kreatorów lub szablonów pomagających w konfigurowaniu sesji.
  • Wyświetl okno dialogowe Wyniki kodowania po zakończeniu kodowania. Należy wybrać tę opcję, aby okno dialogowe Wyniki kodowania było automatycznie wyświetlane po zakończeniu kodowania. Jeśli zaznaczenie tego pola wyboru zostanie usunięte, wyniki można przeglądać, klikając polecenie Wyniki kodowania w menu Widok.
  • Pokaż wszystkie porady. Należy kliknąć ten przycisk, aby wyświetlić porady.
  • Domyślny format wideo. Umożliwia wybranie formatu wideo (NTSC lub PAL), który będzie używany podczas kodowania. Ta opcja ma zastosowanie do ustawień miejsca docelowego, audio i wideo, które są wyświetlane na karcie Kompresja w panelu właściwości.


Przetwarzanie

Należy wybrać opcje, które będą używane do wstępnego przetwarzania zawartości w celu poprawy jakości kodowanej zawartości.

Wideo

  • Brak. Należy kliknąć tę opcję, jeśli do zawartości nie będą stosowane filtry przetwarzania wstępnego. Tej opcji należy używać, jeśli zawartość jest już w formacie wyświetlania skanowania progresywnego.
  • Bez przeplotu. Należy kliknąć tę opcję, aby rozdzielić pola przeplotu w wideo na pojedyncze klatki, co spowoduje, że wideo będzie wyświetlane bardziej płynnie.
  • Inverse telecine. Jeśli wideo źródłowe poddano działaniu funkcji telecine, należy kliknąć tę opcję, aby usunąć klatki dodane przez funkcję telecine. Należy kliknąć opcję Automatyczne, aby wzór funkcji telecine był wykrywany automatycznie. Jeśli wzór funkcji telecine w zawartości jest spójny, należy na liście kliknąć ustawienie odpowiadające pierwszej klatce wideo źródłowego.
  • Zachowaj przeplot. Należy kliknąć tę opcję, jeśli wideo źródłowe jest z przeplotem i przeplot ma pozostać w kodowanym wideo.
  • Wykryj. Należy kliknąć tę opcję, jeśli nie wiadomo, czy zawartość jest z przeplotem, czy została poddana działaniu funkcji telecine. Koder analizuje zawartość i zaleca zastosowanie odpowiedniego filtru.
  • Format pikseli. Należy wybrać format pikseli, który będzie używany.
  • Przerzuć w pionie. Należy wybrać tę opcję, jeśli wideo jest obrócone o 180 stopni. Wideo obrócone o 180 stopni mogło powstać w wyniku użycia do utworzenia pliku .avi urządzenia przechwytującego, które nie spełnia całkowicie publikowanych wymagań technicznych. Wideo obrócone o 180 stopni jest zazwyczaj związane z formatem pikseli używanym przez urządzenie.

Audio

  • Optymalizacja kodera-dekodera głosu. Jeśli używany jest koder-dekoder Windows Media Audio 9 Voice, można zoptymalizować jego zachowanie, sprawdzając, czy zawartość składa się tylko z głosu, czy zawiera również muzykę. Jeśli zawartość składa się z głosu i muzyki, należy kliknąć opcję Audio ze wzmocnieniem głosu. Podczas kodowania koder-dekoder automatycznie używa odpowiedniego algorytmu w celu zoptymalizowania kodowania zawartości (głos lub muzyka). Można też utworzyć plik definicji optymalizacji, który optymalizuje dźwięk, wskazując w pliku miejsca, w których muzyka rozpoczyna się i kończy.
  • Audio 5.1. Jeśli kodowana jest zawartość z audio wielokanałowym, kanały są automatycznie redukowane do dwóch kanałów w celu odtwarzania na głośnikach stereo. Można jednak użyć ustawień w tym obszarze, aby dostosować dystrybucję redukcji. Określane wartości nie są wartościami bezwzględnymi. Zamiast tego ogólny dynamiki kanałów będzie normalizowany w celu uniknięcia zniekształceń. Wpisywane wartości muszą zawierać się pomiędzy 0 a -144 decybeli. (Ta opcja nie jest dostępna podczas kodowania audio 7.1.)

Tematy pokrewne

  • Optymalizowanie wideo i audio
  • Pobieranie źródła z plików wielokanałowego audio


Panel Źródła

W panelu Źródła wyświetlane są wszystkie źródła bieżącej sesji. Podczas kodowania można przełączać się między źródłami, klikając przycisk odpowiedniego źródła.


Karta Statystyka

Na karcie Statystyka wyświetlane są informacje o wejściowych oraz wyjściowych danych audio i wideo, łącznie z liczbą kanałów oraz częstotliwością próbkowania, szybkością klatek, liczbą usuniętych klatek, średnią szybkością transmisji bitów, itp.


Zatrzymywanie podczas kodowania drugiego przebiegu

Bieżąca sesja kodowania używa kodowania dwuprzebiegowego. Jeśli kodowanie zostanie teraz zatrzymane, drugi przebieg nie zostanie zakończony a zakodowana zawartość może być nieprawidłowa.

Tematy pokrewne

  • Kodowanie jedno- i dwuprzebiegowe – informacje


Generowanie pliku formatu strumieniowego

Plik formatu strumieniowego zawiera informacje, które są potrzebne odtwarzaczowi do dekodowania strumienia multiemisji. Ten plik należy wygenerować tylko wtedy, gdy rozpoczęcie kodowania jest planowane po zainicjowaniu przez serwer połączenia z koderem. (Jeśli kodowanie rozpoczęto zanim serwer zainicjował połączenie z koderem, nie jest konieczne generowanie tego pliku, ponieważ serwer automatycznie wykryje format strumieniowego.) Po wygenerowaniu pliku należy dostarczyć go administratorowi serwera. Częścią konfigurowania anonsu multiemisji dla emisji jest identyfikacja przez administratora serwera pliku zawierającego formaty strumieniowe dla strumienia. Plik formatu strumieniowego ma rozszerzenie nazwy pliku .asf.

Tematy pokrewne

  • Umożliwianie klientom ściągania strumienia z kodera


Panel skryptów

Ten panel jest wyświetlany, gdy sesja została skonfigurowana do korzystania ze źródła typu skrypt. Aby dodać skrypty do sesji, należy użyć karty Źródła w panelu właściwości.

Tematy pokrewne

  • Wstawianie poleceń skryptu


Panel Źródła

Ten panel jest wyświetlany, gdy została skonfigurowana sesja kodowania z wieloma źródłami. Podczas kodowania można przełączać się między źródłami.


Karta Kodowanie VBR w oparciu o jakość

Następujące ustawienia są stosowane do profilu używającego kodowania VBR w oparciu o jakość.

  • Format audio. Należy kliknąć opcję dla zawartości audio. To ustawienie określa szybkość transmisji bitów audio docelowego, częstotliwość próbkowania oraz to czy audio jest przeznaczone do odtwarzania na głośnikach mono, czy stereo. Wyższa częstotliwość próbkowania zapewnia wyższą jakość audio, ale większy rozmiar pliku.
  • Rozmiar wideo. Należy wpisać rozmiar (w pikselach) kodowanego wideo. Można użyć liczb z zakresu od 16 do 2000. Rozmiar klatek kodowanego wideo zostanie zmieniony, tak aby pasował do określonej wartości. Aby używany był rozmiar klatek wideo źródłowego, należy zaznaczyć pole wyboru Taki sam jak wejście wideo.
  • Szybkość klatek. Należy wpisać liczbę klatek na sekundę (k/s) dla strumienia wideo. Liczba wpisana dla tej wartości jest zależna od szybkości procesora komputera oraz od tego, czy kodowane jest wideo z dużą ilością ruchu, czy z małą. Wideo z dużą ilością ruchu zazwyczaj wygląda płynniej, jeśli używana jest większa szybkość klatek, ale większa szybkość klatek zwiększa liczbę operacji, które musi wykonać procesor. Określone ustawienie przedstawia maksymalną liczbę klatek na sekundę; rzeczywista liczba klatek może być mniejsza.
  • Interwał klatek kluczowych. Należy wpisać liczbę sekund rozdzielającą klatki kluczowe. Wszystkie klatki między klatkami kluczowymi są klatkami różnicowymi, które są znacząco mniejsze od klatek kluczowych, ale mają gorszą jakość. Jeśli czas między klatkami kluczowymi zostanie zwiększony, rozmiar wideo (w bajtach) będzie mniejszy, ponieważ zostanie użytych mniej klatek kluczowych. Jeśli czas między klatkami kluczowymi zostanie zmniejszony, zwiększy się rozmiar wideo. Interwał klatek kluczowych należy zwiększać dla zawartości o statycznym tle, takiej jak kreskówki. Interwał klatek kluczowych należy zmniejszać dla zawartości z dużą ilością ruchu, takiej jak wydarzenia sportowe.
  • Szybkość transmisji bitów wideo (średnia). Należy wpisać średnią szybkość transmisji bitów (w bitach na sekundę), która będzie używana dla części wideo zawartości. Należy wpisać literę K dla kilobitów, M dla megabitów lub G dla gigabitów. W dowolnym punkcie szybkość transmisji bitów może przekroczyć średnią szybkość transmisji bitów, ale ogólna szybkość transmisji bitów nie przekroczy średniej szybkości transmisji bitów.
  • Złożoność dekodera. Jeśli urządzeniem docelowym jest urządzenie sprzętowe inne niż komputer, można określić kategorię złożoności kodowanej zawartości. Niektóre urządzenia sprzętowe obsługują tylko pewne kategorie. (Więcej informacji znajduje się w dokumentacji urządzenia.) Należy zwrócić uwagę, że opcja Złożony jest przeznaczona do odtwarzania na komputerach. Zazwyczaj należy zaznaczyć opcję Automatyczna, która powoduje, że prawidłowe ustawienie złożoności jest automatycznie wybierane podczas kodowania.
  • Szybkość transmisji bitów skryptu. Należy wpisać szybkość transmisji bitów (w bitach na sekundę), która będzie używana dla skryptów. Wartość musi należeć do zakresu od 1 000 b/s do 10 000 b/s. Dla kilobitów należy wpisać literę K.


Adresy URL do plików

Pliki muszą być dostępne dla odtwarzaczy, więc muszą być umieszczone na serwerze sieci Web i dostępne za pomocą protokołu HTTP lub umieszczone we współużytkowanym folderze i dostępne za pomocą ścieżki UNC. Jeśli zostanie określona ścieżka UNC, odtwarzacz musi mieć uprawnienia odczytu do ścieżki.


Panel wideo

Na Panelu wideo wyświetlana jest kodowana zawartość. W zależności od typu typu zawartości można dostosować wyświetlanie w celu pokazania zawartości przed kodowaniem, zawartości zakodowanej lub obu. Zawartości przed zakodowaniem nie można wyświetlić w obszarze Wejście, jeżeli:

  • Przechwytywany jest ekran.
  • W plikach .avi lub .mpg stosowana jest funkcja usuwania przeplotu.
  • Jako wejście wykorzystywany jest plik Windows Media z rozszerzeniem .wmv lub .asf i ma on te same właściwości co wyjście.
  • Używana jest karta przechwytywania wideo, która nie obsługuje podglądu obrazu przed zakodowaniem.
  • Zawartość jest tymczasowo przechowywana na dysku twardym, a przed zakodowaniem zawartość jest przechwytywana na dysk twardy. (Jednakże zawartość zostanie wyświetlona po zatrzymaniu kodowania.)

Zawartości zakodowanej nie można wyświetlić w obszarze Wyjście, jeżeli:

  • Używany jest profil przechwytywania ekranu lub profil nieskompresowany.
  • Jako wejście wykorzystywany jest plik Windows Media z rozszerzeniem .wmv lub .asf i ma on te same właściwości co wyjście.
  • Używane jest kodowanie dwuprzebiegowe i koder jest w pierwszym przebiegu.
  • Zawartość jest tymczasowo przechowywana na dysku twardym, a przed zakodowaniem zawartość jest przechwytywana na dysk twardy. (Jednakże zawartość zostanie wyświetlona po zakończeniu kodowania.)

obrazek „Uwaga” Uwagi

  • Wideo wyświetlane w obszarze Wyjście może mieć widoczny efekt „bloków”, większy niż podczas odtwarzania w programie Windows Media Player, ponieważ odtwarzacz zawiera filtry usuwające ten efekt, które nie są dostępne w obszarze Wyjście. Ten efekt jest normalny i nie wpływa na jakość zakodowanej zawartości.
  • Podczas kodowania wideo z wieloma szybkościami transmisji bitów można zmienić jakość każdej szybkości transmisji bitów, wybierając odpowiednią szybkość transmisji bitów w polu Podgląd.


Wyniki kodowania

To okno dialogowe zawiera informacje o sesji, której kodowanie właśnie się zakończyło, w tym typ kodowania (emisja lub kodowanie do pliku), wybrane urządzenia oraz oczekiwane i średnie szybkości transmisji bitów osiągnięte podczas sesji kodowania. Wyniki dają użytkownikowi natychmiastowe informacje o przebiegu sesji, co jest przydatne podczas testowania. Użytkownik może na przykład zdecydować o zmniejszeniu szybkości transmisji bitów po przejrzeniu szybkości transmisji bitów w sesji kodowania. Można zmienić konfigurację sesji, zakodować zawartość ponownie, a następnie wyświetlić podsumowane wyniki w celu określenia, czy wymagana szybkość transmisji bitów została osiągnięta.


Dziennik błędów

Lista zawiera komunikaty o błędach otrzymywane podczas sesji kodowania wraz z datą i godziną wystąpienia. Aby wyczyścić dziennik ręcznie, kliknij przycisk Wyczyść teraz. Dziennik błędów jest czyszczony po każdym ponownym uruchomieniu kodera i jest dostępny tylko przez interfejs użytkownika kodera.


Praca z Kreatorem anonsu multiemisji

Jeśli zawartość jest dostarczana w postaci strumienia multiemisji przez serwer z uruchomionym programem Windows Media Services, należy utworzyć plik anonsu (.asx) i informacji o multiemisji (.nsc). Aby utworzyć pliki na komputerze kodującym, użytkownik musi mieć uprawnienia dostępu do usługi Windows Media Services przez interfejs DCOM. Jeśli użytkownik nie ma uprawnień dostępu do usługi, należy utworzyć pliki na serwerze.

Jeśli zawartość jest dostarczana w formie strumienia emisji pojedynczej przez serwer Windows Media, nie trzeba tworzyć anonsu.